kmosx3: FIXED—Help Viewer crashes or shows blank window

Version 1
Last Modified: Feb 22, 2011 7:37 PM
Disclaimer: Apple does not necessarily endorse any suggestions, solutions, or third-party software products that may be mentioned in the topic below. Apple encourages you to first seek a solution at Apple Support. The following links are provided as is, with no guarantee of the effectiveness or reliability of the information. Apple does not guarantee that these links will be maintained or functional at any given time. Use the information below at your own discretion.


This is a common bug in Panther. The solution to this problem is simple though — From thexlab.com Troubleshooting Help Viewer FAQ:

Go to Users/Your_Name/Library/Preferences and delete the following files:
com.apple.help.plist
com.apple.helpui.plist
com.apple.helpviewer.plist

Next go to Users/Your_Name/Library/Caches and delete the folder:
com.apple.helpui

For further information please consult this article: Mac OS X 10.2, 10.3: Mac Help Viewer unexpectedly quits

Do you want to provide feedback on this User Contributed Tip or contribute your own? If you have achieved Level 2 status, visit the User Tips Library Contributions forum for more information.

It is also not the only "fix" for Help Viewer quitting unexpectedly ("crashing" as you write). A comprehensive collection of fixes for all Help Viewer problems can be found in my See my Troubleshooting Help Viewer FAQ.

I suspect the rash of these may be due to something related to the update to Help Viewer distributed with the Security Update 2005-05-24. This also introduced a new bug in Help Viewer, also cited in my FAQ.

Good luck!

Dr. Smoke
Author: Troubleshooting Mac® OS X

---
Note: The information provided in the link(s) above is freely available. However, because I own The X Lab?, a commercial Web site to which some of these links point, Apple's Advertising Policy requires I include the following disclosure statement with this post:

I may receive some form of compensation, financial or otherwise, from my recommendation or link.
Thanks Gulliver!

Worked beautifully for me. In my case I was experiencing extended delays and occasional complete non arrival, although I've never had a "help viewer crash" .

Mr Smoke, I'd suggest you amend your web site to include Gulliver's suggestions concerning slow Help operations and non-appearance of topis (with an appropriate credit to him, of course!)

At present you only have these solutions listed to resolve problems with help viewer quitting. Help Viewer has never quit for me , but its been very slow, or , for some apps, simply never got there. Gulliver's suggestion has completely resolved this issue for me.

Cheers

Rod
Rod,

thanks a lot! Reading a post like your's from a Level 4 tastes like honey.
Just one more thing - before doing the above, check out ~/Library/Documentation/Help and /Library/Documentation/Help and scan the list clicking on each item to see if you have any orphaned aliases there (from apps you've trashed).

I went through the above steps with a malfunctioning Help Viewer and found they fixed the problem exactly once - until the Help Viewer was reinvoked.

Trashing aliases before doing the above made the Help Viewer stable again on my system.
HI, Rod.

My FAQ now covers this, but your suggested attribution is unnecessary since my discovery of the real cause of the performance issue was independent of this, and my FAQ's recommendation to delete the same files predates this thread by nearly a year.

For improved performance, you don't need to delete all the files, just one, and it is likely only to help in 10.3.5: the 10.3.5 Update appears to have included an updated Help Viewer that fixed another bug introduced by the Security Update 2004-05-24, also discussed in my FAQ.

Good luck!

Dr. Smoke
Author: Troubleshooting Mac® OS X
Gulliver64: I hope that Apple recognizes your helpfulness and the degree to which it contributes to satisfaction among Mac users.
Hi, having same problem, but can't get the fix to work. Tried: Go to YourHome > Library > Preferences and delete the following files:
com.apple.help.plist
com.apple.helpui.plist
com.apple.helpviewer.plist
Then go YourHome > Library > Caches and delete this folder
com.apple.helpui folder.
Weird though, i don not have the com.apple.helpui.plist under preferences, just the other two.

I can get other apps to show their help function, but not Mac help for os x. Also, last night when i tried to clone my HD, it hung on the machelp file, twice. Something up there. Any ideas,
Hi,

I've had this same problem before, followed your advice, and it seemed to solve the problem. However, the problem has reoccurred, several times. Each time I delete the files you reference in your e-mail, and it clears the problem.

Why do those files return? Is there anyway to stop them from returning, or will this be a constant maintenance requirement while running panther?

Thanks for your help.
Hi, I tried deleting all the files recommended, two times. i don not have file called com.apple.helpui.plist though to delete. Just the other two. Could that be the problem? Also, i ran a script last night to clone my HD, and it stuck on the Machelp.help file. I had to delete this file to get the machine to run. Now i don't have this file.Any ideas on how to fix this?

Thanks. I can help to work on other apps, itunes, etc. Just not the Mac help for the machine.

MJ 
Matthew,

I suggest you reinstall Help Viewer from the install CD 1.

Download Pacifist from versiontracker.com, launch it, open the install package from the install CD, look for Help Viewer and choose to reinstall.
The problem is not the presense of those file (they are there when it works, too), but with their corruption. Somehow, some help topic or another causes an error in the files from which Help cannot recover. Since it crashes without creating a crash log, I can only assume that the program just exits of its own accord and does not create a hardware exception. Since it seems to exit after finding a bad file, you'd think it could notify the user. Since it is "Help" afterall, and now "Help" is dead, one would think some message like "copy the following files to your desktop and try HELP again. It that works, then you may safely move them to the trash and empty the trash. If not, Bwahahahaha."

Ed
Tried, don't have the file: com.apple.helpui.plist. it is not there.
That's the last file created. I've seen it absent after HELP starts failing; then deleted it and the others, but not the cache file. HELP still failed, but the helpui plist was absent, though the others were there. So I deleted them again, then remembered about the cache file, deleted that, too, and then HELP ran correctly. The helpui file was back again in its usual spot.

Ed