AppleWorks for the modern day, a migration tip

Version 6
Last Modified: Feb 2, 2012 8:36 AM

Some questions people have about AppleWorks moving to modern Macs are answered here:

 

1. Does AppleWorks work on Intel Macs? Yes.

 

2. Does AppleWorks work on Lion (Mac OS X 10.7)?  Not directly.

Conversion to compatible formats (mentioned in question 7 below) before installing Lion, or attaching a bootable external hard drive and installing Snow Leopard or earlier on it and installing Appleworks, is required to ensure your documents remain compatible when you upgrade to Lion.

Snow Leopard installation though is not possible for Macs released new later than July 20, 2011.  Note, some were released new earlier than that date, however were sold new after that date.   To tell the difference, go to Apple menu -> About This Mac -> More Info and look for the Machine ID, and in some cases the processor, release name, and speed are needed to be known:

 

Mac Mini 5,x and later only run Lion and later.  Mac Mini 4,x and earlier can run Snow Leopard with at least 1 GB of RAM (that's greater than 768MB of RAM).

MacBook Pro 13" Core 2.4, 2.8 Ghz only run Lion and later, 13" 2.3 & 2.7 can run Snow Leopard, and can 7,x and earlier Machine IDs.

MacBook Pro 15" "Late 2011"* only run Lion and later, 15" MacBook Pro "Early 2011" can run Snow Leopard, and can 7,x and earlier Machine IDs.

MacBook Pro 17" 2.4 & 2.5 Ghz can only run Lion and later.  2.2 & 2.3 Ghz can run Snow Leopard and earlier.

Mac Pro 5,1 and earlier can run Snow Leopard.

MacBook with no Air and no Pro on the screen as of 11/30/2011 can all run Snow Leopard with at least 1 GB of RAM.

MacBook Air 4,x and later can't run Snow Leopard, while 3,x and earlier with at least 1 GB of RAM can run Snow Leopard.

iMac 12,1 i3 can't run Snow Leopard, while the 12,x i5 and i7 can run Snow Leopard, and the iMac 1,1 through 11,x can run Snow Leopard with at least 1 GB of RAM.

 

* The release names Early and Late can be gotten by plugging the serial number of the machine in

https://selfsolve.apple.com/agreementWarrantyDynamic.do

 

One other possibility, though it isn't one many might think of, you can install Windows on your Mac with Lion.    For options for installing Windows, check the Windows software community, to enquire which is the best option for you.   Apple did release Appleworks for WIndows.   It runs on:

 

A Pentium Intel-based PC running Windows

95/98/Me/XP or Windows 2000
32MB RAM
QuickTime 4.1.2 or later
Microsoft Internet Explorer 5.0 or later


This would allow you to have continued use of Appleworks, until you are able to migrate all your data to Lion compatible versions, without having to reinstall Snow Leopard.  Options for running Windows on a Mac are shown in this tip.  The Windows version of Appleworks is not available for sale from the Apple retail stores any longer.  Finding a legal copy may be cost prohibitive, however, depending on your needs and if a different alternative is not practical, you may want to consider it.

 

3. Does AppleWorks work with Mac OS X 10.6.8 and earlier? Yes.

 

4. Does AppleWorks come with Mac OS X retail? No.

 

5. How to install AppleWorks if you erase and install Mac OS X? Use the restore CDs that came with your Mac if it is a PowerPC Mac Mini (with 2 USB ports as opposed to 4 in the rear), PowerMac G5, G4, or G3 iMac, eMac, or iBook, following the restore directions or using an AppleWorks 6.2.9 retail installer CD. Note the license agreement restrictions on the CD used.

 

Also, OS X support was added with AppleWorks 6.2 sometime in late 2001. Most install disks from then & later will install in OS X. For example, the separate AppleWorks installer included with a G3/600 Late 2001 iBook has an OS X-aware installer for AppleWorks 6.2 with an updater to 6.2.2.

 

6. If I have Appleworks 6.0 through 6.2.7, how do I make it work with Mac OS X? Run the 6.2.9 updater. For some versions of Mac OS X, the recent items folder in your Users -> Documents -> AppleWorks data needs to be emptied to avoid unexpected quits.
Note AppleWorks 6.2.4, 6.2.7 & 6.2.9 all work & are stable in OS X. Some recommend not using 6.2.7 as it was very buggy. But if you need to open any ClarisWorks 4 or earlier files, you need to use 6.2.4 or 6.2.7. AppleWorks 6.2.9 returns an I/O error with about half of those files.

 

7. Are there Intel & Lion Mac native software titles that I can substitute for AppleWorks?

 

iWork (Version 9.1 is Lion compatible) - takes care of spreadsheet, presentation, and word processing functionality.

 

EazyDraw (version 4.0 for Lion) - is able to replace drawing functionaity without some table features found in Appleworks Draw. Ask Eazydraw's author if you think such an object may not be able to be read.

 

Color It (Rosetta compatible, not available yet for Lion), MacGimp (version 2.6.11 for Lion), and GraphicConverter (version 7 for Lion) are all popular alternatives for Paint functionality.

 

A database exported as tab-delimited text can be imported to Filemaker Bento (version 4.0.4 for Lion) or numerous other database programs. You may also want to check out Filemaker Pro (version 8.5v2, 11.03 for Lion).