iTunes 10.5.1 doesn't work with 10.6?  Do I need to upgrade to 10.7 Lion?

Version 1
Last Modified: Dec 2, 2011 7:16 AM

No.    

Chances are what happened is your Quicktime got out of date.  The good news is Quicktime 7.6.6 is available for 10.6.3 and later. 

 

Backup your data at least twice before installing anything.  And ensure all your software is known to work with the software you are installing.

Ask in the forum if you are unsure how. 

 

You can get the Quicktime software from:

 

http://support.apple.com/kb/DL923

 

iTunes currently only needs Quicktime 7.6.4 or later according to:

 

http://support.apple.com/kb/DL1426

 

If you are running an older version of 10.6, the update to 10.6.3 is here:

 

http://support.apple.com/kb/DL1017

 

And 10.6.8 is below if you want the last version of Mac OS X that doesn't require Lion:

 

http://support.apple.com/kb/DL1399

 

Lastly, if you want to know if Lion is for you, check this user tip:

 

https://discussions.apple.com/docs/DOC-2465