Skip navigation

Apple Cinema Display 23" - Blank Screen, "short-long-short" LED code

190177 Views 344 Replies Latest reply: Apr 1, 2014 11:36 AM by hncl RSS
1 2 3 ... 23 Previous Next
lebungleski Calculating status...
Currently Being Moderated
Jul 18, 2009 7:03 PM
Hello everyone.
This sounds like something of an epidemic... My Apple Cinema 23" HD Display (bought Dec. 2007) hasn't been turning on after a power outage hit our area last week.

The Computer and Display were OFF when the outage occurred. Everything was plugged into a surge suppressor. Everything ELSE plugged in to the suppressor is fine (including my Mac CPU)... but not the monitor.
It’s not dead-dead…. It’s a blank screen but there IS a morse-code flash on the LED (short-long-short). According to Apple Support’s LED Translation, it SHOULD be something to do with the power adaptor. The adaptor IS correct… a 90 watt… but just in case I bought ANOTHER 90w adaptor brick. I plugged the monitor to the new brick. THE RESULT WAS THE SAME.

I’ve tried power cycling, I’ve tried plugging it into different outlets, I’ve tried connecting to other computers. The same LED result remains.

And, yes, of course, I’ve got no Apple Support, and from what I read in similar posts, outside-the-warranty repairs could hit around $400. I REFUSE!

For now I have a Samsung monitor from Costco. It’s not bad, but it’s not the Apple monitor with its awesome color-fidelity.

I've read some other posts with the same problem (LED blink code and all) elsewhere but haven't got a solid answer.
I wonder… has anyone else incurring this same problem (with the same LED flashing deal) tried to use a 150-WATT adaptor brick? I would try this myself, but I’m currently financially unable (and personally unwilling) to throw more cash at this problem unless I know it’ll fix it.
Mac OS X (10.5.7)
  • Travattack Level 1 Level 1 (20 points)
    I just got this problem today. I dismantled one of the edit suites where I work and when I put it back together again one of the monitors started giving me the short-long-short flashing code. I KNOW the display was working before I took it apart, and I know I have put it together in the correct manner.

    Now, what is weird is that the second monitor is fine, and when I swap power adaptors, the second monitor is STILL fine, even when using what is supposedly a bad adaptor. This leads me to believe that the adaptor is fine, but for some reason the screen doesn't want to accept it.

    Can anyone help with this?
    Mac Pro, Mac OS X (10.5.5), 2 x 3Ghz Quad-Core Intel Xeon, 8GB RAM
  • tgapen Calculating status...
    I recently started having the same problem with a 23-inch ACD after I moved the G5 it was hooked up to. I have two of these and both of the 90-watt power adapters work on one of them but neither one works on the problematic display. I also have a 30-inch ACD and the 150-watt power adapter will work on the problem display but after taking the 150 off and putting the 90-watt back on, same problem. This was all working fine previous to moving it. And no, it didn't get hurt in the move. It was handled very gently.
    Dual 1.8 G5, 4GB, Mac OS X (10.5.7), 24 inch iMac, PowerBook T550 768MB, PowerBook Pismo 512MB, iPod 30GB, iPhone 4GB
  • matthew_00001 Calculating status...
    I have the same problem. I was able to temporarily borrow a 150W and it did work fine. Plugging back in the 90W I found it didn't work. After buying a new 90W adapter, I have the same problem. Extremely frustrating!
  • ssandon Calculating status...
    Hi lebungleski,

    Same problem here - same monitor, same age. Fuse tripped in the house all sockets died. Monitor on at the time but also into power surge protection. Monitor would not restart, same short-long-short LED code. Took it to local Apple store today, spoke to "genius". Tested with a new 90W brick, no difference. Tested with 150W for 30" worked fine but they could not supply as they have to swap out like for like apparently. Over here in the UK it's £400 to replace the monitor.
    Mac Pro, Mac OS X (10.5.8)
  • tgapen Level 1 Level 1 (10 points)
    I agree that purchasing the 150w adapter is cheaper than what Apple would require to repair or replace, and you can find these on eBay and elsewhere. However, I'm no electrician and I would worry that the 150w adapter would provide too much juice and fry the display in a short period of time.
    Am I wrong?
    Dual 1.8 G5, 4GB, Mac OS X (10.5.7), 24 inch iMac, PowerBook T550 768MB, PowerBook Pismo 512MB, iPod 30GB, iPhone 4GB
  • jhames Calculating status...
    i'm not so sure about buying a used 23" anymore... decided to do some research on this display to see if it had any problems before i made the purchase, and I'm glad i did. has anyone searched and found problems with people using 150w over time?
    MBP Santa Rose, Mac OS X (10.5)
  • tgapen Level 1 Level 1 (10 points)
    As mentioned above, I've had this short-long-short issue for a few weeks now with a 23" ACD that's about 5 years old. After seeing this link http://support.apple.com/kb/HT2803?viewlocale=en_US I think it's safe to use a 150w adapter so I found one on eBay for $99. It works fine and if Apple says it's safe then I'm not worried about it. I wish there was an easier way to fix this but $99 is better than whatever Apple would charge to fix it or buying a new one.
    I have three of these by the way and a 30" and they're all older displays now and I've not had any other trouble with them. I still think they're awesome.
    If I have any other issues I'll report back.
    Dual 1.8 G5, 4GB, Mac OS X (10.5.7), 24 inch iMac, PowerBook T550 768MB, PowerBook Pismo 512MB, iPod 30GB, iPhone 4GB
  • thepikey Calculating status...
    Hey,

    I have also suffered from a power cut in my place and had some trouble getting my Mac Pro up and running. When I eventually managed to get it onto the network the 23" Cinema Display stayed off just showing 3 blinks (short - long - short). I googled the problem only to find this support page from apple:
    http://support.apple.com/kb/HT2811?viewlocale=en_US
    This says that the blinking is showing a power issue. I then used the power supply on another 23" Cinema Display and it worked fine so I have taken a gamble and just bought the 150W power supply from the 30".

    I will let you know if this works but I would be interested to learn how many people have been able to resolve this issue from upgrading from the 90W to the 150W power supply?

    Thanks for the info.
    2 X 3GHz Quad-Core Intel Xeon & 23" Cinema Display, Mac OS X (10.5.7), 23" Cinema Display not doing so well!
  • Matt Leader Calculating status...
    Had the same problem (posted in a similar thread). Used my 23" for 2+ years on my iMac without problems. Upgraded several weeks ago to Mac Pro with 30" cinema plus my 23" as 2nd monitor. When I plugged the 23" into the new system, got the same short-long-short LED codes.
    Read the support information from Apple where they indicate that the 150w PS is compatable with the 20, 23 and 30" cinema displays. Bought one of these and the monitor fired right up and has since been working fine.

    So far so good...

    Matt
    Mac Pro Quad Core 2.66, iMac 24 <> MBP 17" <> iEverything (Pods, phones,...), Mac OS X (10.5.8)
  • thepikey Level 1 Level 1 (0 points)
    The 150W power adapter arrived this morning and once i plugged it in the display is working perfectly
  • lefter Calculating status...
    Hi all!

    As mentioned on the title of this topic *I HAD THE EXACT SAME PROBLEM* with my 23" Cinema Display...

    Before the failure, the monitor *WAS IN PERFECT CONDITION* (trust me when I comment this, my whole life is in front of a monitor)

    *THE PROBLEM SHOWED UP THE DAY I MOVED THE MONITOR TO AN OTHER OFFICE* (???). Please note that *I TOOK EXTRA CARE WHEN I MOVED THE MONITOR*, besides, when something costs around 1K you owe to.

    *I TRIED AN 150W ADAPTER ON IT AND WORKED FINE!!!* Just like before.

    But since *IT WAS UNDER GUARANTY* I sent it to the local distributor who eventually *REPLACED IT WITH A "NEW" ONE*, which after remarks from my side it turned out it wasn't "new" but re-manufactured by Apple (off course, he guarantied me the parts in it, where brand new and had 0 hours of usage).

    In my question to the technical representative of Apple *"WHAT WAS WRONG WITH MY MONITOR"*, he answered me that *THE INVERTER WAS FAULT*.

    After that I questioned him *"WHY MY MONITOR MANAGED TO WORK WITH THE 150W ADAPTER?"*, he answered me that *THE EXTRA CHARGE OF THE 150W ADAPTER WAS ABLE TO "EXCITE" SUCCESSFULLY THE FAULTY INVERTER IN ORDER TO WORK* and that *IT WAS A MATTER OF MONTHS FOR THE MONITOR TO FAIL AGAIN*.

    That's my story... I hope it may help some of you... Personally I can't have an opinion on the matter, since I'm not a technician. The only thing on which I can comment is that *A 1K MONITOR SHOULD BE WAY MORE DURABLE AND TOLERANT WHEN YOU TRANSFER IT AROUND (if that cause the problem of course)*
    Windows XP Pro
  • Michael Pitogo Level 1 Level 1 (35 points)
    I have two Cinema HD displays that both went bad one with short-short-long and the other recently with short-long-short. The short-short-long would power up but half the screen would go dim. The top half of the CCFL would cut out. The code from Apple says bad backlight. The other with short-long-short would not power up with the 90w power supply. I decided to make one that works from two bad ones. I opened both-not very hard to do of you don't have a fear of it, and moving some aluminum-my guess would be on the short-long-short display the control board went bad. So from the monitor that had the bad backlight circuit (likely the inverter board) I took the control board out of it and swapped it out into the display with the good backlight but confused control board. Well after about half an hour of work, I fired it up and boom its working again! The control board may have just needed a 150W power supply who knows. The swap made one good working monitor and the other one broken with short-long-short control board and short-short-long inverter board.

    Yay, I least I have one and its long out of warranty. What is sad in all of this? My 20" ACD late 2003 era purchased with the first gen MP G5 is still rocking it and much better in image quality. These LG displays are pure junk, too bad there's no way to get a refund on crap. I don't mind spending the money on good quality products but the Aluminum 23" Cinema HD is the worst.
    Mac OS X (10.6)
1 2 3 ... 23 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.