Skip navigation
This discussion is archived

Apple Remote Desktop 3.3.1 Client update broke Screen Sharing

19849 Views 29 Replies Latest reply: Jan 9, 2010 6:39 AM by James Rothschild RSS
1 2 Previous Next
scottx Level 1 Level 1 (0 points)
Currently Being Moderated
Aug 22, 2009 8:30 AM
I installed the Apple Remote Desktop 3.3.1 Client update when prompted by Software Update. I have never used Apple Remote management but use Screen Sharing all the time. The update successfully completed but now when I connect to my Mini from my PowerBook I get the Screen Sharing window but it is black and flashes intermittently, but always returns to black. There is no error message to indicate that it is failing to connect. I tried to control the cursor and it is non-responsive. This behavior did not change with a restart of both the Mini and the PowerBook and turning off Apple Remote Management had no effect. Any thoughts?

BTW... I CAN connect to the Mini with Jaduu VNC on my iPhone (?)
PowerBook Pro & Mac Mini, Mac OS X (10.5.8), iPhone 3.0
  • miflo Calculating status...

    I installed the update on two Macs. I have the problem that the update seems to have a damaged signature. Thus the firewall keeps permanently asking me if I want to allow incoming network connections for "". I tried to reinstall it using the download version of the client update from Apple's website.It did not help on both Macs. Clicking "yes" in the firewall dialog does not help. The next time boot OS X (10.5.8) the firewall messages appears again. When I use screen sharing, then the messages pops up approx. every 30 seconds on the client Mac. Can someone help me?
    Mac OS X (10.5.8), Apple Remote Desktop Client 3.3.1
  • SteveMcGregor Calculating status...
    I have installed the update too and now the VNC is slow and when something in the screen updates to many times the linux vnc client freeze. Anyone knows how to revert to the previous version?
    Mac Mini, Mac OS X (10.5.8)
  • pkmusic Calculating status...
    Remote Desktop 3.3 admin seems really slow too - but that could be the client. I will know for sure tomorrow. I'd like to downgrade if I could.
    Intel Xserver, Mac OS X (10.5.6)
  • twood99 Level 1 Level 1 (0 points)
    Similar issues on my computers as well. Screen sharing worked fine between work and home until this update. Rebooting the computers corrected the issues on the home network, but access from work is still not functioning. Home computer shows up in the sidebar when at work, but cannot connect for screen or file sharing.

    Also on the home network, Mocha VNC on the iPhone only loads about 10% of a screen and then freezes. This previously worked without issues prior to the update. If anyone know how to rollback the Remote Desktop update, please post. Thanks.
    MacBook Pro and Mac Mini, Mac OS X (10.5.8)
  • roblight Level 1 Level 1 (0 points)
    Ditto. Screen Sharing is BROKEN after applying Apple's updates.
    MacBook Pro, Mac mini (x2), Apple TV, iPhone 3G (x2), Mac OS X (10.5.7)
  • roblight Level 1 Level 1 (0 points)
    I've noticed that turning off "adaptive quality" and "full quality" on allows screen sharing to work albeit SLOWLY.

    Please fix, Apple!
    MacBook Pro, Mac mini (x2), Apple TV, iPhone 3G (x2), Mac OS X (10.5.7)
  • Adam Nelson Calculating status...
    Same problem here. Updated all my machines to 3.3.1 and 10.5.8. None of them display anything except a black screen when using ARD or Screen Sharing.
    MacBook Pro (Late 2008), Mac Mini (Early 2009), iMac (Early 2006), MacBook (Mid 2007), Mac OS X (10.5.8)
  • p-c-s Calculating status...
    I have the same problem. 1 mac Mini, two 15" MacbookPros running 10.5.8 and recently upgraded to ARD 3.3.1.

    Upgrading to ARD 3.3.1 totally disabled our screen sharing on the Mini (MBP's get a black screen when connecting to the Mini, Mini will connect to MBP's OK, MBP's connect to MBP's OK).

    Chicken of the VNC on the MBP's and VNClite from my iPod touch DOES allow viewing the Mini, so this is definitely an OSX screen sharing issue.

    Apple, please patch/fix this! Screen sharing is essential to controlling our Mini, which is our HTPC as well as our music server!

    As an alternative, can I restore the MBP's from an earlier Time Machine update and get rid of 3.3.1? The only problem is how do I make sure not to lose all the files and word docs I've created since then?
    MBP 15" 2.2Ghz, 2.4Ghz & 1.6Ghz Mac Mini, Mac OS X (10.5.8)
  • ÜberMacHead Calculating status...
    Add me to this list. Environment has a Core2 Duo iMac (which runs ARD Admin) and a Core Duo Mac mini, all on 10.5.x. Updated the mini to 10.5.8 and ARD (and a few other updates that were available, like iPhoto) and suddenly couldn't observe or control the mini from my iMac. Ran similar updates on my iMac and the problem persists. Tried deleting preference files, resetting ARD Admin, multiple restarts, and got nothing.

    I seem to be able to do anything else via ARD Admin, however. I can copy, delete, restart, send messages, etc to the mini. It's only observing and controlling that I can't do. Depending on what I've tried most recently I get either a black window with a "Reconnecting" message (which stays on screen forever) or an "authorization failed" message.
    24" iMac 2.8GHz 4GB/320GB, Mac OS X (10.5.6), Accessories by Apple, Matias, Microsoft, Epson, Dymo, Sony and others. w00t!
  • Gareth Domingo Calculating status...
    Screen Sharing seems to be working fine for me between both mine and my friend's Macbooks. I will update you if I figure out why. We both installed the Apple Remote Desktop 3.3.1 Client as well.
    Aluminium MacBook 2008, n/a
  • twood99 Level 1 Level 1 (0 points)
    Seems that mine has magically fixed itself. I shut it down for four days while away and turned it back on to find that it works again. No idea what happened. Maybe something on Back to My Mac was fixed on Apples end.
    15" MacBook Pro and Mac Mini, Mac OS X (10.5.8)
  • nwelch Calculating status...
    Elementary School Teacher with 41 eMacs having same problem. I tell my students to be patient with my mistakes, but I'm not feeling all that patient with Apple right now.
  • MikeBH Calculating status...
    OK, same story here. I have 3 intel MacMinis. For whatever reason, software update had two of them install the Remote Desktop Client (even though I've never used ARD), and one didn't. The one without the update can screen share and connect to the other two and vice versa. But the two that had the update applied can neither connect to nor share the screen of the other mini that was updated!

    Does anyone know how to remove this update? Where did the installed file(s) go? Can they be manually deleted?
    Intel MacMini, Mac OS X (10.6)
  • MikeBH Level 1 Level 1 (0 points)
    Actually, I just found the software update log files, and the client update was installed on all 3 minis. So I now have absolutely no idea why 1 machine works fine and the other 2 don't. The 2 that don't work aren't even allowing connections between each other. But they will connect to and allow connections from the third mini that's not having any problems. Arrgh!
1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.