Skip navigation
This discussion is archived

Installation went great, but now the internet doesn't work

30780 Views 77 Replies Latest reply: Jan 20, 2010 4:21 PM by Misterpp11 RSS
  • Fozzie Drive Calculating status...
    After installing Snow Leopard my internet has slowed down to nothing! Im not a technical wizz kid, i just want to use the internet as I was doing before... 'Safari can't find the server' is the message I keep getting! Its very annoying. Some pages open, but then you click on a link and it wont open, it takes too long!

    WHATS GOING ON!!??!! It is driving me mad. So many kind people have made suggestion as to how to rectify the problem but none seem to work.

    Is it possible to go back to the old operating system and use the same 10.6 disc at a later date when the issues have been sorted out?
    Macbook Pro, Mac OS X (10.6)
  • Statman1 Level 1 Level 1 (5 points)
    Another one with issues...on my macbook. I have done all of the suggestions (new location, remove and readd, remove system config preferences, re-install, etc.) Mine sees the network fine, but when it goes to assign an IP, it won't assign it automatically (tried resending dhcp lease, etc.). So back to leopard on that mac...LOL
    MacBook, Mac Pro, iMac, Mac OS X (10.6), 10.5.8 on Macbook
  • wil nelson1 Level 2 Level 2 (315 points)
    My Airport connection was not maintaing an IP address as noted the the Network Pane of System Preferences. Making a "New Location" in the Network Preferences fixed the problem. See System Preferences Help for instructions on how to do this as it is a rather simple task. There is also another solution listed for trashing a number of preferences that may do the job.
    15AL PB , MacBook, iMac, Mac OS X (10.6)
  • desulliv Calculating status...
    I've done just about everything suggested above. Internet connection works for awhile, but then disconnects. I have to go into network connections and go over the setup again, then it works or awhile and we go through the same dance again. Very annoying and my first occasion to curse a macintosh operating system.
    Macbook Pro, Mac OS X (10.6)
  • jhuettner Calculating status...
    Hello everyone,
    Had the same problem here, but I got it fixed. Do this:

    - open "System Preferences"
    - select "Network"
    - click on "Location" drop-down menu
    - select "edit locations"
    - create a new one (name it whatever you like, e.g. "10.6" or so
    - obviously select Airport to the left (and remove everything else you need)
    - select the network in the "Network Name" drop-down menu to the right
    - hit "apply" on the lower right corner

    Worked for me. Obviously some kind of bug in the current release.

    Best wishes,
    JH
    MacBook Pro 2.5 (2008), Mac OS X (10.6)
  • virlich Level 1 Level 1 (10 points)
    A clean install do the work, now my computer get internet from my Airport Basestation
    macbook, Mac OS X (10.5.4)
  • wil nelson1 Level 2 Level 2 (315 points)
    Many suggestions on this forum appear to only work for a short period of time. So in System Preferences>Network pane I made a new location with only AirPort in it and I keep it open on the desktop. Now the Airport IP is not being lost but internet connection only works for a short time. So I toggle Airport in the Network Pane to renew connection.
    15AL PB , MacBook, iMac, Mac OS X (10.6)
  • desulliv Level 1 Level 1 (0 points)
    Ultimately, my solution was to upgrade the firmware on my Actiontec GT701-WG. So far, so good. After three hours, no disconnects.
    Macbook Pro, Mac OS X (10.6)
  • smcgee30 Calculating status...
    In reply to Alexander; the solution that is working for most of us who upgraded to Snow Leopard is to do this;

    System preferences > Networks.
    At the top of the screen is a location pull down menu if you have never changed this it says automatic.
    Click on the word automatic and select edit locations
    Add a location (I called mine home).

    Go into advanced (bottom right button)
    Click on tcpip button (near top)
    Click on renew dhcp button (upper middle right)
    Click OK (lower right)

    This should work now.


    Also to others - If you are not familiar with Tech support do not give dangerous advice to reset router firmware, check hardware, or other items. If many people make a single change and get a single issue (like upgrading their OS and losing connectivity) - it is not going to be a thousand different answers.

    The problem is with what was changed. In this case upgrading to Snow Leopard is causing the problem.
    Mac OS X (10.6)
  • mb40 Calculating status...
    I had the same issue and found the solution in a discussion forum category about Airport and Snow Leopard issues:

    "I solved my problem by going into System Preferences > Network and removed the Airport service by clicking "-". I then added the Airport service back by clicking on the "+" and the problem was solved."

    I use a Time Capsule, and as soon as I took the above actions and unplugged the ethernet cable, I was up and running wirelessly. I should mention that I changed my Time Capsule SSID name during the trouble shooting process. This may or may not have played a part in solving my problem.
    Mac Book Pro, Time Capsule
  • pickyuser01 Calculating status...
    This worked for me! I even tried going back to "Automatic" -- the problem returned. I am now using the "new" connection created by these instructions, and it works! Thanks!
    Mac OS X (10.6)
  • pickyuser01 Level 1 Level 1 (0 points)
    Here are the instructions provided by jhuettner:

    Hello everyone,
    Had the same problem here, but I got it fixed. Do this:

    open "System Preferences"
    select "Network"
    click on "Location" drop-down menu
    select "edit locations"
    create a new one (name it whatever you like, e.g. "10.6" or so
    obviously select Airport to the left (and remove everything else you need)
    select the network in the "Network Name" drop-down menu to the right
    hit "apply" on the lower right corner

    Worked for me. Obviously some kind of bug in the current release.

    Best wishes,
    JH
    Mac OS X (10.6)
  • Snoop Dogg Level 4 Level 4 (1,265 points)
    Alexander, the problem is likely that you have non-working DNS servers manually entered in your Network pref pane. If you delete these DNS servers, your networking should start working again. Write down the DNS servers before deleting them just in case that isn't the problem, but I'm pretty sure that will fix it.
    MacBook Pro, Mac OS X (10.6)
  • Dave Moore Calculating status...
    You guys are the best! Thank you!

    After 4 flawless installations, the 5th wouldn't connect. "New Location" fixed it. Thank you.
    MacBook Pro Intel Core 2 Duo 2.66 Ghz, Mac OS X (10.6)
1 2 3 4 ... 6 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.