Skip navigation
This discussion is archived

Spotlight Characters: Apps display in Kanji or Chinese

2357 Views 19 Replies Latest reply: Nov 3, 2009 1:36 PM by modalshift RSS
1 2 Previous Next
James Blandford-Baker Calculating status...
Currently Being Moderated
Aug 28, 2009 2:34 PM
Trying to find an application using Snow Leopard results in the right icon being displayed next to the name but the name is in Chinese (Or Kanji) or something like that. All other spotlight list items are in English!

Any thoughts anyone?

Thanks

James
iMac Intel 2.4GHz 4Gb, Mac OS X (10.6), Time Capsule, Lexmark C530dn
  • F430 Level 1 Level 1 (20 points)
    It's happening to me too. I did open up FontBook and resolved all the duplicate fonts but they still show up that way.
    15.4" uni MacBook Pro 4 GB RAM, Mac OS X (10.6)
  • F430 Level 1 Level 1 (20 points)
    Currently Being Moderated
    Aug 28, 2009 7:08 PM (in response to F430)
    It seems that spotlight is showing the app results in English now. The only thing I did was to fix the duplicate fonts and try searching several times and I could see the initial result come in Chinese and then heal itself.

    Everything seems to be fine now.
    15.4" MacBook Pro 1.5 GB RAM, Mac OS X (10.4.4)
  • Magnus Lewan Level 4 Level 4 (3,655 points)
    James, are you from Cambridge, Mass, or Cambridge, UK? (Both lovely places, btw.) Some other user reported that British English was not recognised by some applications in Snow Leopard, so you need to have (US) "English" as well high up in the list of Languages in System Preferences.
    MacBook, 4GB, 1067 MHz, NVIDIA GeForce 9400M, Mac OS X (10.5.7)
  • Roger Traill Calculating status...
    The solution seems to be that you have to have "English" in your language list not one of the English versions, ie I know have "Australian English" and "English". Neither adding US or British English fixed it.

    I worked it out as I have a "clean" admin user and it worked fine, looked in the language list and "English" was in it.

    It seemed to take a couple of spotlight searches before it switched the chinese characters off.

    I had tried turning all the kanji type fonts off but some couldn't be turned off as they were needed by the system (?). This had no effect.
    MacBook Pro Unibody 2.93ghz Intel Core 2 Duo, Mac OS X (10.5.7)
  • aboywholikesapples Calculating status...
    Same problem here: Spotlight functions correctly, however, when I search for a system application, it's name appears in Chinese characters. My friend, who has the same system as me, is experiencing the same anomaly.

    In online forums I've scoured, users experiencing this issue seem to think it's font-conflict related, but nobody appears to be certain. I haven't heard of a single circumstance in which a user has taken specific action to remedy the problem.

    I suspect this problem is very widespread, but only Spotlight users are noticing it; hence the low level of reports. Touch wood, it's not a major issue, but I like things to be right and it's going to drive me mad until I resolve it.
    iMac 24", Mac OS X (10.6), 2.33GHz, IC2 Duo, 3Gb RAM, NVIDIA GeForce 7600 (256Mb)
  • aboywholikesapples Level 1 Level 1 (0 points)
    Oh brilliant. So if you're British, you have to set your language to "English" and suffer system wide Americanisms or for the purposes of Spotlight, the OS will assume you're Chinese?
    iMac 24", Mac OS X (10.6), 2.33GHz, IC2 Duo, 3Gb RAM, NVIDIA GeForce 7600 (256Mb)
  • peejkerton Calculating status...
    I just wanted to add my voice to this. British English settings, and I am having this trouble too. It also happens within finder. Certain filetypes (such as Mail, Safari Documents, Text files) are all appearing in Asian Characters.
    Apple Macbook Alminium 13inch Early 2009, Mac OS X (10.6)
  • aboywholikesapples Level 1 Level 1 (0 points)
    Roger, you are spot on.

    I apologise for ever doubting you. I followed your advice and added a RESTART, which made all the difference. Now those dreadful symbols, which made me hate the Chinese have gone.
    iMac 24", Mac OS X (10.5.1), 2.33GHz, IC2 Duo, 3Gb RAM, NVIDIA GeForce 7600 (256Mb)
  • chip.r Level 1 Level 1 (30 points)
    For what it's worth, after upgrading to 10.6 I'm having the same problem and I have "English" set in my language list. There were three other eastern European languages set which I unchecked and I've just switched to Australian English to see if the switch back to English makes a difference. So far no luck but I have yet to try anything with my font book.

    Here are some samples of what I'm seeing.

    !http://img.skitch.com/20090904-kn3yk6rf9y19nnmitn7fmeitb2.jpg! !http://img.skitch.com/20090904-qjr8eyg1ybi36hwknram9s5sb3.jpg!

    Thoughts?
    iMac G5, MacBook Pro, 30GB iPod, 8GB iPhone, Mac OS X (10.5.7), .Mac
  • oldgustaf Level 1 Level 1 (20 points)
    Having the same issue here in wild west Wales. See here: http://discussions.apple.com/thread.jspa?threadID=2136693&tstart=0
    iMac 2.66GHz Intel Core 2 Duo - 2GB 1067 MHz DDR3, Mac OS X (10.6)
  • oldgustaf Level 1 Level 1 (20 points)
    Yes, thanks very much - that's me fixed also. What a relief - don't we all hate it when we have a glitch in the system.

    Now, if only I could get a driver update for my HP laserjet...
    iMac 2.66GHz Intel Core 2 Duo - 2GB 1067 MHz DDR3, Mac OS X (10.6)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.