Skip navigation
This discussion is archived

Why did Snow Leopard delete ALL of my leopard time machine backups?

10341 Views 31 Replies Latest reply: Nov 30, 2009 3:37 AM by Phil Purviance RSS
  • halverg Calculating status...
    I saw the same thing. However, the backups were not deleted. Snow Leopard was not mounting the old backup sparseImage (which holds 6 months of my backups). Instead, it was starting a new backup from scratch and therefore showed only one backup in the history.

    I had cloned by boot drive prior to upgrading and was able to boot into 10.5 from that disk. In Leopard, TimeMachine was able to see the prior backups.

    I don't know why it's happening but at least the old backups still exist.
    Mac Pro 2.66 GHz Dual Xeon, Mac OS X (10.5)
  • Pondini Level 8 Level 8 (38,710 points)
    halverg wrote:
    I saw the same thing. However, the backups were not deleted. Snow Leopard was not mounting the old backup sparseImage (which holds 6 months of my backups). Instead, it was starting a new backup from scratch and therefore showed only one backup in the history.

    I had cloned by boot drive prior to upgrading and was able to boot into 10.5 from that disk. In Leopard, TimeMachine was able to see the prior backups.


    You should be able to see them via the +*Browse ...+* option. See item #17 in the Frequently Asked Questions *User Tip.* (You may have to mount the correct sparseimage first.)
    iMac G5 1.8 GHz PowerPC, Mac OS X (10.5.8)
  • KevShootz Calculating status...
    I have had Snow Leopoard now 4 days, and just noticed that Time MAchine was doing this to me as well. I had nearly 1 years worth of backups on my drive.

    And now it deleted every one of them!

    I have NO backups left anymore.

    ***!!!???
    Mac Pro 8 Core 3.0, Mac OS X (10.6), MacBook Pro, iMac (Intel)
  • Pondini Level 8 Level 8 (38,710 points)
    KevShootz wrote:
    I have had Snow Leopoard now 4 days, and just noticed that Time MAchine was doing this to me as well. I had nearly 1 years worth of backups on my drive.

    And now it deleted every one of them!

    I have NO backups left anymore.


    Did you try the +*Browse ...+* option?
    24" iMac 2.66 GHz Intel; 4gb; 640 gb, Mac OS X (10.6), AEBS
  • KevShootz Level 1 Level 1 (5 points)
    yea just did that.

    I had backups spanning thru August 2008. Now I only have backups since Sept 3 of this year (2009). And that is because I stopped Time Machine from deleting any more.

    Wow.

    Totally confused.
    Mac Pro 8 Core 3.0, Mac OS X (10.6), MacBook Pro, iMac (Intel)
  • Pondini Level 8 Level 8 (38,710 points)
    KevShootz wrote:
    yea just did that.

    I had backups spanning thru August 2008. Now I only have backups since Sept 3 of this year (2009). And that is because I stopped Time Machine from deleting any more.


    Details please:

    Did you do a normal install of SL, or did you erase your HD and migrate/restore from Leo?

    How much is used on your internal HD?

    How large is your TM drive?
    24" iMac 2.66 GHz Intel; 4gb; 640 gb, Mac OS X (10.6), AEBS
  • KevShootz Level 1 Level 1 (5 points)
    hey pondini.

    I use a 300 gig raptor drive as my boot, have another drive with all my docs, music photos. both backup to time machine.

    my time machine drive is 1.5 TB. When it started to delete my old backups, i still had 400 gigs left. Space was not a problem.

    When i installed SL, i did a complete erase and install. I wiped my old drive.

    thanks!
    Mac Pro 8 Core 3.0, Mac OS X (10.6), MacBook Pro, iMac (Intel)
  • Pondini Level 8 Level 8 (38,710 points)
    KevShootz wrote:
    hey pondini.

    I use a 300 gig raptor drive as my boot, have another drive with all my docs, music photos. both backup to time machine.

    my time machine drive is 1.5 TB. When it started to delete my old backups, i still had 400 gigs left. Space was not a problem.

    When i installed SL, i did a complete erase and install. I wiped my old drive.


    That means TM will almost certainly do a full backup of your boot drive.

    It sounds like TM was trying to do a full backup of *both drives.* Click here to download the +Time Machine Buddy+ widget. It shows the messages from your logs for one TM backup run at a time, in a small window.

    A few folks have trouble with that on SL; if you do, use Console to look at your logs; filter for the backupd process. (Post back if you need help with that).

    If it was trying to do a full backup of both drives, do a Restart and try again. It will most likely behave properly. Just watch for the amount it wants to back up; cancel immediately if it's more than your boot drive.

    One more thought: did you already have iPhoto 09? If not, nearly that whole thing would have been changed by upgrading, so it will need to be backed-up again.
    24" iMac 2.66 GHz Intel; 4gb; 640 gb, Mac OS X (10.6), AEBS
  • halverg Level 1 Level 1 (5 points)
    My backups reside on a Drobo attached to a Time Capsule. The size of the sparse image is 1.7 GB. The tip for resetting Time Machine did force TM to recognize the existing sparse image. However, the subsequent backup ran very slowly, approximately 50 KB/hour. The Drobo had 180 GB of free space; so it shouldn't have been the Drobo behavior of slowing to a crawl when disk space is low. I eventually discovered a firmware upgrade for the Drobo. After that upgrade, the backup succeeded in a "reasonable" amount of time (22 GB in 16 hours).
    Thanks for the help.
    Mac Pro 2.66 GHz Dual Xeon, Mac OS X (10.5)
  • Pondini Level 8 Level 8 (38,710 points)
    halverg wrote:
    My backups reside on a Drobo attached to a Time Capsule. The size of the sparse image is 1.7 GB. The tip for resetting Time Machine did force TM to recognize the existing sparse image. However, the subsequent backup ran very slowly, approximately 50 KB/hour. The Drobo had 180 GB of free space; so it shouldn't have been the Drobo behavior of slowing to a crawl when disk space is low. I eventually discovered a firmware upgrade for the Drobo. After that upgrade, the backup succeeded in a "reasonable" amount of time (22 GB in 16 hours).
    Thanks for the help.


    Many of us (me included) have had success by cancelling the TM backup, then doing a Restart. (Why, I have no clue!)

    I'm doing backups to a USB drive attached to an Airport Extreme, only about 15 feet from my Mac, and getting about 12 gb per hour wirelessly (although it varies from about 6 to 15).
    24" iMac 2.66 GHz Intel; 4gb; 640 gb, Mac OS X (10.6), AEBS
  • Ron Garret Calculating status...
    This happened to me. TM started deleting old backups. Got about a year's worth before I noticed what was going on and stopped it. Turned out what happened (apparently) is that I had unmounted two external drives, and when I remounted them TM forgot that I had those drives on the exclude list. It tried to back up those drives, needed a terabyte of free space, and blythely started to delete backups to make room, not even noticing that the entire TM drive is only 750GB.

    I'd call this a SERIOUS bug in Time Machine. All external drives should be excluded by default. You can lose ALL of your backups simply by mounting an external drive.
    Macbook Pro, Mac OS X (10.5.6)
  • ChrisRR Level 3 Level 3 (920 points)
    Ron, this is well explained and has also just happened to me - precisely the same thing. I had two external drives attached when TM started to do its thing. It said it had failed as there was insufficient space. What the incompetent and dangerous program did NOT tell me was that it was about to murder 6 months' worth of backups made prior to installing Slow Leopard. (sic)

    So now, my contingency of being able to revert to Leopard has been dashed because of this bug in TM. I cannot restore the machine to how it was prior to SL.

    What an absolute pile of garbage. Thanks Apple. You should try spending at least a couple of hours testing the latest stuff before springing it on us.
    Not happy.
    iMacs, Intel 20 inch 2.0 with 1.5 gig ram, Mac OS X (10.6), 2 InteliMacs, 15" PB, 12" PB, Loads of iPods, 2 Airport Expresses
  • ChrisRR Level 3 Level 3 (920 points)
    Also:
    The Widget mentioned here, showed that even though it started to delete older backups, it still discovered it hadn't enough space! How basic is that! Wouldn't you think it would have the technology to work out PRIOR to deletion whether that action is sufficient? It can work out how much space is required, and how much is remaining - but it deletes stuff willy-nilly without first working out the maths of "before/after'. Brilliant! Genius! Having deleted ALL the backups it says "Oops! Still not enough space. Oh well, never mind."
    iMacs, Intel 20 inch 2.0 with 1.5 gig ram, Mac OS X (10.6), 2 InteliMacs, 15" PB, 12" PB, Loads of iPods, 2 Airport Expresses
  • inod3 Calculating status...
    Same here. ALL last years backups GONE after the upgrade to snowy cat.

    G-O-N-E.

    Where do i go if i need stuff from last week? Certainly not to you Apple, now can i? CAN I?

    Did you even test this? Its not like i did anything special. I have two external harddrives: 1 WD passport and 1 WD Studio FW 800.

    Not even RAID will save you from this Blunder.

    Message was edited by: inod3
    Mac OS X (10.6)
  • Pondini Level 8 Level 8 (38,710 points)
    Ron Garret wrote:
    This happened to me. TM started deleting old backups. Got about a year's worth before I noticed what was going on and stopped it. Turned out what happened (apparently) is that I had unmounted two external drives, and when I remounted them TM forgot that I had those drives on the exclude list. It tried to back up those drives, needed a terabyte of free space, and blythely started to delete backups to make room, not even noticing that the entire TM drive is only 750GB.

    I'd call this a SERIOUS bug in Time Machine. All external drives should be excluded by default. You can lose ALL of your backups simply by mounting an external drive.


    You need to report this to Apple. Start with AppleCare (if you're in the US, 800-275-2273). Have your serial number and the particulars handy, including this +Thread ID+ (2134197). If you're calm and clear, they'll get the right folks involved.

    That said, Snow Leopard and TM were tested extensively, both by Apple and in beta. This is the first report like this in this forum, so it's not widespread.
    24" iMac 2.66 GHz Intel; 4gb; 640 gb, Mac OS X (10.6), AEBS

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.