Skip navigation
This discussion is archived

Strange iTunes behaviour

1334 Views 13 Replies Latest reply: Sep 13, 2009 3:59 AM by Greedytheonly RSS
kieran12 Calculating status...
Currently Being Moderated
Aug 29, 2009 4:14 AM
I upgraded to Snow Leopard this morning and have been experiencing weird iTunes issues.
If I press the play/pause button on my macbook iTunes launches. When I close iTunes (CMD+Q) it closes and then reopens a few seconds later. To keep it closed I have to force quit.

Has anyone else experienced this issue? Any ideas on how to fix it?
Macbook Penryn, Mac OS X (10.6), 2GB RAM, 160GB HD, 13.3" display, 2.4GHZ Core2Duo
  • Charles Conway Level 1 Level 1 (50 points)
    Currently Being Moderated
    Aug 29, 2009 4:25 AM (in response to kieran12)
    I'm having the same problem since upgrading to Snow Leopard, although if I quit iTunes it stays closed until I hit a media key again. Now when trying to use the media keys with Spotify it launches iTunes.
    Mac OS X (10.6)
  • johnnyboy_1969 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 29, 2009 4:59 AM (in response to kieran12)
    For some reason I wasn't able to purchase music, said I wasn't on secure connection and to check that my date and time were correct. Called support, didn't undertstand why I had the issue. As I was discussing issue with support I kept trying to add music to cart and it eventually went through, issue cleared(I hope).
    White Macbook 120GB, Mac OS X (10.6)
  • Todd M Taylor Level 2 Level 2 (245 points)
    Currently Being Moderated
    Aug 29, 2009 3:12 PM (in response to kieran12)
    Not sure if it's the same/related problem. My computer has three users/accounts on it. Only one of them (mine) does this...

    At login or after restart, all is fine. However, the first time iTunes is launched, there is no quitting it. If I quit iTunes, it restarts/relaunches automatically after less than one second. Restarting is impossible. I get a dialog stating that the restart was cancelled due to iTunes starting up.

    Very annoying. Already did a reformat/clean install (and subsequent migration from backed up volume). Problem immediately manifests itself again.

    Driving me crazy... although I imagine there are worse probs w/ SL installs.

    Any ideas would be appreciated.
    20" 2.0 GHz iMac Aluminum |, Mac OS X (10.6), | 3 GB RAM | Maxtor 500 MB external HD
  • Todd M Taylor Level 2 Level 2 (245 points)
    Currently Being Moderated
    Aug 31, 2009 8:44 PM (in response to Todd M Taylor)
    For me, it is solved. While my symptoms were not identical to yours, we may have had different problems. Mine was related to an iTunes add-on called "I Love Stars." The developer of the program knows of the incompatibility and has released an updated the fixes the problem.

    If you have I Love Stars installed, just go to http://www.potionfactory.com/blog/2008/05/15/i-love-stars and download the latest. (If you don't have it, but like to rate your songs as you listen, check it out.)
    20" 2.0 GHz iMac Aluminum |, Mac OS X (10.6), | 3 GB RAM | Maxtor 500 MB external HD
  • benr1972 Calculating status...
    Currently Being Moderated
    Aug 31, 2009 9:04 PM (in response to kieran12)
    I have an issue (http://discussions.apple.com/thread.jspa?threadID=2137662&tstart=0) whereby I can't add iTunes audio into an iPhoto slideshow. It used to work in OS 10.5.7.
    iMac, Mac OS X (10.6)
  • rajaniblue Level 1 Level 1 (30 points)
    Currently Being Moderated
    Sep 1, 2009 6:12 AM (in response to kieran12)
    I'm having the same problem with the pause/play button launching iTunes. I rarely use media keys, so it's not that big of an issue for me, but I would like to get a fix for it, eventually.

    This is one of the few bugs I have found in my particular install of SL. I have a 15" MBP purchased in March (late 2008 version) running Adobe Creative Suite, Suitcase, iWork 09, Stuffit, Firefox and a host of little utility programs. Nothing complicated or unusual. The computer was working flawlessly before SL and is working 98% flawlessly now. I can quit out of iTunes and it stays quit, but the pause/play button does launch it.

    Just wanted to report that other users are having this problem.

    Message was edited by: rajaniblue
    macbook pro 15" early 2009, Mac OS X (10.5.7)
  • Applehjuvik Calculating status...
    Currently Being Moderated
    Sep 1, 2009 9:44 AM (in response to kieran12)
    Just wanted to add my voice too this problem. I use both itunes and spotify a lot! The media key/pause/play key problem is a right nuisance! I use those keys a lot! Also this problem applies to the apple remote.

    As a related question, is there anyone who knows how to use spotify with the apple remote?

    Kind Regards, Stephan
    Late '08 MacBook Pro 15" + iPod touch 32gb 2g + iPod nano 8gb 3g + iPod Photo 60gb, Mac OS X (10.6), 2,4Ghz, 4Gb ram, 250Gb HDD, NVIDIA GeForce 9400M + 9600M GT 256MB
  • christhekid100 Calculating status...
    Currently Being Moderated
    Sep 2, 2009 7:45 AM (in response to kieran12)
    iTunes also launches for me everytime I hit the media keys to control Spotify. Just started today after installing snow leopard.

    Do these kind of things get fixed quite quickly? Is it a bug for Apple or Spotify to fix?
    Mac Book Pro, Mac OS X (10.6)
  • Greedytheonly Calculating status...
    Currently Being Moderated
    Sep 3, 2009 11:38 PM (in response to kieran12)
    I have the same problem but with Songbird. When I hit the music buttons the iTunes launches and there is no option or setting to configure to disable this annoying behavior.

    Does anyone actually has a solution?

    Thanks.

    Peter.
    MacBook Pro 15", Mac OS X (10.6)
  • DeanFlory Calculating status...
    Currently Being Moderated
    Sep 11, 2009 1:10 AM (in response to kieran12)
    I'm having the same "quit but auto restarts" issue with iTunes 8 and now today it's the same with iTunes 9 and 10.6.1. SO, guess I'll have to wait and see if there's a fix for this and the many others (CS3 is a b!†c# on SL).

    Snow Leopard was not ready for release. Don't they use test groups before releasing? Some of these things are so specific yet were not fixed before release.
    8500, G4, iMac (Early 2008), Mac OS X (10.6), 10.6.1, iTunes, Snow Leopard, Adobe Master Collection CS3
  • Nicko88 Calculating status...
    Currently Being Moderated
    Sep 13, 2009 2:29 AM (in response to DeanFlory)
    I'm having the same issue, which makes for an interesting music alarm clock...the first day after installing SL I woke to the not-so-soothing sounds of my wake-up iTunes playlist and the last band I was listening to in Spotify combined. The most persistent problem, though, is that pausing one starts the other, as if someone somewhere doesn't want me to stop listening to music...
    iMac, Mac OS X (10.6)
  • Greedytheonly Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 13, 2009 3:59 AM (in response to kieran12)
    Hi, I found one "workaround", which works for me -> just make sure that you don't have any music loaded in iTunes. Then it does not matter if you press play/pause button - the iTunes will stay ON, but silent. I know, this is not a solution, but at least it not that annoying. And it could be useful for someone until Apple releases any hard solution, which I doubt.

    Cheers!
    MacBook Pro 15", Mac OS X (10.5.2)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.