1 2 3 Previous Next 1,153 Replies Latest reply: May 8, 2013 9:30 AM by i5.com Branched to a new discussion.
Ryan83 Level 1 Level 1 (0 points)
Ever since I installed 10.6 -- I constantly drop my wifi connection.
I have VPN turned off and the all the same settings from 10.5, and I never had a problem before.
Whether I am far away (reception is worse) or only 3 feet away, I drop my signal constantly for no reason.
I have latest Firmware on router and powered down modem and router.

Many times I can not turn off airport as well, and I need to restart my latpop in order to get a strong wifi signal again? Any suggestions?

My router is a Belkin G+ Mimo - most updated firmware

Thanks!

MacBook Pro 2.16 - 15 Inch, Mac OS X (10.6), 4 GB RAM, 320 Gb HD
  • 1. Re: Dropping Wi FI Signal
    donv (The Ghost) Level 5 Level 5 (4,600 points)
    Only doing what is suggested in this thread: http://discussions.apple.com/thread.jspa?threadID=1924527.
  • 2. Re: Dropping Wi FI Signal
    Ryan83 Level 1 Level 1 (0 points)
    I tried this earlier, thank you though
  • 3. Re: Dropping Wi FI Signal
    ericbeer Level 1 Level 1 (0 points)
    I am having a simular situation with the Airport. I just purchased two MacBook Pros less than two months ago. Both are dropping the wireless at the same time. This has never happened before but I install Snow Lep two days ago and this issue has happened three times now. Right now I am using a Liksys Wireless G Broadband. I do have a PC connected to the router and it is working fine.
  • 4. Re: Dropping Wi FI Signal
    Brou Level 1 Level 1 (0 points)
    I've been having the same problem. It's a MBP that I purchased right about 2 years ago. I've never had any issues with using wireless on it until I installed 10.6. Now it just randomly drops connection. Sometimes it re-establishes right away, other times I have to turn off the airport and then turn it back on. It's getting VERY frustrating.

    Message was edited by: Brou
  • 5. Re: Dropping Wi FI Signal
    tomkarl Level 1 Level 1 (10 points)
    Same issues here on a MacBook. Just completed full restore to leopard via a Time Machine backup. The restore went quickly and easily once I read that I had to start with the leopard DVD.

    Installed SL on an iMac that is connected vis Ethernet and once we got past the keychain issues it's been running solid.
  • 6. Re: Dropping Wi FI Signal
    George Stafford Level 1 Level 1 (55 points)
    13 inch MBP and after installing 10.6 my wireless drops very frequently. All bars solid. Have to turn Airport off and back on to reconnect. As others have stated..."Very annoying".
  • 7. Re: Dropping Wi FI Signal
    CircleThree Level 1 Level 1 (0 points)
    I too have the same problem. Driving me crazy and causing grief for on line transactions. I have noticed it is only affecting the browsers (skype and mail is ok) so perhaps a compatibility issue with Safari and Firefox?

    Any ideas on how to get solid browser connection for a WIFI connection that stays up, except for browsers?
  • 8. Re: Dropping Wi FI Signal
    qUAan Level 1 Level 1 (0 points)
    I found this somewhere on the forums

    I followed it and it worked for me too

    Go to Macintosh HD -> Library -> Preferences -> SystemConfiguration ->
    Delete the following Plists:
    com.apple.airport.preferences.plist
    com.apple.nat.plist
    come.apple.network.identification.plist
    com.apple.PowerManagement.plist
    Networkinterfaces.plist

    There should be 4 plist's remaining in the SystemConfiguation folder.

    Enjoy!!!!!
  • 9. Re: Dropping Wi FI Signal
    FlynLow Level 1 Level 1 (10 points)
    Same here, drops signals after a while, requires reboot to get it back.
    This and the printer issues was a real pain. Had to revert back to 10.5. I'm sending SL back, hopefully all the issues will be fixed in a few point updates. SL should be ready for a business environment this fall.

    (FYI, We have multiple router brands at work, and they all disconnected after a while.)

    The only funny thing about this was talking to a tier two tech at apple, he was trying to blame my ISP... When I reiterated the problem and tried to explain by "airport dropping off the local area network" he said "yes, it could be a local problem with your ISP"
  • 10. Re: Dropping Wi FI Signal
    CircleThree Level 1 Level 1 (0 points)
    I tried the suggestion that donv (The Ghost) put forward. Improved the situation a bit but after about 30 minutes it reverted to dropping me out of the browsers, which makes for a re-connect.

    Funny the people here in Australia also blame the ISP. hey can't explain why one machine running on SL crashes while the other version is stable. If you don't know why point fingers.....
  • 11. Re: Dropping Wi FI Signal
    CircleThree Level 1 Level 1 (0 points)
    Tried qUAan's suggestion. It does not fix the problem.
  • 12. Re: Dropping Wi FI Signal
    mitsubish Level 1 Level 1 (0 points)
    Same problem here, MBA updated to Snow Leopard in Spanish. Wifi drops very often, it finally works for a while by restarting.
  • 13. Re: Dropping Wi FI Signal
    Xinaian Level 1 Level 1 (0 points)
    Same problem here, with a 2006 MBP (1,1)
  • 14. Re: Dropping Wi FI Signal
    i dont care what my alias is Level 1 Level 1 (0 points)
    Just to add my voice in case Apple is counting, I'm having problems with dropped internet access since upgrading to snow leopard too. I have a mac mini that talks wirelessly to a time capsule. Worked perfectly before upgrade, now it drops connections constantly. Vista computer (gasp) connected wirelessly to same base station using airport express works flawlessly so I'm certain it's not time capsule or wireless problems in general. There's definitely a bug in the snow leopard networking code somewhere.
1 2 3 Previous Next