Skip navigation
This discussion is archived

Trouble with my Thumbnails since 2.1.4 update

2573 Views 7 Replies Latest reply: Nov 17, 2009 7:32 PM by aTrain93 RSS
coyoboyo Calculating status...
Currently Being Moderated
Aug 29, 2009 12:23 PM
My Thumbnails have been acting crazy lately...it will show the wrong picture for the thumbnail, I have to go up to the toolbar and generate thumbnail, then it is fixed, until I come across the next one, which seems to be happening all the time now.
Anyone else experiencing this?
I have not bought Snow Leopard yet, but I did update Aperture.
IMac 24", Mac OS X (10.5.7), dual core 3.06ghz, 4gb Ram
  • welchgeo Calculating status...
    Currently Being Moderated
    Aug 30, 2009 9:45 AM (in response to coyoboyo)
    I did the update and have upgraded to SL.

    My thumbnails are constantly rebuilding and occasionally I get colored squares in the thumbnail.

    sorry I don't have a solution, just more problems.
    Georgia
    mac Book Pro, Mac OS X (10.5.2)
  • Morris Man Calculating status...
    Currently Being Moderated
    Aug 30, 2009 12:26 PM (in response to coyoboyo)
    Posted this on another similar link
    Friday Aperture 2.1.4 worked fine I upgraded to Snow Leopard on Saturday. On Sunday I found that Aperture was "importing" but would not show anything in the browser except blank rectangles. Viewer would show a photo but if I click on a blank it takes ages to open the new photo. Worse - nothing in the adjustments is active. Hit and miss on older projects whether this works too. Tried re=loading Aperture no difference. Any ideas folks or I will have to use Time Machine to jump back to prior to Snow Leopard if I can.
    Would recommend no one upgrades just yet if running Aperture
    Sorry no solution either just similar problems
    Mac Pro, Mac OS X (10.6), Aperture 2.1.4
  • Morris Man Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 30, 2009 1:33 PM (in response to coyoboyo)
    I found this on an older thread and although some of the files were not present on my machine (perhaps that was part of the problem!) It all seems to be working OK now.

    Another approach you might consider is reinstalling Aperture. To do this
    effectively, you need to remove the application and its receipts, then
    install Aperture and use Software Update to install additional updates. You
    don't have to remove everything that was installed with Aperture. Follow
    the steps below to completely reinstall a fresh copy of Aperture.
    Note: Make sure that you have your installation discs nearby before
    starting this.
    1. Open the Applications folder.
    2. Drag the Aperture application to the Trash.
    3. Go to /Library/Receipts.
    4. In the Receipts folder, select the "Aperture.pkg" and
    "ApertureSampleProjects.pkg" files. Note: If you have Aperture 1.5
    also select the "PluginManager.pkg" file.
    5. Drag the those .pkg files to the Trash.
    6. Insert your Aperture installation disc and install Aperture.
    7. When finished, choose Software Update from the Apple () menu to
    update your software to the latest version.

    For me I had to Trash what I could, reinstall Aperture 2 then the 2.1.4 upgrade and fingers crossed!!!
    Mac Pro, Mac OS X (10.6), Aperture 2.1.4
  • am2am2am Level 1 Level 1 (10 points)
    Currently Being Moderated
    Sep 2, 2009 1:25 PM (in response to Morris Man)
    I have similar problem with thumbnails after upgrade to 2.1.4. My last project with 1000+ images does not display thumbnails at all
    is something wrong with 2.1.4?
    IMac24, Mac OS X (10.5.8)
  • hallerphoto Calculating status...
    Currently Being Moderated
    Sep 4, 2009 5:39 PM (in response to coyoboyo)
    I just thought I'd throw in my experience here. I was unlucky enough to have a sparse disk image containing a 200-300 GB aperture library go missing after installing Snow Leopard last night.

    So today I did a restore from the vault. It took 10 hours and 2 minutes. When it finally opened, it crashed after about 2 minutes.

    Now, my thumbnails are crazy. I expected them to be gone, as they're not stored in the vault. But they're not regenerating. Window > Show Activity shows nothing going on. If I quit, it says, "Aperture is currently processing thumbnails. Are you sure you want to quit?"

    Aperture really seems unable to keep up these days.
    Mac Pro 2.26 GHz x 2, Mac OS X (10.6)
  • SamT Calculating status...
    Currently Being Moderated
    Nov 13, 2009 5:52 PM (in response to coyoboyo)
    Aperture 2.1.4

    Professional wedding shoot. 1,500 photos. 8 CFs. Imported each into separate projects to easily vfy card and project counts matched. Edited 90%. Everything seemed to work fine including thumbnails/previews. While editing last 10%, decided to move all 8 projects into 1. Went to each project, Select All, drag, repeat. When images were all filed under one project, suddenly half the images have a blank thumbnail/preview in the browser pane. Each missing preview is bordered by a roundtangle with a dashed white stroke.

    Tried the following with no luck:

    Quit/Restart Aperture
    Restart Mac
    Create new project, drag photos to it (same thumbs are missing)
    Drag back
    Create new project, drag 10 photos to it (same thumbs missing)
    Ctrl-option > Generate previews
    Ctrl-option > Delete previews
    Ctrl-option > Update previews
    Same without option
    Toggle in and out of Quick Preview mode
    Resize previews via slider
    Enter/Exit Full screen
    Zoom/Unzoom
    Cycle thru all Viewer/Browser modes (V)
    Quit Aperture, open Aperture Library package, drag thumbs file to desktop, Open Aperture
    repeat with other 2 files that appear to hold previews (e.g., ...minis...)

    Now attempting to export project with 1,500 photos, copy entire Aperture Library to 2 TB drive, open backup library there, rename project, re-import exported project.

    There appears to be some reas

    Hunch: when it asks something like "In the process of generating previews... Quit, Cancel?" it could be that selecting Quit leaves the database in an inconsistent state. Although I have clicked Quit once or twice (successfully) before and the wedding photos are from September and should have had valid thumbs generated in 2 months of daily use, somehow they still went missing. I don't quite see how this is possible since moving photos to a different project shouldn't require new thumb creation. Furthermore, it appears that Apple has seen this problem during development and took the time to add options to delete, update and regenerate and force the generation of previews so there appears to be several uncaught bugs here related potentially to Quitting while generating, losing track of previews during drags between projects, deleting and re-generating, and even moving the internal thumbs files can't trick Aperture into regenerating them from scratch. The Canon 5D MarkII could be an issue but thumbs get generated for half the RAWs fine so that doesn't seem to be the root cause. From the clues it seems like thumbs/previews and pointers to them from the full size images are getting corrupted. I assume it's recreatable and therefore fixable based on (others reporting these same problems/symptoms). To do so, create 8 projects with 200 photos and drag into one project. Quit Aperture during the process and select the Quit (while generating previews) option when offered that choice. When blank previews appear, try the delete, update and generate previews options and watch them fail. Clues suggest that the SQL lite database or some other mechanism is holding preview or preview pointer information and these are getting balled up by the above process due to multiple Aperture software defects and glaring omissions in the Aperture test plans (for a premium software package targeted at professional photographers with 100,000+ photos who can't spend days trying to regenerate blank photos).

    A potentially related issue is the false "Unsupported image format" error message displayed on a maroon background where the photographer expects to see his image. I have tens of thousands of images from the same camera, of the same image format and images that display properly 10 times can suddenly flip into an unsupported format? This appears to be another example of poor programming, poor error handling, poor testing and taking shortcuts. For example, why doesn't the error give some actual actionable information such as the format encountered, the size (e.g., zero?), data that, if sent in a screen shot to Apple, could help solve a problem with reports online dating back almost 5 years or more (2005).

    A temporary workaround is to click a blank preview and force it to regenerate a thumb for the now tilted image. There may be a way to CMD-click all the missing thumbs and stamp a slight straightening onto them and regenerate all your thumbs. Depending on how severe this corruption is, it's possible that the new previews and pointers have no choice but to be updated and stored in all the places that Aperture has to keep track of them. Take care not to obliterate and stamp over any prior straightening or enhancements with this workaround to regen your previews.

    My fear is that this band-aid could mask a bigger corruption. If so, you could wind up with all your Vaults and Time Machine backups harboring the same corruptions and restores that take hours, days, weeks only to return you to a state with blank previews and potentially deeper corruptions. One post on the web documents the potential for previews to not only go blank but to also turn to squares and lose all knowledge of the master and, apparently because the size and aspect ratio get forgotten and revert to 0 KB and 0x0, the master, even if relocated, can never reconnect with the blank icon. Hunch: this may have something to do with poor programming and error handling in the area of referenced masters and reconnecting with offline projects, libraries or folders. I've used these but do not in any of the projects in the Aperture library suffering these problems reported here.

    Hopefully these details help apple and others get to the root cause of this potentially severe problem.

    Note that this is NOT a snow leopard problem as I chose not to risk installing that (given past upgrades in iPhoto and Aperture where photos were lost forever and upgrading previews/projects took my business offline for 1 to 2 days solid while Aperture churned on its database) until after completing this project.

    I will post the results of the re-import once it completes...potentially another temporary workaround that may hopefully save others a day of lost work actually enhancing photos for customers instead of being wasted trying to see the photos in your library--the minimal feature of a premium photo library package! -Sam
    MacBook Pro Core 2 Duo 2.53 GHz 4GB, Mac OS X (10.5.8), Canon 5D MarkII, Aperture 2.1.4
  • aTrain93 Calculating status...
    Currently Being Moderated
    Nov 17, 2009 7:32 PM (in response to coyoboyo)
    I am using Aperture 2.1.4 and had the same problem with disappearing thumbnails. This worked: close Aperture, then hold down option+command while opening Aperture - you will get the option to rebuild the Aperture library. I did this and everything came back. Hope this works for you!
    MacBook Pro, Mac OS X (10.6.2)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.