Skip navigation
This discussion is archived

SD Card Reader Not Working

87566 Views 11 Replies Latest reply: Dec 30, 2009 11:45 AM by Bluemango RSS
Mr_Hobbles Level 1 Level 1 (0 points)
Currently Being Moderated
Aug 14, 2009 3:13 PM
Hi there,

I bought this MacBook Pro last Wednesday and am loving it so far. However, the SD card slot on this doesn't seem to work, either on Leopard or on Windows 7.

Nothing happens when I put an SD card in. Nothing mounts on the desktop, and Windows still says there's nothing in there.

Interestingly, the very first time I put one in, it did recognize it, but said there was a problem with it. I took it out, and since then I've had the problem of it not recognizing any SD cards.

Any ideas?

MacBook Pro 15" 2.8GHz July 2009, Mac OS X (10.5.8)
  • RonAnnArbor Level 4 Level 4 (2,695 points)
    Currently Being Moderated
    Aug 15, 2009 6:03 PM (in response to Mr_Hobbles)
    Try a few different SD cards...if it's a standard Sandisk, Kingston, etc SD card it should read it. If it's a cheapy ebay card it might or might not read it. Someone should pipe in, but often Transcend cards also don't work right in a lot of products.

    Otherwise, I think all you can do is have Apple look at it.
    Mac OS X (10.5.7), Macbook Air 2.13-- Macbook Pro 15" UB -- iPhone 3Gs
  • Canadiandude Level 1 Level 1 (10 points)
    Currently Being Moderated
    Aug 16, 2009 5:56 AM (in response to Mr_Hobbles)
    You're not alone. mine is not mounting or reading any card I try. I have tried two cards, one Sandisk and one Transcend and neither show up. I've never had it work. I have contacted Apple Support and have an appointment to get it repaired. I'm secretly hoping it's a logic board problem so Apple will replace it with a new one. The reason being that I bought a 500Gb Seagate drive that my MBP won't install (likely because of the EFi firmware update).

    For what it's worth, I have an SD card USB adapter and my MBP reads the cards fine when they are in the adapter and plugged in via USB so it is most definately the SD port that is faulty. If you have a card reader or adapter handy, try the card in that before requesting a repair.
    MacBook Pro 15" 2.53Ghz (June 2009), Mac OS X (10.5.7), 4Gb RAM, 250Gb HD, 9400M, Bodyguardz protector
  • jerseygoil Level 1 Level 1 (20 points)
    Currently Being Moderated
    Aug 20, 2009 7:36 PM (in response to Canadiandude)
    would you all be using Memory sticks that look like an SD card, BUT is NOT?
    imac core2/ 20' & 24"/macbk 13" wht./ 3Gs, Mac OS X (10.5.7), mm/wifi keybrd
  • eww Level 9 Level 9 (52,975 points)
    Currently Being Moderated
    Aug 20, 2009 8:02 PM (in response to Canadiandude)
    MrHobbes and Canadiandude: After verifying that the SD cards you're using can be read fine in other devices and by a USB reader connected to your own MBP, make a Genius Bar appointment to have the faulty readers examined and your machines repaired.
    15" MBP unibody 2.4GHz/4G/250G; TiBook 1GHz/1G/120G; PTProG3 500MHz/768M/160G, Mac OS X (10.5.8), film and flatbed scanners, projector, graphics tablet, laser and photo printers
  • mtuckman Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 7, 2009 7:44 AM (in response to Mr_Hobbles)
    Add another SD card reader that isn't working. Only thing I am not sure about is if it is related to upgrading to Snow Leopard. It was working before the upgrade, but it may just be a timing / coincidence.

    Guess I'll make an appointment at the local Apple Store and have them take a look.
    Macbook Pro 13" - 2009, Mac OS X (10.6)
  • ttang Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 7, 2009 4:14 PM (in response to mtuckman)
    Same problem with my new Macbook Pro. I bought it two weeks ago and since then have been using sd cards under snow leopard and win7 almost everyday.

    Except from yesterday; all of a sudden, it stopped mounting sd cards in either system.
    Macbook Pro, Mac OS X (10.6)
  • ttang Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 7, 2009 10:37 PM (in response to ttang)
    A call to Apple support suggested that I try to reset the System Management Controller.

    follow the directions: (Apple Portables: Resetting the System Management Controller (SMC).

    My SD card was able to mount after that...

    Good luck
    Macbook Pro, Mac OS X (10.6)
  • Jamesofisc Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 23, 2009 1:09 AM (in response to ttang)
    it works !!! Thanks a lot!!!
    macbook pro, Mac OS X (10.6.1), none
  • GIUBRA Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 26, 2009 12:26 AM (in response to Mr_Hobbles)
    I have problems with a micro SD Card which is seen regularly by SL but you can not transfer files and / or initialize.
    I also tried with a regular SD card and the problem persists.
    Someone tell me if it may be a bug in SL?
    Under XP everything is ok!
    MAC PRO 2,66, Mac OS X (10.4.9)
  • Rod Hagen Level 7 Level 7 (31,985 points)
    Currently Being Moderated
    Dec 26, 2009 4:43 AM (in response to GIUBRA)
    What brand of SD card, what format, what size?
    MBP 13"2.26, MBP15"2.2, iMacG520"RevB , MB2CD, MBCD, ,PM5400/180 & earlier, Mac OS X (10.6.2), 7 chooks, 2 dogs, 2 daughters, 1 pear tree, 0 partridges, itinerant bats, magpie
  • Bluemango Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 30, 2009 11:45 AM (in response to ttang)
    Thanks, this worked for me as well. Saved me a trip to the Apple store


More Like This

  • Retrieving data ...

Bookmarked By (2)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.