Skip navigation
This discussion is archived

Snow Leopard - No Output devices found - (Audio)  Help?

15315 Views 29 Replies Latest reply: May 2, 2010 2:38 PM by Benjamin Stoltz RSS
1 2 Previous Next
Grant_the_kiwi Calculating status...
Currently Being Moderated
Sep 8, 2009 7:30 AM
Folks

I just installed Snow Leopard on my Mac Mini which I use as my home media centre. It upgraded fine except for the lack of audio devices it now reports. Ive been combing forum threads but to no avail.

Appreciate any help or suggestions

Model Name: Mac mini
Model Identifier: Macmini1,1
Processor Name: Intel Core Duo
Processor Speed: 1.83 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 2 MB
Memory: 2 GB
Bus Speed: 667 MHz
Mac Book Pro, Mac OS X (10.5.2)
  • Jeffrey Lee Level 4 Level 4 (2,495 points)
    if your audio device came with a set of software, you'll need to re-install it to get it to work again. You should also check the vendor's site to see if there are updated drivers for 10.6
    Dual 2.26 MacPro, and 15" MBP, Mac OS X (10.5.6)
  • jimliddle_uk Level 1 Level 1 (5 points)
    I have just upgraded my son's Mac Mini to Snow Leopard and have the same problem, namely, no output or input device - anybody come across this and been able to fix it ?
    Macbook Pro, Mac OS X (10.6)
  • ross n. Calculating status...
    i'm having the same problem.

    anyone get this figured out yet??
    mac mini, Mac OS X (10.6.1)
  • littleus2001 Calculating status...
    Same issue here on a macbook pro. I was thinking after I upgraded there would be a software update, and there is one, but it keeps failing, so I'm thinking if I can find the download on Apple's site then maybe that might fix the audio issue as well.
    macbook pro 15 inch, Mac OS X (10.6), 30 GB iPod Video, 8GB iPod Touch
  • littleus2001 Level 1 Level 1 (0 points)
    Just did the software update on Apple's site. Did not fix the issue. Will keep on it on my end.
    macbook pro 15 inch, Mac OS X (10.5.6), 30 GB iPod Video, 8GB iPod Touch
  • Jignesh_Sampat Calculating status...
    I am having the exact same problem of "No output devices found" on my brand new macmini.

    Have tried every possible solution I could find on the net.
    a) First I tried resetting the SMC and the PRAM by pressing the required keys while booting. Didnt work. b) Next I tried the Hardware Diagnostics using the diagnostics utility on the snow leopard "Application" disk. Hardware test report "All ok". c) Next I tried downgrading/reinstalling snow leopard without erasing the partition. No use, d) so finally backedup the entire hard drive, deleted the partition and reinstalled snow leopard, still no audio!!! No audio output device, no sound, rest everything work normal.

    Its not even a month I've got this mac mini and I am going thru all this. Today plan to give to apple service center.

    Very dissapointing.
    Mac mini, Mac OS X (10.6.1), Late 2009 edition
  • littleus2001 Level 1 Level 1 (0 points)
    I'm sad to report that nothing I have tried thus far has worked. I actually reinstalled Leopard and STILL have no audio. Here's a little FYI though; I can get audio through the headphones, it's only wheni try the speakers do I not have any audio output. After a phone call to Apple all they could recommend was to take my laptop to the Apple store nearest me and let them mess with. Thorougly disappointed and ****** off.
    macbook pro 15 inch, Mac OS X (10.5.6), 15 GB iPod Video, 8GB iPod Touch
  • ross n. Level 1 Level 1 (0 points)
    I have about 30 days left on my 3 year Apple Care, so I'm really anxious to get this resolved. Going into Genius Bar tomorrow. Will keep y'all appraised of progress.
    mac mini, Mac OS X (10.6.1)
  • mpcheung Calculating status...
    I have the same problem on the Mac Mini I just opened and got up and running today! Any updates?
    Mac Mini, Mac OS X (10.6.1), 2.0 GHz C2D
  • Joseph Kriz Level 5 Level 5 (5,045 points)
    If nothing is plugged into the audio out jack, then you should be showing one device in the Sound Preference panel under Output.
    Internal Speakers -------- Built-in Output

    If nothing is shown there, remove these 2 files and restart.
    1. com.apple.audio.DeviceSettings.plist
    2. com.apple.audio.SystemSettings.plist

    The above files are located in Library>Preferences>Audio
    iMac 20 (Core 2 Duo), MacBook (Core 2 Duo), Mac Mini (Core 2 Duo), Mac OS X (10.6.1)
  • littleus2001 Level 1 Level 1 (0 points)
    I just tried deleting those two files and still have the issue. Thought it might be worth trying. I do have the Digital Output listed in my Sound Preferences though.
    macbook pro 15 inch, Mac OS X (10.5.6), 30 GB iPod Video, 8GB iPod Touch
  • Jignesh_Sampat Level 1 Level 1 (0 points)
    I deleted those files but still had the same issue. Spoke to the Apple Care center today, where I have send my mac mini for repairs reg. this problem. They said they will replace the mainboard! Dunno whats going on ???!!!
    Mac mini, Mac OS X (10.6.1), 2009 edition
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.