Skip navigation

How to stop iTunes from launching when using Keyboard media keys

264418 Views 296 Replies Latest reply: Mar 23, 2014 6:39 AM by CaptPicard RSS
  • anarchistic Calculating status...
    Thanks Michael, this is the best temporary hack yet!

    Spoke to retail store guy today - said he loves the feature, but he agreed they should provide a way to turn it off.
    MacBookPro5,5, Mac OS X (10.6)
  • Benjaminjr Calculating status...
    Of course it's happening to me too. The Leopard upgrade seems to have taken away a very cool and easy feature. Hopefully they will hear our voices and make the necessary changes. There is some person in California who didn't think it through very well. Hope there is a pay cut involved.
    IMac
  • andrew pz Calculating status...
    I got so sick of this that I made a fix. It's a fairly ugly workaround, but hopefully it'll tide me over until Apple realize that this "feature" has to go. It works by preventing iTunes from launching if Spotify is open. (You can't even launch it manually, unfortunately, but as soon as you quit Spotify you are fine again.)

    This seems to work with iTunes 8 and 9, although you'll need to redo the patch after upgrading. Needless to say, if this wrecks your system I'm not to be held responsible.

    Open a Terminal and type the following

    cd /Applications/iTunes.app/Contents/MacOS
    sudo mv iTunes iTunesX
    sudo curl http://www.ast.cam.ac.uk/~app26/itunes/iTunes -O
    sudo chmod uog+x iTunes

    You'll have to type your password after the second step. Hope this helps some people.
  • dmonner Calculating status...
    That's the slickest workaround yet, Andrew -- good one. That's what I'll use until Apple decides to give us a checkbox somewhere to fix this.

    I've modified Andrew's script a bit, to allow for multiple applications to block iTunes. So if you have, say, both Spotify and Songbird on your system and you want iTunes to interfere with neither, then this is for you. To install my version, follow Andrew's directions and replace his link with mine: http://www.cs.umd.edu/~dmonner/iTunes

    If you want to add or modify the applications that block iTunes, just edit new the "iTunes" file on the line that starts "apps = ", adding in the names of any apps who should prevent iTunes from running when they themselves are running.
    MBP 15" unibody / 2.53 GHz / 4GB, Mac OS X (10.6)
  • biskitwheels Calculating status...
    I have come up with another workaround for this pathetic attempt at whatever it is they are trying to do. It is much more simple than a script.

    I created an empty track that lasts over an hour. I tagged it so that it shows up in the beginning of my library. At least now, when iTunes launches on me, or when it is open and I don't know it, I get an hour before I hear anything. I may just duplicate this file a dozen times so I have a few days before I have to deal with this PITA "feature"

    I've uploaded the file to sendspace so you can grab it. It is a blank track, there is no need to worry about copyright infringement, I give you permission to trade this track freely and post the link wherever you wish.

    http://www.sendspace.com/file/0ff4uy

    If you can find a way to make sure this is at the top of the file by improving file name, please let me know.

    Enjoy the silence!
  • Jack Numick Calculating status...
    The issue extends to other remotes controlling your system. I have a Logitech Harmony One universal remote that is now opening itunes when I hit play/pause after the 10.6.0 update (the 10.6.1 update did not address the issue). Tried to updated the firmware of the remote with no lock I hit the forums.

    With all the programs available that could use the apple remote (or other brands) why would apple decide to default them to open itunes? I can deal with a default to that but at lease give me the option to disable it.

    Glad and disappointed to learn that I'm not the only one with this issue. I'll keep the itunes store open until a fix is made.
    PowerBook 17"
  • Michael Pitogo Calculating status...
    iTunes chews up too much cpu when I try to use a Mac Mini to display EyeTV on a 1080p system. Its barely able to push the frame rate, at 720p not a problem but...kiss is good. Mira switches between boxee, eyetv, hulu and plex.
    Mac OS X (10.6)
  • eddie832 Calculating status...
    I discovered the same issue last night trying to use my Harmony One remote (and Apple Remote). I can't stop iTunes from launching and playing automatically. Does anyone know if 10.6.1 fixes this? I'll try the update later tonight. If it doesn't work, I'm going back to Leopard 10.5.8 (which was working great to begin with).
    Mac Mini, Mac OS X (10.5.8)
  • runappelli Calculating status...
    I would also like to see an option to turn off this "feature" in 10.6... so please add me to the list.

    If iTunes is not running I don't want the play button to launch it.
    MacBook Pro, Mac OS X (10.6)
  • PittHockey Calculating status...
    This is so annoying, I can't believe apple didn't make it an option or preference somewhere.
    MBP v.2008 15", Mac OS X (10.6)
  • god0fgod Calculating status...
    I agree and want Apple to fix this immediately. I want a software update ASAP.

    I use Spotify and like to use the keys.
    Macbook White 2.13Ghz, Mac OS X (10.5.8)
  • Jonik9 Calculating status...
    Michael Pitogo wrote:
    iTunes chews up too much cpu when I try to use a Mac Mini to display EyeTV on a 1080p system. Its barely able to push the frame rate, at 720p not a problem but...kiss is good. Mira switches between boxee, eyetv, hulu and plex.


    Then start QuickTime Player instead of iTunes (but don't open any movie); this will have the same effect.

    Credits for the tip belong to this post on Super User: http://superuser.com/questions/31925/stop-play-pause-button-opening-itunes-in-sn ow-leopard/35296#35296
    Black 2.4 GHz MacBook, Mac OS X (10.6)
  • fuelie Calculating status...
    I've been annoyed by the fact that every time I insert an audio CD into my IMAC, Itunes loads automatically. After searching some 2001 forums on machints.com, I realized that all I had to do to stop this was to go into System Preferences under CDs & DVDs, and set the bottom 3 options ( insert music CD, picture CD, video DVD ) to ignore. Now, I'm not forced to exit Itunes every time I insert a disk. I can choose to open Itunes or choose to open another program or run a script, or just ignore the event.

    Another thing I learned is that the great free utility, TinkerTool, allows one to remove, hide, deactivate, or rearrange login items by drag and drop. Rearranging the order of login items can't be done from System Preferences. Only Apple OS icons on the menubar can be moved by drag and drop, or removed all together by dragging them onto the desktop.

    Under TinkerTool, one extra login item is shown, apparently hidden from sight in System Preferences, called ItunesHelper.app. This can be deactivated also, and it may solve the problem some of you guys are having with Itunes popping up with other programs. For me, it doesn't matter.
    IMAC, Mac OS X (10.5.6)
1 2 3 4 5 ... 20 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.