Skip navigation
This discussion is archived

no tethering on officially unlocked iPhone

48095 Views 413 Replies Latest reply: Feb 11, 2010 9:54 PM by MacAdamy RSS
  • Azm0d3uz Calculating status...
    Currently Being Moderated
    Sep 11, 2009 12:25 AM (in response to janus19)
    I don't see any problem if a carrier together with Apple disable selectively the tethering for commercial reasons.

    What is totally unacceptable is that Apple disable an advertised feature (modem) also for carriers that allow the tethering without any limitation to their customer
    Mac OS X (10.6)
  • max0479 Calculating status...
    Currently Being Moderated
    Sep 11, 2009 12:51 AM (in response to Azm0d3uz)
    I live in Belgium, I do have a unlocked 3GS iPhone and I also lost tethering function... My operator (Mobile Vikings on BASE network) officially allows tethering !
    iPhone, iPhone OS 3.0.1
  • dtsomp Calculating status...
    Currently Being Moderated
    Sep 11, 2009 3:49 AM (in response to janus19)
    Same here. I have an officially unlocked iPhone 3G and I used tethering for months on different operators (a greek and a swedish one) that officially allow tethering. Updating to OS 3.1 broke tethering. This is Apple's fault - simple as that.
  • German Apfel Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 11, 2009 6:05 AM (in response to dtsomp)
    Hello guys!

    I have an factory unlocked iPhone 3G, too. After the launch of the 3.0 software, I downloaded a mobileconfig-file like all of you did and tethering was and is working fine since today. While the first betas of 3.1 launched, I heared of problems with tethering and this mobieconfigs and contacted my provider. I am at o2 Germany, they allow tethering and since a few weeks VoIP, too. O2 is not the official varrier here in Germany, but in fear of disableing tethering with 3.1, I wrote a support ticket to o2 and got EVERY settings, beginning with MMS over APN and amobileconfig file. I thougt I was on the safe way with this file, but a friend of mine, who also uses o2 with his iPhone, lost the tethering-functionallity after updating to 3.1. After I heared about this desaster, I haven't updated yet.
    On wendsday I contacted the o2 support again. They told me, that they son't have any information if 3.1 can do tethering on o2. I hope they can find any workaround or anything else forsolving the tethering problem.
    iPhone 3G, iPhone OS 3.0.1, factory unlocked on o2 Germany
  • Digital Kurtz Calculating status...
    Currently Being Moderated
    Sep 11, 2009 6:15 AM (in response to janus19)
    update: after about an hour of using my computer tethered to my macbook i lost connectivity only to find that the phone (as you all have mentioned) had deleted my tethering option and thusly, disabled that connection port in my network prefs. Anyways, that sucked lol, on the phone now with att reactivating my express-card mobile modem.
    15" MacBook Po Core 2 Duo 2.2GHz, Mac OS X (10.4.10)
  • Delputte Calculating status...
    Currently Being Moderated
    Sep 11, 2009 7:26 AM (in response to janus19)
    Apple shouldn't be doing this. I have an officially unlocked iPhone (I live in Belgium) and my carrier allows tethering. I don't see why Apple has to block this feature for all iPhone users just because AT&T wants this functionality to be blocked. If Apple wants to represent themselves as global company, they should not block tethering based on a request of one company in one country.
    Macbook Air, Mac OS X (10.6)
  • Azm0d3uz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 11, 2009 7:30 AM (in response to Delputte)
    I suggest to try to complain with Apple as much as possible. Let's try also using this form:
    http://www.apple.com/feedback/iphone.html
    Mac OS X (10.6)
  • stebby Calculating status...
    Currently Being Moderated
    Sep 11, 2009 9:57 AM (in response to Azm0d3uz)
    ha - i suggested an alternative "technical" solution here involving product made by other companies and soon to end contract with iphone carries - looks like apple is not impressed LOL


    you know I'm right guys.

    ATT might have some stupid ideas about being able to charge twice for network access for browsing and email (here's a thought guys - I own the iphone screen and the macbook air screen - you own the network - capiche?) but others don't...
  • stebby Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 11, 2009 9:58 AM (in response to stebby)
    so, answer me this - who made the stupid @$£@$£@ decisions on this while Steve was away, and how on earth is he going to climb you guys back down the ladder?
  • stebby Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 11, 2009 10:01 AM (in response to stebby)
    anyhooo - the technical solution to your guys problem is not to upgrade to 3.1. Stay with 3.0.1 and you will be happy campers. Presumably Apple will eventually remove this "feature" - since ultimately its going to hurt them.
  • CHIA Chin Yau Calculating status...
    Currently Being Moderated
    Sep 11, 2009 1:12 PM (in response to janus19)
    Me too with iPhone 3G legal unlocked version, using unofficial carrier Celcom in Malaysia, and got screwed when I updated to 3.1 beta 2 earlier.

    Fortunately able to downgrade to 3.0 and subsequently 3.01.

    The problem is the default carrier bundle UNKNOWN.IPCC which leaves the signed APN blank and you cannot sign the IPCC unless you are a carrier with Apple.

    I am waiting for a solution, whichever will allow me to tether but I am not going to the official carrier Maxis since their plans are far too expensive comparatively.
    Macbook, iPhone 3G, iPhone 3GS, Mac OS X (10.6), iPhone 3G iPhoneOS 3.01, iPhone 3GS iPhoneOS 3.0
  • deggie Level 8 Level 8 (44,860 points)
    Currently Being Moderated
    Sep 11, 2009 2:20 PM (in response to Azm0d3uz)
    Have you also tried calling AppleCare?
    MacPro Dual Core 2.66 Ghz, MacBook Pro 15", iPhone 3G, Mac OS X (10.6), AEXs, Red 2G Nano, Red Shuffle, 160 GB Classic, White 60GB 5G, Apple TV
  • Ashtal Calculating status...
    Currently Being Moderated
    Sep 11, 2009 6:48 PM (in response to janus19)
    I am also in the same boat.

    Updated to 3.1, and the other night between 6-8pm Eastern I was at a coffee shop and needed a reliable connection. The tethering was there, it asked USB or Bluetooth, I selected USB, plugged it in, and then it was gone.

    I am in Canada, I have a locked phone and a Rogers contract that allows tethering. What's going on? My boyfriend hasn't updated to 3.1 yet and I told him not to. He needs tethering for when he's out of the office.

    Is there a (legal) way I can go back to a previous version? I was going to just do a restore before I found the thread here.

    Really kinda bummed about this. I've been keen to upgrade as soon as a new update drops, but I'm going to wait next time and see what bugs crawl out of the woodwork first.

    Message was edited by: Ashtal
    Macbook, Mac OS X (10.5.4), Brand Spankin' New
1 2 3 4 5 ... 28 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.