Skip navigation
This discussion is archived

No Content in iPod part of iPhone after syncing with OS 3.1 and iTunes 9

166628 Views 288 Replies Latest reply: Jan 8, 2011 3:25 PM by UFGUY RSS
  • Hofferama Calculating status...
    Put me down as having the "No Content" issue as well. I've restored my iPhone 3 times now to fix it. The last time I even restored my iPhone as a new phone thinking maybe my backup was bad. Just did my morning sync and the problem is back.

    I'm extremely annoyed by all this. I use my iPhone a lot for podcasts and such. This problem just kills it.
    MacBook, Mac OS X (10.6.1), The metal kind.
  • Hofferama Level 1 Level 1 (0 points)
    I'm syncing my old iPod nano right now. I'm thru using the iPod part of my iPhone until Apple fixes this.
    MacBook, Mac OS X (10.6.1), The metal kind.
  • etkal Level 1 Level 1 (20 points)
    I performed a restore on my work system (which of course explicitly deleted all the music since I don't sync it there), then went home and synced to restore the music (and apps). Now I'm back at work and everything appears to be ok again.

    Whatever this bug is, it's nasty!!!
    HP, Windows Vista
  • JoradZero Calculating status...
    iPhone 3.1 = No Content. Restore to 3.0 = content (an hour later). Sync = installed 3.1 WITHOUT ASKING ME = No Content.

    Apple, get your act together and at least POST A RESPONSE TO THIS ISSUE.

    I'll be the guy at 1 Infinity Circle banging on your door today so you can answer your customer's questions regarding this debilitating issue. It appears to be the only way to get an answer from you.
    Frankenstien, Windows Vista
  • Mad Clown Calculating status...
    Just wanted to chime in and say I'm having the exact same problem after updating to OS 3.1. I sync automatically via playlists and update my podcasts every day with a smart playlist. I update all my podcasts in the library, then sync. iTunes says sync is complete, but iPod on the phone says "No Content". When I look at the info on the iPhone, all the space is occupied (20-odd gigs occupied, 9-odd gigs free), but the video and music count are both 0.

    The previous suggestion of making one change and resyncing in iTunes works for me so far, but this bug is a huge hassle. It took over an hour to update yesterday, making me late for work, and then when I got in the car and saw "No Content", I was not happy. I'm glad I checked today after getting my new batch of podcasts or else it would have happened again.
    HP
  • eddyrose13 Calculating status...
    This has happened to me as well now. The last few purchases from itunes have stayed on but everything else doesn't show up unless conected to itunes when it shows up fine under the music tab.

    Oh and might I add the 4 albums that have stayed on are all on there twice.
    Message was edited by: eddyrose13

    Message was edited by: eddyrose13
  • TAFB Calculating status...
    I also had the no content error (iphone showing no content even though content would show up in itunes as being on the iphone). Here is the fix that worked for me (so far): I updated genius (click on STORE, then UPDATE GENIUS). After the genius update was complete, I synched the iphone, and the content came back.
    Mac, Mac OS X (10.5.4)
  • iPhone in HK Calculating status...
    I'm in the exact same boat! It worked fine for the past few days, all of a sudden iPhone decided to update library this morning...
    PC, iPhone OS 3.0.1
  • ndaversa Calculating status...
    Me too. So annoying, don't feel like doing a restore, grrr...

    Apple Fix now!

    iPhone 3GS/iTunes9/iPhone OS 3.1
    iPhone 3GS
  • sevenofvelvet Calculating status...
    Yet another new iPhone user disappointed by the brokenness of this software update. At first, after I updated, I had no iPhone content whatsoever, factory-installed or otherwise, and I couldn't even turn it on. I spent all day (unsuccessfully) trying to figure out what had gone wrong and what I could do to fix it. It kept failing to complete restore attempts. Finally when my husband (the technology-savvy one of us) got home he was able to complete the restore and even get all my contacts, purchased apps, and calendar data back - everything but my iTunes content. And like everyone else, when I try to sync the phone, it looks like my music is there, but the phone keeps telling me, 'No Content'. I've tried a number of different solutions that others on this board have proposed: using a different USB cable, adding or removing a song in my laptop iTunes library, etc. I haven't tried messing around with Genius but I don't have it activated. I also haven't tried doing another restore - that's my last option.

    This is especially frustrating because getting the iPhone was a huge step up for me - my previous cell phone was a basic-level Nokia that I'd had for 6 years. I liked the iPhone because it had many functions in one device and was a very useful tool as well as a fun toy. Having this problem when I've only had the phone for 2 months is very disappointing. (As I grumbled to my husband, 'Developers and programmers, if you'd just write your d*mn code correctly in the first place, you wouldn't have to issue updates every 15 frickin' minutes!)

    I've made an appointment for someone from Apple Support to call me about this issue on Friday the 18th; if I learn anything that seems useful, I'll post it.

    --seven
    Dell Inspiron 2200, Windows XP, iPhone 3Gs 32 GB
  • eddyrose13 Level 1 Level 1 (0 points)
    Well mine seems to have fixed itself. I deleted one song and after the sync it all came back again. I shan't be pluging it into itunes again until I'm sure they have this problem sorted. Hope everyone else gets on okay with their's.
  • byfordscrafts Calculating status...
    I THINK I HAVE THE ANSWER. I just got off the phone with Apple Tech Support. It looks like, during the iTunes 9 update, the link to the music was broken. I had to go into my music library, highlight, right click, and delete all of my music (HOWEVER, click yes to delete but if the music is IN iTunes it will ask whether you want to Keep files or send to Recycle bin, KEEP!!!). Then in iTunes go to File/Add File OR Folder to Library (if you have individual songs, do file, if you copied whole CDs, choose folder). This will import the songs back into iTunes and reconnect the broken link. I also found that I had to DELETE all songs in a PLAYLIST and re-add them.

    GOOD LUCK!!!
    PC, 3Gs
  • welwyn Calculating status...
    I tried this..
    At first blush it appears to work
    Did not disrupt my audible books nor music videos
    However, re-creating a whole lot of playlists will take time!
    various, Windows Vista
  • sevenofvelvet Level 1 Level 1 (0 points)
    byfordscrafts wrote:
    I THINK I HAVE THE ANSWER. I just got off the phone with Apple Tech Support. It looks like, during the iTunes 9 update, the link to the music was broken. I had to go into my music library, highlight, right click, and delete all of my music (HOWEVER, click yes to delete but if the music is IN iTunes it will ask whether you want to Keep files or send to Recycle bin, KEEP!!!). Then in iTunes go to File/Add File OR Folder to Library (if you have individual songs, do file, if you copied whole CDs, choose folder). This will import the songs back into iTunes and reconnect the broken link. I also found that I had to DELETE all songs in a PLAYLIST and re-add them.


    Hey byfordscrafts, I'm guessing you're performing these functions on your computer rather than on the iPhone itself. I'm also guessing that after taking these repair measures, one should re-sync the phone. Am I correct? Just making sure, I'm technologically challenged! Thanks for posting!

    --Seven
    Dell Inspiron 2200, Windows XP
  • Sawbones64 Calculating status...
    Well, I have been having this problem since before Aug 27 and with OS 3.0.1. See my post back then. I spoke to an Apple support tech who was very nice and made me go through a clean restore (ie.as new phone). That worked for a while but my issue has returned. I have not "upgraded" to OS 3.1 because of all the people having issues with shutdowns and comas. So I am not sure it is necessarily 3.1 related, though there does seem to be a lot more people with the problem now. It seems to me like the processor is trying to update the library and crashes, maybe lack of memory or something. Seems more frequent if I have a lot of music on the phone ie. more than about 1000 songs +/-. Also, i noticed that a lot of people with this problem are on Vista 64 fwiw. My work around has been to remove an app and then resync. Doesn't always work though. I feel your pain, very frustrating.
    Vista Ultimate 64, iPhone OS 3.0.1
1 2 3 4 5 ... 20 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.