Previous 1 2 3 4 5 6 Next 694 Replies Latest reply: May 22, 2014 3:56 PM by SantaFe67 Go to original post
  • Keithos Level 3 (520 points)
    I had this problem on an earlier installation of Snow Leopard as well (earlier this week). I turned on my MacBook Pro and all of a sudden the computer was up and running but with no menu bar at the top of the screen... The icons on the upper right-hand side were there (very hard to see against the wallpaper) but the menu bar was missing... and the Finder icon in the Dock did not have a little light underneath it. I tried clicking on the Finder icon to launch Finder and that's when I got that error.

    I've since then formatted my MacBook Pro because I thought that was a really serious issue and I couldn't have Finder messing up on me like that. Well I just went through and re-installed everything... took an entire day. This morning I successfully installed iLife 09. I rebooted, ran Software Update and successfully installed 6 updates (all iLife 09 related).

    I rebooted again, and then bam the menu bar is missing again. No Apple logo on the top left-hand corner so I launched Safari (so the menu bar would appear) and then did an Apple-Restart.

    Really annoying here Apple... Snow Leopard has had so many quirks already.

    Does anyone know if the above-mentioned will corrupt or "harm" my computer in any way? I don't really want to sit here all day and reinstall everything but if things are corrupt, etc I'd rather get this fixed sooner rather than later.

  • Sp0k Level 1 (10 points)
    I already reported this to the list. So I went through the same spiel like you and only things that I did not install was 1.6.1 update. So I am running 1.6.0 w/o any issues so far.
  • Sylense Level 1 (5 points)
    I just experienced this problem for the 2nd time tonite. This time, I noted two things:

    1.) I clicked on my MobileMe iDisk earlier
    2.) I put my laptop to sleep and then woke it up

    The common thread seems to be mounted disks.
  • Keithos Level 3 (520 points)

    I never do either of those things, so those aren't common causes.

    Also I've experienced this problem straight from a cold start...
  • Heejong Level 1 (0 points)
    Same issue here. I'm using 10.6.1 and mid 2009 Macbook Pro. The finder has suddenly frozen two times in the last week. Of course, It can't be reopened. Hard reboot would be the only solution. I have no external hard drives. It just happens randomly.
  • Fizwidget Level 1 (80 points)
    The same problem happened to me today. I was browsing some files on my USB drive, and the beachball of death appeared. I waited several minutes, then tried to relaunch Finder. I got the error message "The application Finder can't be opened. -10810".

    After trying this several more times, I initiated a shutdown. It got stuck on the pale blue screen with the spinning icon, so I held the power button and forced the shutdown.

    What a mess! Hopefully Apple will fix this annoying problems soon.

    I'm running 10.6.1 by the way.

    Message was edited by: Fizwidget
  • quaker120 Level 1 (0 points)
    Me, too. I get it when trying to access samba shares after the machine has woken up from sleep. Tried manually unmounting volumes, etc. Nothing works & have to reboot. Very annoying.
  • Osolemio Level 1 (10 points)
    Same here! Plugged in a laptop via Firewire a few times, copying stalled and then relaunching the Finder caused the error.

  • abril05 Level 1 (0 points)
    Hi, first of all I'm sorry for my English (I'm from Spain), it's the first time I write in a english forum.
    I've spent all this morning looking for this problem. I have exactly the same problem as you (the missing bar menu).
    I haven't re-installed anything since this problem appeared, and neither clicked on the Finder icon, so that the problem "The application can't be opened" doesn't ocurred to me, simply I don't realize this.
    The problem with the "missing bar menu" appeared when I modified my preferences settings in order to change my desktop wallpaper in every start up. I've tried with several options like "every day",...etc. But always the same problem. The bar appeared when I made right-click on the desktop to change preference settings again, or simply changing desktop with spaces.
    This morning I removed the mark from the option "translucent bar", restart my computer and the menu bar appeared apparently without problem. And another thing, when the computer starts the finder tries to load a wallpaper (it can be seen just a split second) but immediately loads another one...
    Does anyone else have this problem?
    What could be the solution?

    Thank you very much
  • Rafael Figueroa Level 1 (5 points)
    This just happened to me as I turned on my external USB drive. The Finder had an hysterical attack, threw up its proverbial hands in the air and gave the infamous "The application can't be opened. -10810" ultimatum.

    This little stunt ended up causing directory damage on the drive (Disk Utility fixed it up.)

    abril05: it sounds like your drive may have some issues. Disk Utility may be able to fix them up (it usually does for me.) Welcome to the board.
  • Arthur Sorkin Level 1 (0 points)
    I had the finder die and got that message. I had terminal running and ps -ax showed the finder app
    still had a process, so I did "kill -HUP pid" where pid was the process number, and the Finder restarted.
  • aladdin Level 1 (140 points)
    Hi all, I do have this fatal *Finder crash* multiple times a day But not only the Finder seems very unstable to me, also Quicktime crashes regularly, Safari, ARD and Keychain problems are frequent and of course many *driver issues* have been detected here.

    I'm working as a System Administrator and actually I only took over 4 of all our Macs, 3 Mac Pro and one iMac. The most problems are reported from the Mac Pros, but that's not objective as the iMac is not being used the same way in production. The problems also are not the same everywhere: one has more QT issues, the other one completely messed up the Keychain and Safari, ARD is not stable all over the place, but the Finder crashing seems to be present on the them all...

    The kill-process trick did not work here until now; the desktop cannot even be accessed anymore and connecting with ssh did not resolve the problem; my only solution is to pull the plug!

    By the way, all these Macs have been running very stable under Leopard! Two of them have been updated and the third Mac Pro (the one with the Safari and Keychain problems) has been reinstalled from scratch! I also believe that it's not an operator/administrator problem as I successfully support our Mac Farm for 10 years now and think I have a very good knowledge of the product.

    *My opinion:* _keep away from Snow Leopard in production until a stable release will be available!_

    I think Apple had to release SL early for competition reason while the product was not yet ready. I seriouly think about downgrading the 3 Mac Pro's back to Leopard next week...
  • alleksu Level 1 (0 points)
    I also have had the same basic issue several times now.

    In my situation:
    MacBook Pro running 10.6.1
    No external drives or mounted network drives
    (Only 2 USB devices plugged in: keyboard + mouse; wired ethernet, airport off)
    The trigger may have been dragging an item to the trash.
    Screen shot of the error:

    I gradually lost the ability to do anything on the system. At first I couldn't open Finder windows or alt-tab, which means I was basically limited to the windows I already had open. I tried to get to Terminal, but all my keystrokes were going to my Firefox process. I could select things from the menubar, but there wasn't any result to doing so. Left with only Firefox I couldn't guess of a way of fixing anything.

    Luckily (?) I have remote access on and could determine my IP address, so I could ssh into my laptop from another machine. I saw that Finder wasn't running, so I tried to launch it, but the command line gave me the same error:

    open /System/Library/CoreServices/

    LSOpenURLWithRole() failed with error -10810 for the file /System/Library/CoreServices/

    I tried a kill -HUP of the Dock followed by an open, but that didn't accomplish anything. Not being too familiar with OSX I looked for other processes to try restarting and decided windowserver sounded like a good one. Poor choice; it basically instantly logged my account out, which isn't much better than just holding down the power button since it killed my open processes. Next time I'll try something else.
  • Hirendra Hindocha Level 1 (5 points)
    I had a similar problem post Snow Leopard installation. When I logged into my account, I could only get the applications that were in my login items. No Dock, No Finder. But another account on the laptop did not have any issues.

    I could not open Finder from the terminal either and I finally solved the problem by moving everything out of ~/Library and restarting.
    Once I did that everything worked fine.

  • WilsonLaidlaw Level 1 (0 points)
    I have spoken twice to Applecare. They either don't seem to know this 10810 issue exists or are in denial. Their only suggestion is a clean re-install - pathetic. I have already done a re-install with no improvement. Like others, I am sure it is related to external hard discs not waking properly, having gone through syslogs in detail. There is an Apple support thread suggesting that you buy!!!!!!! a shareware program called Cache Cleaner. I have done this - I would like my money back it is no **** use at all. It would be nice if just for once Apple would acknowledge the existence of an issue and let us know they are working on it for the next upgrade.

Previous 1 2 3 4 5 6 Next