Skip navigation
This discussion is archived

Disk Utility Crashes after Snow Leopard Install

4936 Views 14 Replies Latest reply: Dec 5, 2009 8:37 AM by Thomas von Eyben RSS
sirsky Calculating status...
Currently Being Moderated
Sep 13, 2009 6:55 PM
Every time I try to open Disk Utility, it crashes HARD. Here is the error:

Process: Disk Utility [184]
Path: /Applications/Utilities/Disk Utility.app/Contents/MacOS/Disk Utility
Identifier: com.apple.DiskUtility
Version: ??? (???)
Build Info: DiskUtility-2980000~29
Code Type: X86-64 (Native)
Parent Process: launchd [127]

Date/Time: 2009-09-13 20:45:09.843 -0500
OS Version: Mac OS X 10.6.1 (10B504)
Report Version: 6

Interval Since Last Report: 3983 sec
Crashes Since Last Report: 15
Per-App Crashes Since Last Report: 10
Anonymous UUID: 8D0820C2-E83E-44D4-8BCB-62D79F2632E5

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread: 0

Dyld Error Message:
Library not loaded: /System/Library/PrivateFrameworks/PlatformHardwareManagement.framework/Versions /A/PlatformHardwareManagement
Referenced from: /System/Library/PrivateFrameworks/ServerFoundation.framework/Versions/A/ServerF oundation
Reason: no suitable image found. Did find:
/System/Library/PrivateFrameworks/PlatformHardwareManagement.framework/Versions /A/PlatformHardwareManagement: no matching architecture in universal wrapper

Model: MacBookPro5,1, BootROM MBP51.007E.B00, 2 processors, Intel Core 2 Duo, 2.66 GHz, 4 GB, SMC 1.41f2
Graphics: NVIDIA GeForce 9600M GT, NVIDIA GeForce 9600M GT, PCIe, 512 MB
Graphics: NVIDIA GeForce 9400M, NVIDIA GeForce 9400M, PCI, 256 MB
Memory Module: global_name
AirPort: spairportwireless_card_type_airportextreme (0x14E4, 0x8D), Broadcom BCM43xx 1.0 (5.10.91.19)
Bluetooth: Version 2.2.1f7, 2 service, 1 devices, 1 incoming serial ports
Network Service: AirPort, AirPort, en1
Serial ATA Device: Hitachi HTS543232L9SA02, 298.09 GB
Serial ATA Device: MATSHITADVD-R UJ-868
USB Device: Built-in iSight, 0x05ac (Apple Inc.), 0x8507, 0x24400000
USB Device: Apple Internal Keyboard / Trackpad, 0x05ac (Apple Inc.), 0x0236, 0x04600000
USB Device: IR Receiver, 0x05ac (Apple Inc.), 0x8242, 0x04500000
USB Device: Sennheiser USB Headset, 0x1395, 0x0002, 0x04100000
USB Device: BRCM2046 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0x06100000
USB Device: Bluetooth USB Host Controller, 0x05ac (Apple Inc.), 0x8213, 0x06110000

It crashes both using the 32-bit kernel and 64-bit kernel, I've reset the PRAM, still no dice. Interestingly, after booting from the 10.6 install CD, and running the exact copy of Disk Utility from my HDD (NOT the one on the CD) via console, it works without a hitch.

Any ideas?
MBP 5,1, Mac OS X (10.6)
  • Carolyn Samit Level 10 Level 10 (84,160 points)
    Currently Being Moderated
    Sep 13, 2009 7:00 PM (in response to sirsky)
    Hi,

    Try deleting this file.

    com.apple.DiskUtility.plist

    /Users/YourName/Library/Preferences.

    Drag that file to the Trash, empty the Trash and restart your Mac.






    Carolyn
    Intel iMac 2.66 Snow Leopard, Mac OS X (10.6), iPhone 3GS PBookG4 iBookG4 Intuos Tablet Epson Olympus Airport iPods JBL
  • KJK555 Level 4 Level 4 (2,895 points)
    Currently Being Moderated
    Sep 13, 2009 9:17 PM (in response to sirsky)
    be sure the permissions are correct on it:
    (via console)

    sudo chown -R root:admin /Applications/Utilities/Disk\ Utility.app

    sudo chmod -R =rw,+X /Applications/Utilities/Disk\ Utility.app

    Kj
    Mac Pro Mac OS X (10.6.1), , Win XP  "What!?, you didn't back it up?" 
  • tncook Calculating status...
    Currently Being Moderated
    Sep 14, 2009 7:13 AM (in response to sirsky)
    Cool, I am having this problem too. I was also getting the same error when launching the 10.6 Versions of Workgroup Manager and Server Admin.

    Off to another 10.6 machine.
  • tncook Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 14, 2009 8:34 AM (in response to tncook)
    That did it! Awesome. Thanks.
  • KJK555 Level 4 Level 4 (2,895 points)
    Currently Being Moderated
    Sep 14, 2009 11:03 AM (in response to sirsky)
    Just curious, did you upgrade by booting from the SL DVD or did you start the install from the
    desktop first?

    I had problems when I started the install from the 10.5 desktop, but had no problems when
    starting directly from DVD and simply selecting the volume I wanted to install to. It upgraded properly
    using the boot from DVD method.

    Glad you found a solution.

    Kj
    Mac Pro Mac OS X (10.6.1), , Win XP  "What!?, you didn't back it up?" 
  • RHKFilm Calculating status...
    Currently Being Moderated
    Sep 22, 2009 8:44 AM (in response to sirsky)
    I had the same issue. Also, Activity Monitor would hang upon launching it. I considered doing the whole "use Pacifist to extract updated Hardware.platform from the Snow Leopard install CD" but it failed checksum so there was no way I was going to rely on it as a critical system file.

    I installed 10.6.1 in hopes it would resolve the issue, and it did resolve Activity Monitor hanging, but disk utility still crashes. Off to the Genius Bar. ugh./
    17" MBPro Matte 2.93 unibody, Mac OS X (10.5.6)
  • dberreby Calculating status...
    Currently Being Moderated
    Sep 30, 2009 1:46 PM (in response to sirsky)
    I have this same problem with a number of apps -- Disk Utility, SugarSyn Manager, others that are crashing on startup.

    I'd love to try your solution but according to the Finder there is nothing called ``PlatformHardwareManagement.framework" anywhere on my hard drive, so I can't figure out how to replace it with a more recent file? Can anyone advise?

    Thanks!

    David
    Macbook, Mac OS X (10.6.1)
  • Revdhorse Calculating status...
    Currently Being Moderated
    Oct 23, 2009 5:27 AM (in response to sirsky)
    My DU was crashing upon launching after installing 10.6. Numerous trips to 'Genius' bar were unhelpful. Penultimate visit suggested reformatting by hard drive which i did (after backing everything up). 25hrs later same problem!! Not happy. Last return to 'genius' showed i was trying to launch an old PowerPC version of DU which i had moved from the Utilities folder on my Macbook. When i installed 10.6 it put the current copy of DU in the right place, but left the older version where i had moved it to (for convenience). Moral of the story for me was to not move system apps from their proper folders. If anyone else is having a similar problem, do a spotlight search for "Disk Utility" and see if more than one version is found on your Mac!
    Macbook, Mac OS X (10.6.1)
  • Thomas von Eyben Calculating status...
    Currently Being Moderated
    Dec 5, 2009 8:37 AM (in response to dberreby)
    I had the same problem (and cannot remember what the difference was between the installation on the to machines.
    Both have been installed from the same bootable harddrive with the SL image, but I THINK that I did it slightly different.
    One was booted from the SL installer, the other began the installation by double clicking the installer.
    Anyways - heres how to fix it.

    NOTE: 'SCP' will not work since it follows symlinks 'RSYNC' works handling symlinks as expected.



    1. To verify that the "PlatformHardwareManagement.framework" is indeed missing list the PlatformHardwareManagement.framework:
    TvE-iMac24 is BAD!
    TvE-MBP15 is GOOD!

    # A broken installation #
    TvE-iMac24:~ tve$ ls -lR /System/Library/PrivateFrameworks/PlatformHardwareManagement.framework
    total 8
    lrwxr-xr-x 1 root wheel 24 27 Sep 18:33 CodeResources -> Versions/A/CodeResources
    drwxr-xr-x 3 root wheel 102 22 Okt 17:19 Versions

    /System/Library/PrivateFrameworks/PlatformHardwareManagement.framework/Versions:
    total 0
    drwxr-xr-x 4 root wheel 136 22 Okt 17:19 A

    /System/Library/PrivateFrameworks/PlatformHardwareManagement.framework/Versions/ A:
    total 8
    lrwxr-xr-x 1 root wheel 28 27 Sep 17:58 CodeResources -> _CodeSignature/CodeResources
    drwxr-xr-x 3 root wheel 102 1 Aug 07:59 _CodeSignature

    /System/Library/PrivateFrameworks/PlatformHardwareManagement.framework/Versions/ A/_CodeSignature:
    total 0
    -rw-r--r-- 1 root wheel 1657 1 Aug 07:59 CodeResources

    # A working installation #
    TvE-MBP15:~ ladmin$ ls -lR /System/Library/PrivateFrameworks/PlatformHardwareManagement.framework
    total 24
    lrwxr-xr-x 1 root wheel 24 Aug 29 09:32 CodeResources -> Versions/A/CodeResources
    lrwxr-xr-x 1 root wheel 43 Aug 29 09:32 PlatformHardwareManagement -> Versions/Current/PlatformHardwareManagement
    lrwxr-xr-x 1 root wheel 26 Aug 29 09:32 Resources -> Versions/Current/Resources
    drwxr-xr-x 4 root wheel 136 Aug 29 09:34 Versions

    /System/Library/PrivateFrameworks/PlatformHardwareManagement.framework/Versions:
    total 8
    drwxr-xr-x 6 root wheel 204 Aug 29 09:34 A
    lrwxr-xr-x 1 root wheel 1 Aug 29 09:32 Current -> A

    /System/Library/PrivateFrameworks/PlatformHardwareManagement.framework/Versions/ A:
    total 296
    lrwxr-xr-x 1 root wheel 28 Aug 29 09:32 CodeResources -> _CodeSignature/CodeResources
    -rwxr-xr-x 1 root wheel 364464 Aug 29 09:33 PlatformHardwareManagement
    drwxr-xr-x 5 root wheel 170 Aug 1 07:59 Resources
    drwxr-xr-x 3 root wheel 102 Aug 1 07:59 _CodeSignature

    /System/Library/PrivateFrameworks/PlatformHardwareManagement.framework/Versions/ A/Resources:
    total 0
    drwxr-xr-x 3 root wheel 102 Aug 1 07:59 English.lproj
    -rw-r--r-- 1 root wheel 867 Aug 1 07:59 Info.plist
    -rw-r--r-- 1 root wheel 452 Aug 1 07:59 version.plist

    /System/Library/PrivateFrameworks/PlatformHardwareManagement.framework/Versions/ A/Resources/English.lproj:
    total 24
    -rw-r--r-- 1 root wheel 62163 Aug 1 07:59 PlatformHardwareManagement-IPMI.plist

    /System/Library/PrivateFrameworks/PlatformHardwareManagement.framework/Versions/ A/_CodeSignature:
    total 0
    -rw-r--r-- 1 root wheel 1657 Aug 1 07:59 CodeResources


    2. From the broken Mac use rsync to get a copy of the files back to the broken mac:
    sudo rsync -ave ssh ladmin@TvE-MBP15.local:/System/Library/PrivateFrameworks/PlatformHardwareManage ment.framework /System/Library/PrivateFrameworks/

    Replace username 'ladmin' and hostname 'TvE-MBP15.local' as appropriate
    Provide passwords as prompted.
    First the remote users (here "ladmin" then the local user (unless you have sudoed within the last five minutes)


    3. Now you have the correct permissions AND the files hence you'll be able to use both DiskUtility as well as Server Admin Tools (the latter also being "broke" and generting the same error in the logfiles.
    iMac 24" and a lot more, Mac OS X (10.6.2)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.