11 Replies Latest reply: Oct 22, 2009 2:55 AM by Ian Sommerville
herrgross Level 1 Level 1 (0 points)
hi folks,
since i updated from leopard to snow leopard i'm having permanent external drive problems.
connecting an external drive results in the message, that IOStorageFamily.kext is not properly installed.
after having installed 10.6.1 and removed two kext-files, that eyetv had installed, it worked for some time, but now it stopped working again. can anybody help me and tell me, what to do to make my external disks working again? problem is too that i'm travelling and left original install disk at home...
thanks
herrgross

MacBookPro 2.53 GHz Intel Core 2 Duo, Mac OS X (10.6.1)
  • 1. Re: external drive problems
    donv (The Ghost) Level 5 Level 5 (4,600 points)
    I have searched on your problem and have found nothing definitive. Are your Mac's operations being affected? I keep bumping into a possible relationship between the file and the color or style of drive icons. Does you drive icon look like an external? What color is it?

    Message was edited by: donv (The Ghost)
  • 2. Re: external drive problems
    herrgross Level 1 Level 1 (0 points)
    all operations on the computer are running normal - only there is no recognizing firewire drives, usb drives, cds. but my external usb number block is working, as well as the usb-dongle for software - and ethernet as well, so i have internet connect, as u can see...
    the internal drive icon on the desktop is just looking normal - gray harddisk symbol
  • 3. Re: external drive problems
    donv (The Ghost) Level 5 Level 5 (4,600 points)
    I see. My inclination would be to reinstall Sno over Sno via the upgrade route. Perhaps doing so would, for some small problem that is causing your issue. But, I know you don't have your disk with you. Maybe you could borrow an upgrade disk and try my solution. On the other hand, you probably don't want to foul your system completely while on the road.
  • 4. Re: external drive problems
    herrgross Level 1 Level 1 (0 points)
    well, reinstall would be difficult here in yerevan and risky too - i need to work with the machine...
    but, i have the idea maybe to exchange the IOStorageFamily.kext, because i think there might be something wrong in the plist. could u make a copy of your IOStorageFamily.kext from your macbook pro and send it to me? maybe that would help....

    Message was edited by: herrgross
  • 5. Re: external drive problems
    donv (The Ghost) Level 5 Level 5 (4,600 points)
    I would need your email address, and posting them is not OK here. I suppose you could make your email visible in your public profile. Let me know.
  • 6. Re: external drive problems
    herrgross Level 1 Level 1 (0 points)
    you can see it now.... thanx for helping me!
  • 7. Re: external drive problems
    donv (The Ghost) Level 5 Level 5 (4,600 points)
    I will be home in an hour or so and will do it. You are very welcome.
  • 8. Re: external drive problems
    herrgross Level 1 Level 1 (0 points)
    i copied your kext into my systemfolder now,
    luckily the computer is still working, but the problems stay the same...
    so the kext isn't the problem
    but nevertheless thanks for sending it
    so maybe tomorrow i'll try your boot.efi ...
    or does somebody here think i should definitely not?
  • 9. Re: external drive problems
    donv (The Ghost) Level 5 Level 5 (4,600 points)
    You are very welcome. Thanks for letting us know. I'll keep thinking about the problem and will post back if I come up with anything.
  • 10. Re: external drive problems
    herrgross Level 1 Level 1 (0 points)
    problem solved!
    well, checking out the IOStorageFamily.kext i found the very useful UNIX command kextutil.
    this showed me, that the owner and group settings of that kext were wrong - something had set it to my admin name (owner) and "staff" (group); so i changed them back to root:wheel with the chown command. then i found that something had replaced two parts of the kext (CodeDirectory and CodeResources in the _CodeSignature Folder) with just aliases... so i copied them from the kext the ghost sent me into there - and HEUREKA! it's working again! i have my access to firewire and usb devices back as well the access to my DVD drive... i hope it'll stay like that :))
    thanks for your help!
    michael

    Message was edited by: herrgross
  • 11. Re: external drive problems
    Ian Sommerville Level 1 Level 1 (0 points)
    Hi Michael,

    I have the same problem that you had. I'm pleased to see that there is a solution but please can you help me. I am not nearly as computer literate as you are. I would be most grateful if you could describe the process in a way that is simple.
    Can you help?


    Thanks


    Ian