Skip navigation
This discussion is archived

External TV Display is black and white when connect via DVI to S-Video

28261 Views 68 Replies Latest reply: Mar 29, 2010 4:44 PM by CalebGilbert RSS
  • cshamis Level 1 Level 1 (0 points)
    It is not a problem with the age of the hardware. This is a problem that exists in SL 10.6.1. The problem does not exist when I boot from my 10.5.6 backup on my external drive on the same machine.

    Message was edited by: cshamis
    Macbook Pro, iPhone, Mac OS X (10.6.1)
  • djbutt63 Level 1 Level 1 (5 points)
    Just a note to say that I have exactly the same issue. Reboot is required to get color output.
    Macbook Pro, Mac OS X (10.6.1)
  • gustavoe Level 1 Level 1 (0 points)
    I just found a solution... under Display Preferences I select the TV settings or secondary display, in my case NTSC/PAL and on the Refresh Rate I select 52 Hertz and that did it...

    Hope this helps!
    Macbook Pro, Mac OS X (10.6.1)
  • cshamis Level 1 Level 1 (0 points)
    That is strange indeed.
    North American NTSC CRT TVs can't sync on 52 Hz.

    But, in any case, I'm not going to go into the display perferences and flip the screen every time my mac comes out of sleep when connected to my TV. That's completely unsat.

    But, at least it saves me from rebooting until they fix it...

    -C.
    MacBookPro4,1, iPhone 3G, Mac OS X (10.6.1)
  • djbutt63 Level 1 Level 1 (5 points)
    Interesting, but connected to my New Zealand CRT I only get the options of PAL at 50Hz or NTSC at 60Hz, so that doesn't work for me.... still restarting every time I want to watch something on the TV, no fun at all.
  • ourwinter Calculating status...
    One more vote for this problem. MacBook Pro, 2.6GHZ, 4GB. The latest problem has been that the screen starts fritzing out and looping, as if I had an old Zenith TV that can't get a good signal. I don't know if it is just me but SLeopard is VERY buggy.
    MacBook Pro, MacBook Air, MacBook, Mac OS X (10.6.1)
  • Yannis Haralambous Calculating status...
    I have the same problem: MacOS X 10.6.1, 2.6 GHz Intel Core 2 Duo, 4 Go RAM. I tried all possible settings in the Monitors panel (including PAL/SECAM and PAL/NTSC), nothing changed. I didn't tried to reboot (because I can't simply close all my applications and reboot every time my daughters want to see a movie…). It is really time Apple fixes this bug. Will there be a 10.6.2 coming out soon?
    MacBook Pro, Mac OS X (10.6.1)
  • Clifford Hill Calculating status...
    I'm getting the same issue as others in the thread after installing 10.6.1 EXCEPT the output to my CRT television is rainbow colored with the spectrum of colors shifting like a gradient layer in Photoshop from left to right on the screen. However, the desktop and icons are all showing too, but in rainbow hues as does any video played via any application such as Boxee, Front Row, or via a browser, etc.

    I'm simply using the composite video out on the DVI analog video adapter dongle (the large format, not the mini since that came with later MacBook Pro models). When I plug in the dongle, the output is always rainbow colored.

    I tried messing with the refresh rate and other screen resolution sizes in the System Prefs without success. The only solution seems to be restarting with the dongle attached. Seems like this must be 10.6.1 since that installation was the only change before the problem started.
    MacBook Pro, Mac OS X (10.6.1), 15" 2.5GHz Intel Core 2 Duo, early 2008, NVIDIA GeForce 8600M GT
  • smcnichol Level 1 Level 1 (0 points)
    I'm having the same issue. It seems to rotate between black and white, color hued and blank. It works fine when the LCD screen is opened, so I'm sure it's not a hardware issue. Reported it, hopefully it gets resolved.
    MacBook Pro 2.4 GHz Intel Core 2 Duo, Mac OS X (10.6.1)
  • scott in towson Calculating status...
    i am using a DVI to video (RCA) to my Sony Trinitron flat screen TV. Everything had been working fine, I would disconnect the DVI and hookup the DVI to video adapter and watch movies on the video 2 channel on my Sony. Then I decided to change the screen resolution so the icons would be bigger on the Sony. Immediately the screen went to black and white and the v-hold began to flicker uncontrollably. There was no way to hook up the TV and navigate the mouse to anywhere as you could not see the pointer with the flicker being out of control. I attempted to change the resolution to every possible setting and refresh rate and nothing. It was as if I had permanently broken the TV or the device or something.

    I did notice the screen settings dialog box was DIFFERENT on the TV, even though I changed nothing from when it was hooked up to the monitor. It said NTSC/PAL and the refresh rate came up as 50 Hz. When I hooked the monitor back up the NTSC/PAL language was gone and the refresh rate was back to where it had been before, usually 60 or 75. There is no 50 Hz option when hooked up to my monitor.

    What do I do? Should i reboot with the TV hooked up?
    powermac g5, mac mini, Mac OS X (10.5.6)
  • logaan Calculating status...
    +1 same issue here! I hope apple will fix this soon!
    Macbook Pro 2.2 GHz Intel Core 2 Duo, 4GB 667MHz DDR2 SDRAM, Mac OS X (10.6.1), DVI to S-Video on a pal TV
  • J. R. Calculating status...
    Ditto for me. I am using a mini DVI video adapter to connect my MacBook to my TV to watch my videos. Since upgrading to Snow Leopard, my TV screen goes to black and white, is very fuzzy, and the image is off center. However, restarting while the adapter is connected has not worked for me. I also used the feedback link to let Apple know about the problem.
    MacBook, Mac OS X (10.6.1)
  • MeMooMeM Calculating status...
    Yup, same problem here. Happened after Snow Leopard upgrade. It even made me buy a new cable! I also installed Windows 7 with bootcamp, its TV out is just fine... Wait... What? On a MacBook Pro, something works on the Windows side but not on the OSX side? What is happening to you Mac guys!!?
    MacBookPro, Mac OS X (10.6.1)
  • Steven Littiebrant Level 1 Level 1 (20 points)
    Ditto here. An odd bug... makes showing videos a bit annoying.
    MacBook Pro, Mac OS X (10.6.1)
  • Jobbaman Calculating status...
    same problem here on an early 2008 macbook pro
    Macbook Pro C2D, Mac OS X (10.6.1)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.