Skip navigation
This discussion is archived

Spotlight language issues

1152 Views 9 Replies Latest reply: Oct 3, 2009 9:31 AM by Mr J Psycho RSS
chris10.6 Calculating status...
Currently Being Moderated
Sep 10, 2009 4:20 AM
Apologies if this has already been posted.

After an install of Mac OSX 10.6 on a Macbook Pro (version before the unibody) Spotlight is displaying certain programs like textedit in a foreign language, anyone else have this problem. Or encountered similar issues elsewhere.

And more importantly, does anyone have a solution please?
Macbook Pro, Mac OS X (10.6)
  • Feek Calculating status...
    Currently Being Moderated
    Sep 23, 2009 2:26 AM (in response to chris10.6)
    I upgraded Leopard to Snow Leopard on my Mac Pro and had the same problem, I tried deleting the spotlight preferences but it made no difference. I also tried deleting various caches but it still made no difference to this.

    I ended up making a fresh Snow Leopard installation.

    The same thing happened when I upgraded my Macbook Pro! I've done nothing to try and fix it yet as I've not had the time but would appreciate a fix for this annoying problem.
    Mac Pro (Early 2008), Macbook Pro (Late 2008), Mac OS X (10.6.1)
  • Christopher Akira Martin Calculating status...
    Currently Being Moderated
    Sep 23, 2009 2:33 AM (in response to chris10.6)
    I also have the same problem, but don't have a solution. All the applications are displayed in Japanese, since I had to buy Snow Leopard in Japan. Did you install OS X from the region you are in? It's very annoying as currently I use it as an app launcher.

    Maybe you can edit the .plist or .strings file (If you know how to, since it can foul up the system) to solve the problem.
    MacBook Pro, Mac OS X (10.6.1)
  • Feek Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 23, 2009 2:49 AM (in response to Christopher Akira Martin)
    I installed for the correct region, without a doubt. The text I get appears in Japanese/Chines style characters as well.
    Mac Pro (Early 2008), Macbook Pro (Late 2008), Mac OS X (10.6.1)
  • Christopher Akira Martin Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 23, 2009 3:01 AM (in response to Feek)
    I'll love Apple even more if this problem is fixed, Feek. Guess that the only solution is a update, but you can edit names like

    NAME VALUE
    XXXXXXX.app テキストエディット
    change to EeeeeEeeee.app in the VALUE part inside the xxxxxxxxx.lproj folder in the "Contents" of each app where x is the whatever language and e is the language you want it to be.
    Long way around, but might help.
    MacBook Pro, Mac OS X (10.6.1)
  • Tom Gewecke Level 9 Level 9 (70,865 points)
    Currently Being Moderated
    Sep 23, 2009 4:48 AM (in response to Christopher Akira Martin)
    since I had to buy Snow Leopard in Japan.


    OS X is the same no matter where it is sold, and the user interface language can be changed in few seconds via system preferences.

    As for the spotlight issue, have you seen the other threads like this one?

    http://discussions.apple.com/message.jspa?messageID=10267272#10267272
    iMac Intel/2C2D, eMac G4/700, Mac OS X (10.6), 10.5, 10.4, 10.3, 9.2
  • Feek Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 23, 2009 8:17 AM (in response to Tom Gewecke)
    The solution in that thread fixes the issue for me, thanks for the link.
    Mac Pro (Early 2008), Macbook Pro (Late 2008), Mac OS X (10.6.1)
  • Mark Sieber Level 1 Level 1 (15 points)
    Currently Being Moderated
    Sep 30, 2009 7:42 AM (in response to Feek)
    I am a U.S. user, and was getting Swedish in Spotlight--which I use as an app launcher--for some applications, notably Address Book.

    I went to System Preferences/Language & Text to see which languages were checked. When installing 10.6 I had only included a few languages, and while these were ordered below U.S. English, there were a another half-dozen languages above it in the list which I didn't think I had installed, topmost was Swedish. I unchecked this and the other languages (I thought) I hadn't included on the install.

    Thereafter, Spotlight showed Japanese instead of Swedish--and it wasn't anywhere on the System Preferences list!

    So I unchecked everything but U.S. English ('English' had never been checked) but with no resulting change in Spotlight behavior.

    I then went off to repair permissions and dragged out the appropriate pref file, but with no success.

    After a couple of days of web searches, I found a hint here:

    http://archicadtalk.graphisoft.com/viewtopic.phpp=153991&sid=dff1eb2496add561d49 2fa83ec7eb42a

    I selected both 'English' and 'US English' in System Preferences/Language & Text and my Spotlight is now displaying the previously problematic app names in English.
    MacBook Pro 2007, Mac OS X (10.6.1), LaCie Firewire B/U. Network--Airport Extreme, Maxtor HD
  • Tom Gewecke Level 9 Level 9 (70,865 points)
    Currently Being Moderated
    Sep 30, 2009 9:15 AM (in response to Mark Sieber)
    When installing 10.6 I had only included a few languages, and while these were ordered below U.S. English, there were a another half-dozen languages above it in the list which I didn't think I had installed, topmost was Swedish. I unchecked this and the other languages (I thought) I hadn't included on the install.


    There isn't any connection between what is on the list in system prefs/language & text/languages and what you install. If you click on the Edit button you should see upwards of 100 languages you can add to the list, which serves various purposes in setting OS language priorities.
    iMac Intel/2C2D, eMac G4/700, Mac OS X (10.6), 10.5, 10.4, 10.3, 9.2
  • Mr J Psycho Calculating status...
    Currently Being Moderated
    Oct 3, 2009 9:31 AM (in response to chris10.6)
    Yes I had the same problem that I noticed just a little while ago. It was rather weird to see the apple standard apps appear in chinese, japanese or hebrew or something.

    To solve it I had to re-enable English and put British English at the top of the list.

    Very Strange, because initially it came up in German and then when I removed that it came in spanish, so I removed the remaining language and it turned hebrew or something.
    MacBook Pro 13" Unibody, Mac OS X (10.6.1)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.