Skip navigation

Solution: Stopping iTunes from starting when pressing Play-key in 10.6

13290 Views 6 Replies Latest reply: Mar 21, 2013 7:31 PM by KevinR RSS
0scar Level 1 Level 1 (10 points)
Currently Being Moderated
Sep 17, 2009 2:07 PM
This is a response to this thread: http://discussions.apple.com/thread.jspa?messageID=10023424

I thought I'd just post it here to make it a little bit more accessible.

Problem
iTunes launch when you press the Play/pause key on the keyboard in Snow Leopard. This makes it practically impossible for other apps to respond to that key (ie Spotify, VLC etc).

Workaround
• Quit iTunes
• Locate iTunes.app in Finder (In Finder: Menu › Go › Applications...)
• Ctrl-click on the iTunes.app-file and select 'Compress "iTunes.app"' (for backup)
• Ctrl-click on the iTunes.app-file and select 'Show Package Contents'
• Locate the file 'Info.plist' inside the folder 'Contents'
• Ctrl-click 'Info-plist' and select 'Open with..' and select 'TextEdit' (or your favourite text-editor. Not Word tho.)
• Near the bottom of the file locate the following segment:

<key>CFBundleIdentifier</key>
<string>com.apple.iTunes</string>

• Change the last 's' in the word 'iTunes' to 'z', like so:

<key>CFBundleIdentifier</key>
<string>com.apple.iTunez</string>

• Save the file
• IMPORTANT: Drag the file 'iTunes.app' out of the Applications-folder and on to the Desktop
• Drag the file 'iTunes.app' back into the Applications folder
(• You should probably disable the iTunesHelper. This can be done by going to System Preferences › Accounts › (Your account) › Login Items and remove the 'iTunesHelper'.)
• Log out and log in

Hopefully this works. It works for me anyway

(Note: This workaround most certainly will have weird side-effects. Also, please post a bug to Apple about this issue, whether this workaround works for you or not.)

ciao
/ozzie
Mac OS X (10.6.1)
  • biskitwheels Level 1 Level 1 (0 points)
    Works great!

    2 notes on the instructions

    1. you need to change permissions on the folder "Contents" to save the plist file
    2. move itunes back to apps folder after logging back in (obvious)


    Note: This turns off all keyboard function shortcuts for iTunes. back.next.play.pause will no longer work.

    to Apple: you're not absolved until you make this right by giving the user the option to not use iTunes.

    Message was edited by: biskitwheels
  • Flopsy007 Calculating status...
    Thanks to Ozzie for the workaround for this annoying OS X "disorder".

    A comment on Biskitwheels' comment above:
    Actually, it didn't work for me until I did it in the following order:

    1. Move 'iTunes.app' out of the applications folder BEFORE modifying 'Info-plist'.
    2. FIRST THEN alter the 'Info-plist' file as described.
    3. Log out of OS X.
    4. Log back in.
    5. Move 'iTunes.app' back into the applications folder.

    Now it works as advertised - and me is happy
    Macbook Air, Mac OS X (10.6.1)
  • Lord Kamina Calculating status...
    Fix is awful. What use is stopping iTunes from opening when I press play if I can't actually control it when it IS open?

    I'd rather just stop using the remote completely. (Also, iTunes takes about twice as much to load with this fix)
    Macbook 2.0GHz, 2gb ram, Mac OS X (10.6.1)
  • Ffefj Calculating status...
    This is still an issue for me. All I really want to do is to make this key open Songbird. Would it be possible to just reassign that key to something else that would be interpreted as a shortcut to open your media player of choice/play/pause?

    So far I've really enjoyed OSX so far but it's stupid stuff like this and Microsoft making people use IE to update windows that makes me want to just stick with Linux. These companies need to learn that if they will not build products that do what the users want them to do the open source community will continue to gain market share...
    Macbook Pro, 2.26 GHz
  • franger Level 1 Level 1 (0 points)
    Thanks, that helps somewhat. I'm new to OSX and can't stand the constant 'work arounds' required for simple everyday use.
    MBP 13, Mac OS X (10.6.4), 'play/pause' key is now an 'open itunes key', nasty
  • KevinR Level 1 Level 1 (75 points)

    The simplest fix yet requires no terminal commands and no additional software to download and can be accomplished by going to System Preferences/Keyboard and selecting " Use all F1,F2, etc. keys as standard function keys".

     

    This way if you do want to use the media keys like F8,press the "fn" key + F8 to have it function as a media key again.

     

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.