1 2 Previous Next 29 Replies Latest reply: Mar 20, 2010 10:55 AM by jonbirduk
Andy Fryer Level 1 Level 1 (0 points)
I upgraded to SL yesterday, and today picked up a Three ZTE MF627 Dongle, which I now discover is only compatible with Leopard up to 10.5.2 and so I can't install it! Any ideas as to how to overcome this, whether it is likely to be upgraded in the next few days, or is it useless?

Thanks
Andy

iMac + Macbook, Mac OS X (10.5.8)
  • 1. Re: Three ZTE MF627 Dongle
    DaddyPaycheck Level 6 Level 6 (16,035 points)
    The only thing I know of is to roll back your software to Leopard.

    Either that or wait them out. However only being updated to 10.5.2 might indicate that it won't be updated in the next few days.
  • 2. Re: Three ZTE MF627 Dongle
    fearoffish Level 1 Level 1 (0 points)
    I'm a little confused. I have the Three Dongle (ZTE MF627), I plug it in, I run the software installer, and boom it works.

    I'm on SL 10.6.1, a fresh install. Could you confirm whether you upgraded or fresh installed, and also whether you have tried to run the installer?

    Cheers
    -- Jamie
  • 3. Re: Three ZTE MF627 Dongle
    RagingReindeer Level 1 Level 1 (0 points)
    I am having similar problems at my end. I just purchased the ZTE MF627 Dongle from Three Broadband. The Setup Assistant fails to find my device. I have recently upgraded from Leopard to Snow Leopard. I wonder if that is the reason it seems not to work.
  • 4. Re: Three ZTE MF627 Dongle
    fearoffish Level 1 Level 1 (0 points)
    I can only think that the difference is you didn't do a fresh install. If you have a time machine backup maybe you could do a fresh install, restore your user profile and then try and install again?
  • 5. Re: Three ZTE MF627 Dongle
    Lee Collier Level 1 Level 1 (0 points)
    I've been able to get this working on my MacBook. The process I used was:

    1. clean install Leopard (not Snow Leopard)
    2. install dongle software and check it's all working, leave dongle plugged in
    3. upgrade to Snow Leopard
    3. in network preferences, delete the 3Connect location
    4. switch to Automatic location and click the + button
    5. add the ZTEUSBModem device
    6. put phone number "*99#"
    7. click advanced, select vendor "Generic", Model "GPRS (GSM/G3)", APN "3internet"

    I can now connect and disconnect without using the 3connect application and it seems to be working perfectly. It has the added advantage of not messing up my network settings and requiring reboots as the awful 3connect app did.

    With regards to installing on a clean or upgraded Snow Leopard, the issue will be getting the right kernel extensions into the right folders. It may be possible by exploring the files in the 3connect package and manually putting them in the right places. If anyone is desperate for this and if I have time I can try installing onto my Mac Pro and see if I have any luck.

    Message was edited by: Lee Collier
  • 6. Re: Three ZTE MF627 Dongle
    fearoffish Level 1 Level 1 (0 points)
    Just make sure you leave the Mac_SwapperDemon in your login items, or the dongle will never flip from 'memory stick' to 'modem'. This is why when you plug in the dongle you see the 3Connect external drive icon appear on your desktop and then disappear. Mac_SwapperDemon does this.

    Strange that I clean installed Snow Leopard and ran the installer with no problems. Thank you for giving me the info for getting rid of the 3Connect app though, I now use the modem directly.

    Cheers!
  • 7. Re: Three ZTE MF627 Dongle
    Lee Collier Level 1 Level 1 (0 points)
    I reckon they're selling dongles with different versions of the software, I did a clean install of Snow Leopard and the installer wouldn't run, then I did the above and everything was OK. I wonder whether one of the posters above whose dongle installed on Snow Leopard would be kind enough to post the package somewhere?
  • 8. Re: Three ZTE MF627 Dongle
    Lee Collier Level 1 Level 1 (0 points)
    Actually, just to clarify, the installer ran, but when the Setup Assistant ran, it searched for the dongle for about 3 minutes then said it couldn't find any compatible hardware.
  • 9. Re: Three ZTE MF627 Dongle
    fearoffish Level 1 Level 1 (0 points)
    My pleasure => http://dl.getdropbox.com/u/1169118/3Connect/3Connect.zip

    I've bundled both the Mac and Linux software just in case.
  • 10. Re: Three ZTE MF627 Dongle
    bilbo777 Level 1 Level 1 (0 points)
    ZTE MF627 does not work for my 10.6.1 as well even I delete the "Mac_SwapperDemon" from the auto-login list.

    Is anyway to work around in 10.6.1?

    Thanks
  • 11. Re: Three ZTE MF627 Dongle
    fearoffish Level 1 Level 1 (0 points)
    Don't remove the Mac_SwapperDemon I said. This little program turns the dongle from a memory stick in to the modem, if it's not running then it'll never work. Let me stress that again for those that skim messages badly:

    * DO NOT REMOVE THE MAC_SWAPPERDEMON FROM LOGIN ITEMS, IT HAS TO RUN *

    I'm on 10.6.1 and my dongle is still working. I've had no problems with my fresh install of Snow Leopard, but for what it's worth, it wouldn't work on an upgrade. So the best plan of action is to fresh install Snow Leopard.

    That means:

    1. Back up everything
    2. Boot from the Snow Leopard disc
    3. Click the menu item Utilities and Disk Utility
    4. Erase your Macintosh HD
    5. Exit Disk Utility
    6. Complete the install of Snow Leopard
    7. Plug in your 3Connect dongle and run the installer it shows (or use the one I uploaded earlier)
    8. ...
    9. Profit

    Hope that helps.
  • 12. Re: Three ZTE MF627 Dongle
    R1ckyR1cky Level 1 Level 1 (0 points)
    Hey Guys. I have the Three ZTE MF627 dongle as well. It was plugged in when I upgraded to SL so i've never had problems.
    I suggest you unlock the dongle if you can't get it working... simply google how to unlock the dongle. you need xp OR WINDOWS 7 (i've done two dongle on 7, it works fine) to do it. It installs some austrailian connection software which works on any network and mac or pc onto the dongle... sorted!
  • 13. Found The Solution
    Nalluri Level 1 Level 1 (0 points)
    Here is the simple trick

    Instructions:

    1. Install 3 connect as usual on Mac 10.6
    2. Download and install the Telstra Drivers from the following link for mac (http://www.maxon.com.au/downloads.php?p=1). since Telstra uses the same ZTE hardware.
    3. Run 3 connection setup. Will work like breeze...


    Note: This drivers work not only for 3 network it works for all the the ZTE hardware for Mac with latest 10.6 OS
  • 14. Re: Found The Solution
    philg1824 Level 1 Level 1 (0 points)
    You are a real star!! My Dad has just gone into a nursing home and I need to get him on line.
    I got the 3 system which would not work, I searched for a solution and was delighted to see that there was one. I came home, poured a glass of wine, tried it and bingo it works.
    I will now be able to go back to the home tomorrow and increase the quality of my Dad's life.
    THANK YOU all who contribute to these forums. God bless you everyone!
1 2 Previous Next