Skip navigation
This discussion is archived

What's your Airport Card Country code?

20728 Views 32 Replies Latest reply: Feb 10, 2010 4:34 PM by TheGriffyn RSS
1 2 3 Previous Next
andre.mengatti Calculating status...
Currently Being Moderated
Sep 30, 2009 6:25 PM
I live in Brazil, and bought my 17" MBP from Canada in June, and my airport Country Code right now is ZW (Zimbabwe). When i'm at college, it jumps to US. And at home, it changes to ZW. This is a problem as in some countries some frequencies are now allowed. I have the 10.6.1 SL.

It's seems that either I have a faulty Airport Card, or Snow Leopard changes the card locale depending which routers are available for connection.

So, I wanted to know if anyone is seeing somethig weird as I am in the Airport Country Code.

Here's what I see in my info. The problem is that I can't use Wireless N in this country code.

Software Versions:
Menu Extra: 6.0 (600.22)
configd plug-in: 6.0 (600.27)
System Profiler: 6.0 (600.9)
Network Preference: 6.0 (600.22)
AirPort Utility: 5.4.2 (542.23)
IO80211 Family: 3.0 (300.20)
Interfaces:
en1:
Card Type: AirPort Extreme (0x14E4, 0x8D)
Firmware Version: Broadcom BCM43xx 1.0 (5.10.91.19)
Locale: FCC
Country Code: ZW
Supported PHY Modes: 802.11 a/b/g
Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13
Wake On Wireless: Supported
Status: Connected


To check this out, it's under

About This Mac/

More Info.../

Airport/
17" 2.88 Ghz MBP 5.2 500GB 5.4K Hitachi, Mac OS X (10.5.7)
  • gasboy Level 1 Level 1 (15 points)
    Currently Being Moderated
    Oct 26, 2009 9:01 AM (in response to andre.mengatti)
    Hey there. Definitely something up with Snow Leopard, country codes and airport wireless N 5GHz. I have 3 macs and 3 airport routers across the house, which have been working for years without issue wirelessly. Since the upgrade to Snow Leopard, my Macbook, and only my Macbook started not being able to connect or see the 5GHz network. My Macbook Pro and Mac Pro have no issues connecting or seeing the 5GHz network. It's not related to weak signal as I've tested the Macbook sitting next to the Airport Extreme. Interestingly there was no problem with 2.4GHz.

    So I thought it might have been a coincidental breakdown of the 5GHz N antenna on the airport card in the Macbook post Snow Leopard upgrade.

    Then I noticed a few posts on the net about Country Codes, Airport and Snow Leopard. This has never been an issue for me before. The Country Code is set at FR on my Macbook which is incorrect. Apparently this is set by Snow Leopard in response to routers available.

    As you are aware some channels are not usable in some countries.

    So I changed my Airport Extreme channel from Automatic to a fixed channel (36), and instantly the problem has been solved.

    So something has changed with Snow Leopard, Country Codes and Airport, which only affects some Macs. Ugh

    At least my problem was solved, hope this helps
    Mac Pro 8-Core 5GB RAM 4TB, Eizo S2411W, 2.4 SR MBP Glossy 7200, MB 2.16 2GB,etc, Mac OS X (10.6.1)
  • putnik Level 3 Level 3 (620 points)
    Currently Being Moderated
    Oct 26, 2009 2:06 PM (in response to gasboy)
    For what it's worth, both our Macbooks here in Madrid (Spain) have the country code FR (France?). I don't know how it was before upgrading to 10.6.1...

    The older black one has occasional loss of WiFi but seems to recover if I disconnect/reconnect the airport. I put in a new location which helped to start with. It is now back on auto.

    My new MBP has no problem.

    We have a Belkin N router. It seems that all our neighbours are still on g and use different channels. We are also the only ones using WPA2 personal.

    Does this information help?

    One other thing, the computer is unable to set the Time Zone automatically in Date/Time preferences. I don't know why not...

    Message was edited by: putnik

    Message was edited by: putnik
    MacBook Pro 13" 2.53GHz August 2009, Mac OS X (10.6.1), Gave up on Windows 7
  • William Kucharski Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Oct 26, 2009 8:14 PM (in response to andre.mengatti)
    andre.mengatti wrote:
    It's seems that either I have a faulty Airport Card, or Snow Leopard changes the card locale depending which routers are available for connection.


    That's exactly what it does.

    When an AirPort interface is turned on, it listens for 802.11d beacon packets, and those contain what is called a regulatory domain field.

    The AirPort driver uses the first valid regdomain setting it sees.

    So for example Andre's issue is that there's someone (illegally) using a router intended for sale in Zimbabwe in his neighborhood.

    Likewise, at college, someone is improperly using a US router.

    Unfortunately, there's not a really good way around this.
    Quad 2.5 GHz G5, 5 GB | 15" 2.6 GHz MBP Penryn, 4 GB | 1 TB Dual-Band TC, Mac OS X (10.6.1)
  • putnik Level 3 Level 3 (620 points)
    Currently Being Moderated
    Oct 27, 2009 12:45 AM (in response to William Kucharski)
    I looked at my router settings and cannot see any "regulatory domain field" to check if the incorrect country code is in my router or if the computer is latching onto a neighbour's.

    Is there a way to tell what router the beacon latches on to (they are all listed in the System Profiler)?
    Does it relate to the lack of ability to find the correct time zone in the Date/Time preferences?
    Should I report this as an error to Apple or Belkin?
    Is it important?

    Message was edited by: putnik
    MacBook Pro 13" 2.53GHz August 2009, Mac OS X (10.6.1), Gave up on Windows 7
  • William Kucharski Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Oct 27, 2009 1:41 AM (in response to putnik)
    The regulatory domain is given by the message logged to the dmesg buffer, e.g.:

    en1: 802.11d country code set to 'US'.

    The country code of your router is whichever one it was legally purchased for use in.

    If you see something strange, it's the router of some neighbor or another.
    Quad 2.5 GHz G5, 5 GB | 15" 2.6 GHz MBP Penryn, 4 GB | 1 TB Dual-Band TC, Mac OS X (10.6.1)
  • Barney-15E Level 7 Level 7 (33,285 points)
    Currently Being Moderated
    Oct 27, 2009 4:40 AM (in response to putnik)
    Who to report it to?

    Good question. I think Apple has implemented a specification that assumes you won't be spoofed by your neighbor's bad equipment. My suggestion would be to talk to Apple. They can't fix the specification, but they might be able to fix the way that it chooses the beacon it latches onto.
    1.8 SP G5/iMac G4 FP/MBP 2.33/PB G3 Pismo, Mac OS X (10.6.1), XLR8 G4 Upgrade for Pismo
  • putnik Level 3 Level 3 (620 points)
    Currently Being Moderated
    Oct 27, 2009 6:43 AM (in response to William Kucharski)
    Thank you for your reply

    Sorry I'm quite new to Macs. Can you tell me how to look at the "dmesg buffer".

    It occurs to me that I bought the Belkin N1 router at Carrefour in Madrid which is a huge supermarket chain based in France. It may well be that it started life the other side of the Pyrenees.

    It seems important to know if Belkin need to change my router country code or if Apple needs to get my computer to latch onto my router and not my neighbour's.

    Could this affect WiFi connectivity?

    You did not answer my question about the effect of this on the computer's ability to automatically change the Time Zone in Date/Time Preferences.

    Thanks for any clarification.

    Message was edited by: putnik
    MacBook Pro 13" 2.53GHz August 2009, Mac OS X (10.6.1), Gave up on Windows 7
  • William Kucharski Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Oct 27, 2009 12:13 PM (in response to putnik)
    putnik wrote:
    You did not answer my question about the effect of this on the computer's ability to automatically change the Time Zone in Date/Time Preferences.


    The regulatory domain of your AirPort interface has nothing to do with Date/Time preference settings.
    Quad 2.5 GHz G5, 5 GB | 15" 2.6 GHz MBP Penryn, 4 GB | 1 TB Dual-Band TC, Mac OS X (10.6.1)
  • putnik Level 3 Level 3 (620 points)
    Currently Being Moderated
    Oct 28, 2009 1:14 AM (in response to William Kucharski)
    Both my computers are normally showing they are in France (FR).

    I still do not know how to check my own router's Regulatory Domain directly from the 802.11d log (mesg buffer) so I turned it off to test other routers in the neighbourhood.

    I then joined several other of the many insecure networks visible at my house. Each time, the Country Code changed to Spain (ES). This would indicate to me that I do not have a "Dominant French Neighbour" and that the error is in my own router.

    In this case I do not have a problem with Apple but will contact Belkin instead.
    MacBook Pro 13" 2.53GHz August 2009, Mac OS X (10.6.1), Belkin N1 router
  • William Kucharski Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Oct 28, 2009 1:53 AM (in response to putnik)
    I had presumed that you had verified the country code of your own router first.
    Quad 2.5 GHz G5, 5 GB | 15" 2.6 GHz MBP Penryn, 4 GB | 1 TB Dual-Band TC, Mac OS X (10.6.1)
  • putnik Level 3 Level 3 (620 points)
    Currently Being Moderated
    Oct 28, 2009 3:21 AM (in response to William Kucharski)
    William,

    I did ask... Can you tell me how to look at the "dmesg buffer".

    Another possibility is that my neighbours all use wireless g and the problem may be only with Snow Leopard plus wireless n.

    Belkin have a beta firmware update available but I shall wait to see what they say about this.
    MacBook Pro 13" 2.53GHz August 2009, Mac OS X (10.6.1), Router - Belkin N1 Vision
  • William Kucharski Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Oct 28, 2009 1:11 PM (in response to putnik)
    Enter the following into a Terminal window:

    sudo dmesg

    and provide your administrator password when asked.
    Quad 2.5 GHz G5, 5 GB | 15" 2.6 GHz MBP Penryn, 4 GB | 1 TB Dual-Band TC, Mac OS X (10.6.1)
  • putnik Level 3 Level 3 (620 points)
    Currently Being Moderated
    Oct 29, 2009 10:00 AM (in response to William Kucharski)
    Thank you. This also gives "en1: 802.11d country code set to 'FR' " on both computers.
    MacBook Pro 13" 2.53GHz August 2009, Mac OS X (10.6.1), Router - Belkin N1 Vision F5D8632
  • William Kucharski Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Oct 29, 2009 5:45 PM (in response to putnik)
    The thing about this is that it would be rather difficult for Mac OS X to get this "wrong" and just happen to say, set FR rather than AU.

    In particular, 802.11d beacon packets contain the country code information as a three-letter character sequence containing the ISO 3166-alpha2 code element denoting the router's country of authorized operation followed by either a space, the letter "I" for indoor environments, or the letter "O" for outdoor environments.

    The AirPort code is closed source, so I can't say for sure what it's doing, but you'd have to code the driver in a rather interesting way to get "FR" from the string "AU," or perhaps "ZW" from "BR"…
    Quad 2.5 GHz G5, 5 GB | 15" 2.6 GHz MBP Penryn, 4 GB | 1 TB Dual-Band TC, Mac OS X (10.6.1)
1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.