Skip navigation
This discussion is archived


23142 Views 43 Replies Latest reply: Dec 10, 2009 8:18 PM by Nathan Jones2 RSS
  • LociKW Level 1 Level 1 (0 points)

    I think you were correct.

    I did an archive of my whole ~/Library/Mail folder as its just a good idea anyway.

    The first thing I did was remove the offending INBOX.INBOX.etc entries in

    Second (before relaunching Mail) I fixed your IMAP subscription problem but in a lazy way... I merely went into the problem account via web mail (Squirrel Mail in this case) and unsubscribed the offending folders. I restart Mail (3.5 - 930.3) and boom , the folders are there and then are instantly removed and Mail syncs everything exactly as it should. Curiously, Mail strikes me as snappier now; perhaps the bad subscription entries were introducing unnecessary synchronization steps?

    Whether this fixes it permanently or not is another issue, but I think you were right on about the 'IMAP subscriptions' and that its a setting that is on the server. My guess is that Apple Mail is interacting with that in unsuspecting, possibly buggy ways, but to be fair this may not be all Apple's fault.

    It reminds me of the headache I initially had with Apple Mail whining every time I started it about certificate mismatches. Well, in fact, that was a FEATURE that every mail program should have but most don't. In my case it was telling me there was a domain-cert mismatch with my setup and I had permanently tell Mail is was ok to assume it was a proper server.

    Thanks so much, if the problem appears again at least I know how to clean it up.
    MBP 2.2 128vid, Mac OS X (10.5.6), external lcd (1680x1050)
  • LociKW Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 29, 2009 12:03 PM (in response to LociKW)
    To clarify what I did:

    "The first thing I did was remove the offending INBOX.INBOX.etc entries in"

    ... in fact I edited those entries, correcting them, which meant removing one or more 'INBOX' parts of the string.
    MBP 2.2 128vid, Mac OS X (10.5.2), external lcd (1680x1050)
  • chip.r Level 1 Level 1 (30 points)
    I think that MobileMe Sync might be part of the culprit in producing all these nested INBOX.INBOX.INBOX accounts. I've had this account cleaned up of nested inboxes for a while and today my desktop was showing this sync conflict:


    I have not changed anything in this account so why the change now?

    Has anyone else seen this behavior? Got any ideas?

    iMac G5, MacBook Pro, 30GB iPod, 8GB iPhone, Mac OS X (10.5.7), .Mac
  • capt996 Calculating status...
    I was able to get my IMAP e-mail back to normal by following this sites instructions. Basically I only needed to follow the instructions under setting straight. which basically has you tell the mail app which folders should be for trash, sent, etc... very easy fix.

    for some reason google is flagging this site as "bad" but it is ok. if you are not comfortable, here is the text from the site:

    Setting Straight

    Now that you’ve made sure the folders exist, in order for to save your drafts or copies of your sent messages it needs to know where to put them, so this final step is the most important:

    1. Click the folder name that matches the function you want to assign (e.g. “Sent”) so it is highlighted in the list
    2. Go to Mailbox → Use This Mailbox For → [function name] (e.g. “Sent” again)

    That’s all there is to it,your folder will disappear from the list, and reappear as a sub-folder beneath the function you specified, with the same name as the account it’s connected to. So, if your account name is “My IMAP Account”, the “Sent” folder will now be located under “Sent → My IMAP Account” in the sidebar.
    Imac 2.8 24", Mac OS X (10.5.7), iPhone 3 GS
  • Ttombali Calculating status...
    I still have this problem! I assigned the boxes for send etc but still after awhile the same problem comes up. It looks like it has something to do with ToDos and Notices.

    Could someone tell me why Apple didn't fix this in the latest releases or is it my fault? I only use apple mail on my computer and iphone and it should not so complicated.

    Macbook Pro, Mac OS X (10.5.6)
  • Dadmin Calculating status...
    I have had the same problem for a couple of weeks. This fixed it.

    iMacDV, eMac, iMac, iBookG4
  • ryan. Calculating status...
    I fixed this very easily.

    - closed & logged into webmail
    - unsubscribed from all the inbox folders then saved
    - go back into folder list and delete all inbox sub-folders
    - opened and they disappeared

    I use roundcube for webmail which made this very easy.
    MacBookPro, Mac OS X (10.5.7)
  • Ighal Goldfarb Calculating status...
    After trying everything I solved it by doing this:

    - Open
    - Go to preferences --> Accounts --> Advanced (tab)
    - Where it says "Imap Prefix: INBOX" erase the word INBOX and leave blank.
    - Close Preferences.
    - Delete de bothering INBOX folder on top of the other INBOXes
    - Open Preferences again and retype INBOX where you left blank.
    - Close
    - Open

    MBA, Mac OS X (10.5.8)
  • Ighal Goldfarb Level 1 Level 1 (20 points)
    It looks like Snow Leopard fixes this too. You have to delete de INBOX folder by right clicking on it and selecting "Delete Mailbox" and it is really gone this time.
    MBA, Mac OS X (10.5.4)
  • Rob Persaud Calculating status...
    I am having the same problem happen... I delete the first main "INBOX" but then any time I have Spam, when I go into that mailbox to delete the mail, the "INBOX" folders reappear again...

    I have tried all of the above suggestions, but nothing seems to work??

    Any others?
    Mac Book Pro 2.4Ghz 4GB Ram, Logic 7.2.3, Mac OS X (10.4.11)
  • Gregory Sawyer Calculating status...
    Interesting, Rob, about the junk mail folder, because that's what I'm suspecting is the culprit. I was doing just fine for quite a number of months until suggested that training time for junk mail filtering was over. I turned it on automatic, and soon after that the inboxes appeared.
  • tksalvo Calculating status...
    I solved the nested inbox issue thus:

    1. Quit Mail
    2. Move the file to trash (you can find it in your_user/library/preferences)
    3. Restart Mail
    4. Quit Mail
    5. Move the new file to trash
    6. Move the old from trash back into your_user/library/preferences
    7. Restart Mail

    I have no idea why this should have worked, but all the nested inboxes simply disappeared.

    Message was edited by: tksalvo

    Message was edited by: tksalvo
    MBP 2.6GHz 4GB 250GB Leopard, iMac G5 PPC Tiger, iPhone 3GS, Mac OS X (10.6.2), Mac user 1984 onwards
  • Nathan Jones2 Level 1 Level 1 (25 points)
    I cannot see how that can work at all. If there is an issue with the preference file, then you've simply created a new one, deleted it and then put the old corrupt one back in again!
    MacBook (Black), Mac OS X (10.5.7)
1 2 3 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.