1 2 3 4 5 6 Previous Next 272 Replies Latest reply: May 1, 2013 6:55 AM by Chris McCord Go to original post
  • 45. Re: External HD Problem in Snow Leopard
    netnutmike Level 1 Level 1 (0 points)
    Geez, add me to the growing list. I installed snow leopard on my macbook pro and it has been working great after I figured out the battery problems. So I decided to upgrade my mac pro. I have an external cool drives JBOD that is a total of 2TB and hooked up via esata, it can be seen but with no partitions. It looks the same with firewire. Unfortunately it has no firewire connections. This is the drive I have been using for time machine.

    Has apple even acknowledged the problem yet?

    Also, since the upgrade I keep getting the black screen of death in multiple languages. Everything just locks up and requires a forced power down.

    It seems to be worse when I have any estata drive turned on. So I am thinking it is related. But there have been a time or two the drives have been off and it still happens. It seems snow leopard might have been a mistake.

    And now apple has a BSOD just like microsoft. Sad....

    Mike
  • 46. Re: External HD Problem in Snow Leopard
    jonnix Level 1 Level 1 (0 points)
    A solution (or two) { _while we wait_ } :

    Boot from any linux or windows disk/partition/DVD/CD that has a partitioning tool; say *boot from SystemRescueCd and use GParted*. YES there's a GUI. (SystemRescueCd : is available online, is a smallish download, works on Intel based Macs.)

    GParted (the software) will in fact report that the Partition Table is damaged and offer to create a new MBR one. You should also +use GParted to create a New partition+ afterwards and *format it to FAT32*. Then restart Snow Leopard and use DiskUtility to reformat it to HFS+ (or whatever). DO NOT USE DiskUtility to REPARTITION.
  • 47. Re: External HD Problem in Snow Leopard
    jonnix Level 1 Level 1 (0 points)
    *RE: SOLUTION Posted ABOVE*

    +As I can't edit the post I submitted earlier I offer the amendment here.+

    _DO NOT USE DiskUtility to FORMAT the drive to HFS+_. (It worked for me the first time but not the second time.)

    Instead boot from SystemRescueCD 1.1.6 (or higher) which ships with support for HFS+ format and use GParted to perform the Partition and Format (i.e. MBR partition, HFS+ format)

    Sorry about that. :/
  • 48. Re: External HD Problem in Snow Leopard
    theblackbubble Level 1 Level 1 (0 points)
    Hi All,

    I have had nightmare with this today and finally found a way round using terminal and the chap who posted this solution...

    http://www.macosxhints.com/article.php?story=20070306150736965

    It worked on mu LaCie firewire/usb mobile drive

    Hope it works for some of you
  • 49. Re: External HD Problem in Snow Leopard
    Y-Guy Level 1 Level 1 (0 points)
    Add me to the frustrated list about this. Finally got a couple drives for my RAID box and its not formatting. Equally as irritated that Apple hasn't replied to this problem after 4 pages.
  • 50. Re: External HD Problem in Snow Leopard
    James Babcock Level 1 Level 1 (140 points)
    Tyler:

    Find the $$$... I have used iPartition since Jaguar days (2002) and it never has failed. A BIG plus: their tech Support is superb!

    iDefragLite comes with the license....

    Don't delay... take charge of your Partitoning HD AND /OR External drives/...

    Jim B
  • 51. Re: External HD Problem in Snow Leopard
    Devildog64 Level 1 Level 1 (0 points)
    I had the same problem i got a raid enclosure usb 2 and put in 2 brand new 750 mhz drives and got the same error "POSIX reports: The operation couldn't be completed. Cannot allocate memory." I took Kisuske3's advise i fired my parallels with windows 7 and did the format there it gave me a little problem but had to format as mbr and then i dropped it from windows and it formatted on the mac....
  • 52. Re: External HD Problem in Snow Leopard
    jonnix Level 1 Level 1 (0 points)
    This is the best solution to this problem I've seen...

    http://www.macosxhints.com/article.php?story=20070306150736965
  • 53. Re: External HD Problem in Snow Leopard
    mgoltra Level 1 Level 1 (0 points)
    Tried it and it din't work. Same error message.
  • 54. Re: External HD Problem in Snow Leopard
    bk88a Level 1 Level 1 (0 points)
    1TB WD external drive. Disk Utility "Cannot Allocate Memory" when trying to save Mac Book Pro disk image (Macintosh HD) to external drive, as seen by many other users here. Sound like maybe go buy a Firewire external drive, then it will work? No hint Apple will fix USB DD any time soon.
  • 55. Re: External HD Problem in Snow Leopard
    The Dude Abides Level 4 Level 4 (1,835 points)
    I'm done with WD. Their tech help told me straight out their machines shouldn't be used as the boot disc so I could run DiscWarrior on my internal HD. Got a new G-Drive and it works great with FW. Little more $ than WD but, like I said, it works with FireWire.
  • 56. Re: External HD Problem in Snow Leopard
    r.kampy Level 1 Level 1 (0 points)
    All right,
    here is what worked for me:

    1) Open Disc Utility
    2) Pic any Volume and chose the Restore tab
    3) Drag and Drop your Macintosh HD (or any other partition that has the desired format of your target USB HD) into the Source
    4) Drag and Drop your USB drive onto the Destination
    5) Hit Restore
    6) Wait until you see the USB drive in your finder (containing a few files)
    7) Cancel the Restore and erase the files that were copied in Finder

    It did the trick for me! I hope it will help you guys.

    Please let us know if that worked or did not work for you!
  • 57. Re: External HD Problem in Snow Leopard
    Virtuoid Level 1 Level 1 (0 points)
    no way, this is the output: Could not erase target - Operation not permitted
  • 58. Re: External HD Problem in Snow Leopard
    ukrunr Level 1 Level 1 (0 points)
    Did manage to get my drives working following a reformat on my Tiger based iMac from 2001!

    None of the other options offered worked for using Apple software RAID via Disk Utility.

    Then decided to upgrade my time machine disk via an esata PCIe card and external RAID5 array. Another issue for SL, drivers not exactly working well here either, loading the esata driver for the PCIe card screws up my kernel extensions and my Mac Pro fails to boot from internal sata drives.

    Had to reinstall from SL DVD, recover using user migration from time machine backup and then start again.

    Eventually got it all working, but boy do I not trust driver updates or SL in general right now...
  • 59. Re: External HD Problem in Snow Leopard
    Berryrat Level 1 Level 1 (0 points)
    I have two identical USB drive enclosures (Metal Gear Box Substance II). After upgrading to SL, my enclosure with the 300GB drive would not mount anymore although Disk Utility could see the drive. The other enclosure with my 160 GB drive has been working fine.

    I tried just about all the tips in this thread to get my external 300GB working. I finally got the drive to format by using the Apple Partition Map option. Thought I was good to go.

    Then I setup Time Machine to use this drive. It got a little ways into the backup and then I got an error from Time Machine indicating it could no longer access the drive. It still appeared mounted, but I could not use it anymore.

    I'm puzzled as to why my 160GB drive works, but I can't get the 300GB to work. I don't want to buy a firewire enclosure because funds are tight right now.

    I hope Apple is working on this problem. Hopefully this will be fixed in 10.6.2 (or sooner).
1 2 3 4 5 6 Previous Next