Skip navigation
This discussion is archived

Updated to itunes 9:  now Airtunes won't connect,

57058 Views 119 Replies Latest reply: Oct 10, 2010 4:32 PM by GoPSU2 RSS
  • stephbu Level 1 Level 1 (0 points)
    Here's a nugget of interesting information that I fixed my issue (WinTunes + WRT610n + AE).

    Key to understanding why AirTunes broke for me started at noticing that I stopped seeing Bonjour adverts for my ITunes Library on IPhone Remote a few minutes after my Windows PC booted and ran ITunes. 2nd clue, Airport Utility would not find AE on the network after a few minutes - I had to find it by IP address.

    This is the same exact behaviour that my AE/Airtunes had after being reset for the 1st time. It appeared briefly in ITunes after a reset - then vanished.

    I went looking for reasons why Bonjour would stop working, and stumbled upon a comments about SPI firewalls inhibiting it like this forum post:

    http://forums.linksysbycisco.com/linksys/board/message?board.id=Wireless_Routers &thread.id=143606

    General indication was that recent revisions in Bonjour have started to trip up SPI certainly on my router - and possibly on others too. By disabling SPI, my IPhone Remote started working properly, and lo and behold Airtunes now works properly too.
    Macbook Pro, Mac OS X (10.5.2)
  • ArchiTex Level 1 Level 1 (5 points)
    Me too...I overlooked the fact that this thread was Windows, but it's my Macbook and my express wireless system trying to use airtunes that is messed up.
    MacBook, Mac OS X (10.4.9)
  • smithmm Calculating status...
    I have solved this problem on both of my Windows PCs!

    The inability to connect was due to the McAfee firewall settings on both machines. My settings were originally set to allow iTunes and iTunes Helper full access, with Service port UDP 5353 forwarded as described elsewhere.

    I REMOVED all of these settings, expecting to reset them. Instead, AirTunes connected to remote speakers on both machines without the McAfee firewall asking for permission. Windows Vista firewall asked for permission, which I granted, and all is well.
    HP dv3t laptop PC, Windows Vista, Intel Core 2 Duo
  • cwitho Calculating status...
    I had the same problem but THIS FIXED IT FOR ME
    Go to Airport Utility and select Manual Set Up
    Go to Advanced and select IPv6
    Change from Link-Local only to NODE
    Airport Express will be temporarily unavailable but when it re-booted my speakers were back!!!
    imac, Mac OS X (10.6.1)
  • jdmjdm Calculating status...
    Currently Being Moderated
    Nov 8, 2009 11:28 AM (in response to cwitho)
    Thanks for this post. This solution worked for me too. At last.
    Windows Vista
  • ShawnDuncan Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 13, 2009 6:23 AM (in response to cwitho)
    Our iMacs, which are connected to an AirPort Extreme BaseStation via ethernet have been able to use AirTunes fine since the update to 10.6 but not our MacBook Pros connecting wirelessly to the airport net. Changing the IPv6 settings to NODE fixed this for us as well, but not until this setting was changed in both the AirPort Express connected to the AV System and in the AirPort Extreme which controls the network.

    Thanks for passing along the fix!
    iMac(mid-2007), MacBook Pro 13", Mac OS X (10.6.2)
  • bakaka Calculating status...
    I had the same situation, and Vangelis' solution fixed the problem for me (trashing SystemConfiguration files, restart with apple-option-p-r)!

    If you are a Mac user, I strongly recommend you try it.

    Using OS X 10.6.2, and iTunes 9.
    Macbook Pro, Mac OS X (10.6.2)
  • kddpop Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 20, 2009 4:35 PM (in response to bakaka)
    this is a strange one.
    airtunes worked fine last night.
    today after work, no music.
    no changes, no downloads, no installs, no upgrades. just silence and the "network failed" message.
    all firewall setting checked and open.
    i trashed plists and zapped pram.
    i rebooted everything.
    still silent.
    macbook 2GHZ, intel core 2 duo, Mac OS X (10.6.2), ituens 9.02 2 gigs of ram
  • Sonomagreen Calculating status...
    SOLVED!

    I was having this exact problem. I have an Airport Extreme in my office and an Airport Express in my bedroom and living room. Both Airport Expresses are connected to stereos and neither of them were working after the iTunes 9 upgrade.

    I just got off the phone with Apple Tech Support and they helped me fix it. In Airport Utility, in the "Wireless" tab, she had me change the channel from 11 to channel 4. She says that channels 1, 9 and 11 are the most frequently used channels and therefor most likely to experience interference. Since I have them set up using a WDS network, I had to change the channels on the Airport Expresses before I changed it on the Airport Extreme. Updated them all and...

    ...my house is bumping with music. Aaaaahhhhh...

    Good luck!
    iMac, Mac Book, Mac OS X (10.5.1)
  • kddpop Level 1 Level 1 (0 points)
    i will try this solution.
    but i think mine is a more esoteric problem.
    i am able to (and currently am) streaming music wirelessly to my stereo through my tv and it works flawlessly.
    so i think my issue is with the airport express. although it is working fine as a print server.
    thanks for the reply and i'll try your fix in a few minutes.
    macbook 2GHZ, intel core 2 duo, Mac OS X (10.6.2), 2 gigs of ram
  • kddpop Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 21, 2009 3:13 PM (in response to kddpop)
    WOOT
    resolved.
    changed to channel 4.
    music is a flowin.
    thanx!!
    macbook 2GHZ, intel core 2 duo, Mac OS X (10.6.2), 2 gigs of ram
  • JonBruc Level 2 Level 2 (200 points)
    If you are running multiple Airports: Check that each has its own IP address.

    After experiencing the "network connection failed error today, I went back and checked the settings on my Airport express. I set the wireless connection sharing on the Airport Express connected to my router to Off (bridge mode), and my other Airport Express w/Airtunes began working again.

    *PowerBook G4 running 10.5.8 to AirPort Expresses running 6.3
    Powerbook G4 15 1.67, Mac Pro, iPhone 3G, Mac OS X (10.5.8)
  • jaclemmens Level 1 Level 1 (0 points)
    Thanks for all the suggestions. Neither worked over time.
    Config: TimeCapsule / airport express all latest software versions - osx 10.6.2 / itunes 9.0.2

    Checked and tried almost everything which was suggest in this and other forum posts (IPv6 off, Channel number, reboot, power off all network components etc - http://discussions.apple.com/thread.jspa?threadID=2173022) nothing seems to have a lasting effect.
    Put everything back in original config and now it also works (!?). But for how long is the question.
    All the solutions mentioned just seem to be a temporary patch to an underlying problem which hasn't been determined/fixed yet. And I agree with some of you that its an iTunes 9 problem.

    I have my hopes on a iTunes 9.0.3 release. If anybody has better ideas, let me know!

    Thanks again!
    MacBook Pro 15"; iPhone 3GS; iPod Classic 120Gb, Mac OS X (10.6.2)
  • Stephen_B Calculating status...
    petegas4life wrote:
    I tried everything, rebooting, restarting airport express. then I tried something that should not have done anything, but did: I restarted my airport extreme base station (the airtunes speakers are NOT connected to this, it is simply my main router, and seemed to be working fine).

    Voila, problem solved. weird.


    Thank you for this. Nothing else was working. Who would have thought that reseting the wireless base station used to connect to the internet (airport extreme) would have made the difference in streaming to an entirely different base station (airport express).
    Dual G5, Mac OS X (10.5.8)
  • iq2hi4u Calculating status...
    This is indeed a strange issue. None of the suggested fixes/work-arounds work for me. For the record the Airtunes function has never worked for me using iTunes 9.0.2 on my MBP 10.6.2. I will pull out another MBP to test alternate versions of iTunes to verify where the functionality was broken. But until then...

    Observations: After connecting to my Airport Express with iTunes and playing music I notice that there is NO network activity from the iTunes application. I downloaded the Airfoil trial and started up the program. Connected to my Airport Express with it and to my surprise after pressing play in iTunes I see 100+ kbps network traffic. This is repeatable and reliable. I would like to see a fix for this issue since I do not want to (nor should I need to) invest in a 3rd party application to get functionality I have already paid for.

    So, Apple, what's wrong with iTunes 9? It will be nice to understand more on this issue and the openness is appreciated by the user community.
    MBP, Mac OS X (10.6.2)
1 ... 4 5 6 7 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.