Skip navigation
This discussion is archived

Magic Mouse hypersensitivity and InDesign

18473 Views 16 Replies Latest reply: Mar 16, 2010 7:08 AM by danbosh RSS
1 2 Previous Next
Stymied again Calculating status...
Currently Being Moderated
Nov 11, 2009 3:19 AM
(No mouse forum so I'm posting here - hope that's OK.)

InDesign (and a few other apps) has a very large pasteboard and I've found that with the very sensitive touch surface of the Magic Mouse (which I like very much) it's too easy to inadvertently send the page skittering away sideways miles off screen. This didn't seem a problem with the Mighty Mouse. Turning scrolling sensitivity right down and disabling scrolling with momentum does help but doesn't cure the problem.

Have others encountered this? Any solutions?
Mac Pro, Mac OS X (10.6)
  • Anonymoustache Calculating status...
    Currently Being Moderated
    Nov 13, 2009 11:30 PM (in response to Stymied again)
    I've been having the same problem a bit, but generally only with the Adobe apps that have big pasteboards like Flash, InDesign and Illustrator. I doubt there's anything that can be done about it...
    Mac Pro (Two 3.0GHz Quad-Core Intel Xeon 5300 series), 9GB Ram, 4TB, Mac OS X (10.6.1), iPhone, iPhone 3G, iPhone 3GS
  • Ryan Homer Level 1 Level 1 (95 points)
    Currently Being Moderated
    Nov 28, 2009 8:52 AM (in response to Anonymoustache)
    It doesn't seem to matter which software application is being used. The inadvertent scrolls and clicks happen all the time. I think it's a driver issue that Apple needs to address.
    Macbook Pro (Late 2006), Mac OS X (10.6.2), 2.33 GHz, ATI Radeon X1600
  • gumsie Level 4 Level 4 (2,075 points)
    Currently Being Moderated
    Nov 28, 2009 11:21 AM (in response to Ryan Homer)
    Ryan Homer wrote:
    I think it's a driver issue that Apple needs to address.

    As opposed to a finger wiping across the body of the mouse? Takes a bit of getting used to but it's a problem I rarely have now.
    PowerMac G6 Alu Cinema HD, Mac OS X (10.6), Ctrl, Alt, Del.........AAAaarggghhh!
  • Anonymoustache Level 1 Level 1 (100 points)
    Currently Being Moderated
    Nov 28, 2009 11:32 AM (in response to gumsie)
    Yeah, I don't think it's a driver issue at all, or even really a problem. I think it's just that the amount that it scrolls depends on the amount of time between the beginning and the end of the touch, so a tiny little touch, even one that you might not feel, can trigger a massive unintentional scroll. I had it a lot at the start but now I'm used to it and it hasn't happened at all lately.
    Mac Pro (Two 3.0GHz Quad-Core Intel Xeon 5300 series), 9GB Ram, 4TB, Mac OS X (10.6.1), iPhone, iPhone 3G, iPhone 3GS
  • Ryan Homer Level 1 Level 1 (95 points)
    Currently Being Moderated
    Nov 29, 2009 4:45 AM (in response to Anonymoustache)
    Well, the scrolling is one thing, but I also get inadvertent clicks too. I've been using the Magic Mouse for over a month now, after having used the Mighty Mouse for a long time. Let's see what happens in the next month or so.
    Macbook Pro (Late 2006), Mac OS X (10.6.2), 2.33 GHz, ATI Radeon X1600
  • lesharrison Calculating status...
    Currently Being Moderated
    Nov 30, 2009 6:04 PM (in response to Stymied again)
    I too have been having loads of problems with this. Not great when you have a design client sitting beside you!
    I have turned down the sensitivity and disabled momentum... but does that not negate why I bought this mouse in the first place?
    Initially I loved this mouse but as most of my work in is design I am wondering should I buy a different one. It is just not usable for me.
    IMac 2009, Mac OS X (10.6.2)
  • Peter Goodman Calculating status...
    Currently Being Moderated
    Dec 4, 2009 9:05 PM (in response to lesharrison)
    Just got my new iMac, and immediately noticed the problem with the Magic Mouse causing the screen area to jump. Clicking on a word to edit text, for example, sometimes causes the page to shift to the right. Very annoying, and it makes it very hard to do close work, particularly at the edge of the screen. I've tried different scroll and speed settings, and nothing makes a difference. Hope someone out there comes up with some ideas about fixing this issue.
    iMac 3.06 gHz, Mac OS X (10.6.2)
  • NinjaBoot Calculating status...
    Currently Being Moderated
    Dec 8, 2009 1:21 PM (in response to Peter Goodman)
    I am having the same issue with both apple mice and indesign. I think the issue is with indesign not having a fine enough scroll line pattern. I would really like to see the ability to disable mouse scrolling within indesign its self, the only way I have been able to get indesign to scroll smoothly is by space bar grab scrolling. I love the magic mouse when using anything apple written, it also makes surfing and navigating the system a truly smooth and pleasurable experience. I believe they had the "default apple user" in mind and not the power user/professional during the development of this product. Just my two cents.
    MacBook Pro5,2, Mac OS X (10.6.2)
  • JonSeph Calculating status...
    Currently Being Moderated
    Dec 14, 2009 12:06 AM (in response to NinjaBoot)
    Found this thread while looking for a solution. Let's hope Adobe / Apple don't just blame each other, but it seems more of an InDesign issue to me as most other apps don't suffer the same problem.
    Annoying as Apple seem to have made their first ever decent mouse!
    MacBook Pro, G5, Mac OS X (10.5.6)
  • grirad Calculating status...
    Currently Being Moderated
    Dec 30, 2009 5:08 PM (in response to Peter Goodman)
    I got the same issue, when working in MS Word - suddenly the page jumps up or sideways. Never occurred in Safari. Very annoying.
    MBP, Mac OS X (10.5.1)
  • Ein Level 2 Level 2 (410 points)
    Currently Being Moderated
    Dec 30, 2009 7:35 PM (in response to grirad)
    PowerMac 7500, Mac Pro 2.8X8/8800GT, Intel G2 80G SSD, Mac OS X (10.6.1)
  • Wognum Calculating status...
    Currently Being Moderated
    Jan 21, 2010 6:22 AM (in response to Stymied again)
    The same problem for me as well.

    I have been using the Mighty Mouse and InDesign for a long time and bought the Magic Mouse as soon as it got out. It does not work well at all with InDesign. I have tried to get used to it, but no...

    So now I use both of them – i.e. I use Magic Mouse with all applications except InDesign. There must be a solution to this...

    I don't know if this is an Adobe or Apple related problem.
    Mac Pro (208), Mac OS X (10.6.2)
  • happyaustinbassist Calculating status...
    Currently Being Moderated
    Feb 3, 2010 3:56 PM (in response to Stymied again)
    Same problem here. Other apps are fine, but InDesign + Magic Mouse = screen scrolling wildly left & right for no reason (my fingers are nowhere NEAR the touch surface of the mouse - only on the sides!)
    Macbook Pro 2.4, Mac OS X (10.6.2)
  • Leidon Calculating status...
    Currently Being Moderated
    Feb 23, 2010 8:34 PM (in response to Stymied again)
    I'm having the same problem with the mouse. It seems not only did I upgrade to iMac (with yellow tinge), but now have to upgrade inDesign and lost some of my fonts. Ahhhh the agony of upgrading!
    iMac 21.5", Imac G5 2ghz Intel Core Duo (10.5.8), 15" MacBookPro (10.5.8), Mac OS X (10.6.2), Started my Apple journey 1998, Mac Classic..those were the days!
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.