Skip navigation
This discussion is archived

Another bug? no sound from next patch

5400 Views 19 Replies Latest reply: Jan 11, 2010 11:15 AM by littleeden RSS
1 2 Previous Next
littleeden Level 1 Level 1 (75 points)
Currently Being Moderated
Oct 11, 2009 10:54 AM
Another thing I noticed today is that occasionally when I switch patch, I get no audio from my guitar.

Practicing today, I used the arrow key to change to patch for a solo mid-song, and all the audio cut. It was a patch I've used many times before no issue. I switched around a few other patches and got sound, then when I came back to the problem patch, there was the sound again, just as if nothing had happened.

I then had this same problem with another patch a few minutes later. I've never seen it before, and the rest of the practice session was trouble free.

any ideas, anyone?

Thanks in advance
Macbook 13", Mac OS X (10.6), 4Gb RAM
  • rc tech Level 2 Level 2 (215 points)
    Currently Being Moderated
    Oct 12, 2009 10:25 AM (in response to littleeden)
    Is this audio from the previous patch that cut out or audio from the current patch you just switched to?

    It will cut off audio from patches you switch away from if your cpu load is too high. You might be able to decrease cpu load quite a bit by changing all of the plugins and the input to be mono (especially if you are using a guitar, this probably is what you want anyway).
  • bilbo_baggins Level 4 Level 4 (2,230 points)
    Currently Being Moderated
    Oct 26, 2009 10:25 AM (in response to littleeden)
    I'm having exactly the same problem. I'm using a MacBook Pro Unibody and an Apogee Duet. Clicking on patches sometimes works as expected, but other times the audio becomes silent as soon as I select another patch. Clicking on a different patch usually fixes it (and often then going back to the silent patch then works normally). It's a 2.4GHz MBP, 4GB RAM, and none of the meters are more than about a third across.
    Mac Pro 2.8Ghz 8-core / MBP Unibody 2.4Ghz, Mac OS X (10.6.1), 8GB RAM, GeForce 8800GT / 2GB RAM
  • jimchik2 Level 1 Level 1 (45 points)
    Currently Being Moderated
    Oct 26, 2009 2:07 PM (in response to bilbo_baggins)
    I have the same issue on occasion. In my case, I've discovered that just flicking the expression wheel on the faulty channel strip snaps the sound level right back.

    I've tried muting cc 11 to the strip, but it doesn't seem to make a difference. The only thing that I can say might relate is the fact that the pedal off of my controller (an S90ES) is sending CC 11. But, there is no predictability to a patch getting muted (or quieting in volume). 3rd party PI's (VI's) seem to be more easily effected, as does a channel strip used for the S90, an external one re-routing MIDI data back to the S90. Local control is off.

    Now I need to restate, it is rare that a channel strip gets muted. Not quite as rare when the volume from the S90 is lessened. But in both cases, a flick of the Expression dial on the channel strip always corrects the problem. However, it always displays full level, or at least 70 on a scale of 0-127.

    Now, in my case at any rate, where is it getting the CC11 info from, and more importantly, why the discrepancy between the readout and the level?

    Thanks.

    btw, I'm using a MOTU Ultralight for the interface, and the S90ES is going in via USB.
    Mac Pro, Mac OS X (10.6.1), brand new MAc Pro, 16 Gigs of Ram, 10.6.1, MS 2.0.1
  • rc tech Level 2 Level 2 (215 points)
    Currently Being Moderated
    Oct 26, 2009 4:30 PM (in response to jimchik2)
    Your device might be sending out CC11 (expression) randomly. I saw this once at a friend's house... we worked around this by creating a knob in the layout that was assigned to expression, and set the "midi thru" to "do not pass through." This intercepted the expression message that was being sent, and stopped the problem from happening. I guess the other way to fix the issue is to see if you can keep expression from being send in these random cases, but MainStage is easier to set up then trying to figure out a cryptic series of steps from a controller's/synth's manual!
  • jimchik2 Level 1 Level 1 (45 points)
    Currently Being Moderated
    Oct 26, 2009 11:12 PM (in response to rc tech)
    Thanks for the reply. I'll try that today and let you know how it works with the rest of my layout.

    Best
    MBP, Mac OS X (10.6.1), 3.06 Ghz Core 2 Duo
  • Darth_Fader Calculating status...
    Currently Being Moderated
    Nov 17, 2009 12:15 PM (in response to littleeden)
    I too am experiencing this same issue. To be clear, let me explain my exact scenario.

    First, the setup is as follows: 24" aluminum iMac 2.4GHz, 2 Gb RAM, OS X 10.5.8, Mainstage 2.0.1, M-Audio Axiom 25, FastTrak Pro, Behringer FCB 1010.

    Yesterday, I created a new guitar rig concert just to play around with the sounds and get my foot controller set up to control stompboxes, patch changes, etc. I used the factory template, 'single amp with patches.' So, this was not a custom concert made from scratch with a ton of resource hogging plug-ins. I got everything assigned and up and running. Then, I noticed that when changing patches, occasionally (about 50% of the time I would approximate) there is no output from the new patch. The new patches' input meter shows signal, but the output does not. This occurs whether I change patches from my foot controller, the arrow keys on the keyboard, or via a mouse click on the patch list. This also occurs when switching to a new patch via jumping to a new set by any of the above means.

    I have restarted Mainstage several times which did not solve the issue. I restarted the computer also, but this didn't help either. The CPU and memory meters are not in the red. I thought at first, it may be that I don't have enough RAM, but seeing that this is happening to others with more than enough verifies to me the meters are relatively accurate and this is not the issue. I am going to continue troubleshooting this issue by retrying this scenario on my 13" Macbook (with 4 Gb RAM) to reconfirm that it is not a shortage of RAM on my part.

    I have not extensively used Mainstage 2 since it's release, but I have been playing with it enough to know this is a new issue. Maybe related to the 2.0.1 update? I got the software shortly after release, and played quite a bit with the new features. I never had this issue before.

    I have found somewhat of a work-around, but I don't know how well it will hold up. While troubleshooting, I came to notice that when I came to patch that did not produce output, if I backed up to the previous patch then switched to the new one again, it worked fine. It seems almost as if previously unused patches in a concert are somehow inactive. But once they are "woken up," they stay awake and work fine. My final test yesterday was to open the concert and then simply hold down the arrow key to scroll through the entire patch list quickly. Then, I could switch to any patch or set and it worked as expected. Now, I have not tested this work-around for long periods of time, such as that which would be required in a live situation. I don't know yet if the patches will "go back to sleep" after a certain period of time.

    I realize that I am coming into this discussion thread late. I hope those who have posted here have not abandoned the issue. If necessary I will post this as a new question. I was just wondering if anyone has learned anything more about this issue. I am unsure what to do next to try and solve the problem. One question for those affected- What version of OS X is everyone using? Is anyone using Snow Leopard? I just wonder if this is occurring to those who are using SL also.

    Any advice or suggestions is greatly appreciated!
    Chris
    iMac Intel 2.4GHz 2G RAM, Mac OS X (10.5.8), Logic Pro 9; FastTrak Pro; Axiom 25; Seasgate FreeAgent 1.5 TB FW 800 external H
  • Darth_Fader Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 18, 2009 10:34 AM (in response to littleeden)
    I have reported the issue vie the feedback option in Mainstage. I will keep my eye on this thread and update should I learn anything helpful. I hope for your sake the 10.6.2 update fixes the issue. Please let us know if that is the case. I am still holding off on the update to SL due to issues with other apps.
    iMac Intel 2.4GHz core II duo; 2G RAM, Mac OS X (10.5.8), Logic Pro 9; FastTrak Pro; Axiom 25; Behringer FCB 1010
  • museofitall Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 30, 2009 4:01 PM (in response to littleeden)
    Hi, I noticed that some patches when switched to or it could be just a change on anything which causes a spike which then freezes up. The problem existed in MS1. Re-initializing the program. It is possible the setting at the end of the patch being played before the patch being switched to isn't set right. Or the patch you are switching to may be set wrong. There are choices of how a patch changes make sure they are setup right for what you want. It is always good practice to check your patches and settings before your ready to go. It may be something as simple as adding or changing a setting. Best of Luck! Always re-initialize when you make changes if it doesn't work the 1st time. Saving your work may save you some time narrowing it down.

    Peace!
    MacbookPro 2009 Intel 4 gig, Mac OS X (10.6.2)
  • LunaMusic Calculating status...
    Currently Being Moderated
    Jan 1, 2010 7:49 AM (in response to littleeden)
    Download a midi monitor and try to see what exactly your footswitch is sending. If you are using an FCB1010, they can sometimes send weird little messages.
    Mac OS X (10.5.1)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.