Skip navigation
This discussion is archived

iPhoto library shares suddenly disappear

5862 Views 9 Replies Latest reply: Nov 21, 2009 3:04 AM by SamCritch RSS
Damon Beales Calculating status...
Currently Being Moderated
Jun 15, 2009 2:50 AM
I have noticed a problem where shared iPhoto libraries suddenly disappear. The setup is two Macs, connected via wired Ethernet though ADSL modem/router. On one Mac, I have a few iPhoto albums shared. On the other Mac, I have iPhoto setup to look for shared albums.
I found that I could run a slideshow showing the photos from a shared album for about 15 mins, and then it would stop. The iPhoto left side-bar shows that all shared albums had gone (i.e. the other Mac had 'disappeared'). I didn't touch the remote Mac. If I closed & restarted iPhoto on the Mac (that I was viewing the photos on), then the shared albums would re-appear, and I could continue.
This was quite repeatable, and happened every 15 mins or so.
I also found the same thing would happen if viewing via Front Row (which I guess is expected as this is just a front-end to iPhoto).

This reminds me of a time a while back when I was trying to view a movie stored on the remote Mac using Front Row. It played for a few minutes and then froze.
So I was wondering whether this is not a iPhoto problem, but a more general problem with sharing? (Maybe a Bonjour problem?) If so, this probably affects iPhoto 9 as well. Or maybe the two problems aren't related.

A thought occurred to me that maybe it's the router that somehow gets in the way. The router is configured to dish out the IP addresses via DNS, and I was wondering whether assigning static IP address and turning off DNS may solve the problem. I'll do some experiments.

Anyone else seen anything similar?

Damon
iMac 20" white, Mac mini, Mac OS X (10.4.11)
  • T_E_X_07 Calculating status...
    Currently Being Moderated
    Jul 8, 2009 11:56 AM (in response to Damon Beales)
    Just started having the same problem here. Macbook Air to a PowerPC dual G5, both running OS 10.5, iPhoto 8.0.4

    Solved the issue. The offending computer (containing the photos I wanted to share) had a corrupted event in it. Rebuilding iPhotos database did not work. It contained 2600 (out of 13000) photos, however, all of the photos could not be located on the drive.

    Once I deleted that event, sharing returned to normal.
    MacBook Pro 2.4GHz, 2 GB ram, iPhone 3GS, 3 Ap Express; unfortunately WinXP exp, Mac OS X (10.5.7)
  • jarik Calculating status...
    Currently Being Moderated
    Jul 12, 2009 8:23 PM (in response to T_E_X_07)
    How'd you figure out which event was the problematic one?

    I just recently tried using iPhoto Sharing. I have about 16000 pictures in about 600 events in the main library and I am trying to access these via iphoto sharing on another mac. As soon as I click on the share on the sidebar it vanishes: No errors, nothing in the logs, just gone. If I set up another mac to provide a share with only one photo in the library, it seems to work fine. I suspected it might have been something to do with the size of the library.

    Anyone else having this problem also using iPhoto Library Manager? I have been using it to combine libraries from different macs into the main library.

    Are these problems recent? Did it used to work? Until when?
    MacBook, MacBook Pro, Powerbook G4 15", Intel Mini., Mac OS X (10.5.7)
  • Riverrunner1 Calculating status...
    Currently Being Moderated
    Aug 29, 2009 10:44 PM (in response to jarik)
    I have the same issue. With my macbook, I can access other's shared libraries on my network. When I use the other mac's to look at my macbooks shared library, it just disappears after being accessed. This is a recent occurrence. I"m not sure what has triggered it. It has always worked in the past.
    I've gone so far as to remove/archive all my photos off my macbook in case there was something damaged. This did not help. Still the same issue.
    Macbook, Mac OS X (10.5.8)
  • dchase Calculating status...
    Currently Being Moderated
    Sep 18, 2009 7:20 PM (in response to Damon Beales)
    It may be an issue with your firewall. I was having the exact same problem, made adjustments to my firewall access and all worked fine afterwards on ALL ACCOUNTS. FYI, I'm using doorstop, not using mac firewall, (which is set to allow all access), but when I adjusted my firewall settings to allow ALL USERS OF MY SUBNET to have iPhoto sharing access I have had no problems with the iPhoto shared library disappearing when I select it from another user. Maybe disable your firewall and see if the problem goes away. If it does it's just a matter of configuring your firewall correctly. Hope this helps.
    Mac OS X (10.5.8)
  • phunkphuz Calculating status...
    Currently Being Moderated
    Nov 17, 2009 6:33 PM (in response to Damon Beales)
    Just had this same issue. I think it's a firewall thing. I was able to solve it by making sure "allow incoming connections" was enabled for iPhoto on the computer i wanted to share (in preferences, privacy, firewall). Once i switched that to "allow incoming connections", it worked for me.
  • SamCritch Calculating status...
    Currently Being Moderated
    Nov 21, 2009 3:02 AM (in response to Damon Beales)
    I have this problem sharing libraries between users on my new iMac. Switch users from A to B, A's library is visible in B's iPhoto, but when you click it, the photos appear briefly and then the whole library disappears. Go back to user A, turn sharing off then on in iPhoto preferences, then the library is visible in user B's iPhoto. Repeat ad nauseam. Very annoying as user B (my girlfriend) wants to be able to see all our photos.

    At first I thought this was something to do with the Facebook publishing plugin, but I've deleted that and it still seems to be an issue.
    iMac 3.06GHZ 4GB, Mac OS X (10.6.2)
  • SamCritch Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 21, 2009 3:04 AM (in response to Damon Beales)
    PS my firewall isn't even turned on
    Macbook 2.4GHZ 4GB, Mac OS X (10.5.3)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.