5 Replies Latest reply: Nov 21, 2009 11:53 PM by K Shaffer
lburg801 Level 1 Level 1 (0 points)
Have my daughter's old ibook and want to run Firefox but it requires ver 10.4 or higher. I'm Mac illiterate and need help. Thanks. Trudy

iBookG4, Mac OS X (10.3.x), 933 MHz PowerPC G4; 640 MB DDR SDRAM
  • 1. Re: Help! Have ver10.3.9 & Firefox requires 10.4 or higher
    S.U. Level 6 Level 6 (8,360 points)
    Welcome to Apple Discussions!

    What you would have to do is to install Tiger (OS X v. 10.4) or possibly Leopard (OS X v. 10.5) on the iBook. To do this, you would need to have a full retail install disc. The problem is that Apple no longer sells these, and they are very expensive on the secondary market.

    You might be able to find a retail install disc on your local Craig's list or on EBay. But you have to be careful. You cannot use a gray original install disc or an upgrade disc--it has to be a full retail disc.

    Good luck!
  • 2. Re: Help! Have ver10.3.9 - Firefox requires 10.4 or higher
    K Shaffer Level 6 Level 6 (9,220 points)
    Is there a specific reason for needing or wanting Firefox (new version)
    when you can get Camino 1.6.10 from http://camino.org site and do OK
    with that for awhile, on most sites; until you sort out the upgrade path?

    Many web sites utilize newer flash and shockwave players (adobe) so
    in some cases, the old Panther 10.3.9 system is too old to get later
    updates anymore; the last Flash and Shockwave players are too new
    for Panther 10.3.9, but the Adobe site does have older ones that may
    be newer than the current ones in your old iBook's OS. If these are in
    need of update, the old versions would need to be uninstalled when
    you get the replacements, before newer ones are installed.

    Between a different browser and these two players, some internet
    should be more than just possible in that computer. There is an
    older Firefox that is still available for download here:

    The Adobe players have newer versions than your computer OS can use
    so be aware the links to the slightly older ones (as needed) are there.

    Get Adobe Shockwave: (shockwave version 10 may be it, not 11.)

    Get Adobe Flash player: (note 'Select version to download' chooser to get v.9)

    Confirmation on the correct Flash and Shockwave for your 10.3.9 system
    is recommended; and also, once you get these, check for an official app
    that removes each of the older versions. An Uninstaller, one for each item.

    The Camino browser is newer than the Firefox, but both should
    work well enough for the most part, given the correct Flash & Shockwave.
    Some sites and web content may not work even then, but most things will.

    Good luck & happy computing!
  • 3. Re: Help! Have ver10.3.9 & Firefox requires 10.4 or higher
    John Huber1 Level 6 Level 6 (17,745 points)
    The current version does but older versions don't.


  • 4. Re: Help! Have ver10.3.9 - Firefox requires 10.4 or higher
    lburg801 Level 1 Level 1 (0 points)
    Thanks! The solution I needed was not a new OS X but an older ver of Firefox. Perfect. Am happily using it now.
  • 5. Re: Help! Have ver10.3.9 - Firefox requires 10.4 or higher
    K Shaffer Level 6 Level 6 (9,220 points)
    Looking back, my bad on the link to get the Mozilla Camino browser;
    it should have been: http://caminobrowser.org - The shorter link in my
    earlier post takes one somewhere quite different, not the right place.

    or here: http://caminobrowser.org/download/releases/1.6.10/

    And it is worth getting the Camino 1.6.10 version for 10.3.9 as an
    alternative browser to use concurrently so if you find some site
    that may not work correctly with Firefox, that should help.
    And some content will work better if the correct last Shock/Flash
    players are in the 10.3.9 system. These are not seen as updates
    by Software Update of Panther; & old ones would be uninstalled.

    Good luck & happy computing!