Skip navigation
This discussion is archived

AFP file sharing broken on one MacBook, not others

5447 Views 15 Replies Latest reply: Jan 19, 2010 5:22 AM by bu11etpr00f RSS
1 2 Previous Next
BradPDX Calculating status...
Currently Being Moderated
Sep 3, 2009 8:16 AM
We have 4 Macs in our house - a late 2006 iMac and 3 early 2009 MacBooks. All are loaded with SL at present. I am using a typical home network with Airport Extreme which works fine. I enable File Sharing on all Macs so that files can be browsed and shared between machines.

On one MacBook, the SL upgrade appears to have broken AFP File Sharing. When any other Mac tries to connect to it via the Finder, the connection fails after several minutes.

If I add SMB file sharing, that works. Likewise Screen Sharing works as well - and thus other network services are functional on this MacBook.

The MacBook appears to "advertise" that AFP is available - if I run iStumbler from any other Mac, it "sees" the AFP and SMB services via Bonjour, and of course the MacBook is visible in the "Shared" section of the Finder sidebar on the other Macs. It's just that the AFP dead ends on this one machine.

I have tried restarting File Sharing, fixing permissions, restarting the whole machine - but the results never vary. Suggestions?
iMac Intel Core 2 Duo, MacBook Intel Core 2 Duo, Mac OS X (10.6)
  • a brody Level 9 Level 9 (62,060 points)
    Currently Being Moderated
    Sep 3, 2009 8:20 AM (in response to BradPDX)
    Snow Leopard doesn't support AFP.
    An Apple user since 1981, Mac OS X (10.6)
  • Bruno Enz1 Calculating status...
    Currently Being Moderated
    Sep 3, 2009 8:41 AM (in response to BradPDX)
    I've the same problem here with my Macs (MacBook Pro/Air). My MacBook Air had a clean install of 10.6.

    " have tried restarting File Sharing, fixing permissions, restarting the whole machine - but the results never vary."
    Me too!

    I tried different firewall settings - no effect!
    MacBook Pro Core2Duo 2.53GHz, 4 MB RAM, 320GB HD, Mac OS X (10.6)
  • a brody Level 9 Level 9 (62,060 points)
    Currently Being Moderated
    Sep 3, 2009 8:50 AM (in response to BradPDX)
    Oh, I thought they were based on the same protocol.
    Did you install Rosetta on one machine, but not others?
    An Apple user since 1981, Mac OS X (10.6)
  • a brody Level 9 Level 9 (62,060 points)
    Currently Being Moderated
    Sep 3, 2009 9:36 AM (in response to BradPDX)
    Rosetta allows more PowerPC code to run.
    I suspect AFP may still be PowerPC based. Try installing Rosetta on the other machines having trouble and see if it makes a difference.
    An Apple user since 1981, Mac OS X (10.6)
  • Bob Leland Calculating status...
    Currently Being Moderated
    Sep 6, 2009 12:58 PM (in response to BradPDX)
    Try this. After several days of trying many things, this fixed my connections:

    Open the System Prefereces/Sharing panel.

    In the first verticle panel Click on "File Sharing"

    In the second verticle panel, "Shared Folders" click on your Public Folder.

    In the third verticle panel "User's" click on the "+" to add a User.

    Add another User's sign on Name and Password.

    Do the same for you drop box.

    The added User will now be able to connect.

    Repeat, adding Users needed.

    Good Luck

    The Permissions Read & Write
    iMac 24", 2.8ghz, 4gb; Dual 867 MMD, 2gb, 1 tb mirrored ext.; iMac 20", G5, Mac OS X (10.6)
  • [ shua ] Calculating status...
    The problem with this is, for example, if I create a file (Word, Pages, whatever) and save it locally in a shared folder, even users who are on the "Users" list and set as Read & Write can't edit that file. It results in a permissions error.

    Anyone found a fix to this?
    Mac OS X (10.6.1)
  • donv (The Ghost) Level 5 Level 5 (4,600 points)
    Currently Being Moderated
    Oct 26, 2009 7:45 AM (in response to BradPDX)
    You are correct. I use afp between my MBP and iBook--no Rosetta installed. Your problem is a strange one. You could try resetting your [PRAM and NVRAM|http://support.apple.com/kb/HT1379?viewlocale=en_US]. Also you could try reinstalling Sno over Sno as in an upgrade install. The procedure is very safe, but it still is an install. So, be well backed up.
    15" 4 GB 2.8 GHz 500 GB MacBook Pro with LaCie 1TB external 7200 RPM RAID 0, Mac OS X (10.6), PowerBook 540c; iBook G4; 2 Dell Laps; 1 HP Lap; Mega Gateway FX Desk
  • Stephen Hanson Calculating status...
    This fix worked for me with a variation. I have SL on a Mac Book Pro. my Desktop is a G5 running 10.5.x. I could always connect 10.6 to 10.5, but not the other way.

    When I was in the sharing preferences on the MBP, with "File Sharing" ticked and selected, I noticed that there was a folder called username's Public Folder-1. The username being my administrative account. I deleted this folder by clicking on the "-", then added a folder, clicking on the "+", and navigated to the correct Public Folder. Screen sharing and file sharing instantly worked between all machines, both ways.

    Thanks for this tip!
    MacBook Pro and G5 Tower, Mac OS X (10.6.2)
  • donv (The Ghost) Level 5 Level 5 (4,600 points)
    Currently Being Moderated
    Nov 27, 2009 7:32 AM (in response to BradPDX)
    BradPDX wrote:

    It's just that the AFP dead ends on this one machine.

    I have tried restarting File Sharing, fixing permissions, restarting the whole >machine - but the results never vary. Suggestions?

    On the errant Mac, if you haven't done so, go System Preferences > Sharing > Check mark File Sharing > Go Options > Check mark the AFP blurb. I feel confident that you have selected these settings. But, ....

    I suggest that, for now, you use Go > Connect to Server--afp://IpAddress in trying to connect to the errant Mac. To some extent, connecting using the shared section of a Finder window is broken for some in Sno.
    15" 4 GB 2.8 GHz 500 GB MacBook Pro with LaCie 1TB external 7200 RPM RAID 0, Mac OS X (10.6.2), Boot Camp/Win7; PowerBook 540c; iBook G4
  • Tajmari Calculating status...
    Currently Being Moderated
    Nov 27, 2009 7:33 AM (in response to BradPDX)
    Brad,

    I'm following this thread because I've had sharing issues, too. I have noticed that lately Firefox and Safari tend to be very slow. I have a Linksys router for a home network that links two 2009 macbook pros and one G4 older box. I have some control via a web page of my router, too. Would you please explain in a little more detail the process you used to change the DNS for your computers? I don't know what an OpenDNS server is.

    Thanks so much!
    macbook pro, Mac OS X (10.6.2)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.