Skip navigation
This discussion is archived

Time Machine just forgot about my iPhoto Library!!

2530 Views 14 Replies Latest reply: Apr 28, 2010 3:06 PM by Espen Vestre RSS
Espen Vestre Level 1 Level 1 (140 points)
Currently Being Moderated
Dec 3, 2009 6:06 AM
Hello,

today I exchanged my MacBook Pro's built-in 320GB hard disk with a 500GB one. As a preparation, I had bought a brand new 1.5TB disk for backup yesterday, and started a fresh TM backup on that disk. Today I then installed Snow Leopard on the new 500GB disk and restored from the TM backup. I got suspicious as I noted that the amount of data after the restore was too low, and started figuring out what would be missing. I was very surprised and disappointed to discover that my iPhoto library wasn't on the TM disk at all - on NONE of the backups!

The log on the TM disk says "Node requires deep traversal: /Users/<me>/Pictures/iPhoto Library reason:must scan subdirs|missed reservation|"

- but doesn't report any errors.

Very, very disappointing. I think I'll redo the restore from the old disk, I don't know what else may be missing, so...
MBP (late 2008) 15" 2.8/4/320 - MBP 15"/MBP 13"/MB 13"/PB 12" - iPhone 3G, Mac OS X (10.6.2), At work I use a Hush with Ubuntu 64 bit
  • macjack Level 9 Level 9 (50,445 points)
    iMac 24" 2.16 GHz 3GB RAM/22" external HP display, Mac OS X (10.6), iMac G4 17" 800 MHz 768MB/ iMac 333MHz 256 MB / LaCie d2s/ APC-UPS
  • macjack Level 9 Level 9 (50,445 points)
    Never mind that didn't work.



    -mj

    Message was edited by: macjack
    iMac 24" 2.16 GHz 3GB RAM/22" external HP display, Mac OS X (10.6), iMac G4 17" 800 MHz 768MB/ iMac 333MHz 256 MB / LaCie d2s/ APC-UPS
  • direwolf8 Level 4 Level 4 (1,280 points)
    I don't know of any backup program that will reliably backup open files. If you want proper backups, leave the computer on and exit all applications.
    G5, Mac OS X (10.5)
  • Pondini Level 8 Level 8 (38,710 points)
    Yes, it does appear that Time Machine will not back up the iPhoto "package" while it's open. That's what all those "reservation" plists are about. You'll also see a message in your system log when it does get backed-up, about a "deep traversal" being required because of a "missed reservation."

    And yes, it certainly should send a message, at the very least!
    24" iMac 9,1 2.66 GHz; 4gb; 640 gb, Mac OS X (10.6.2), dual-band AEBS v. 7.4.2
  • nolamike Level 1 Level 1 (5 points)
    Just posting to relate similar experiences. This must get resolved somehow. A message saying "the following items not backed up" is contrary to Apple's (and Time Machine's) "don't bother the user unless absolutely necessary" philosophy, but in this case, lacking a better solution, OK, bother me.

    In my case, I was surprised at how little space my fresh backup took, then realized that indeed my 205GB iPhoto library was missing. I quit iPhoto and waited several hours, and it would not put it into the backup. After a little forum reading, I was ready to wipe my backup drive, ensure iPhoto was closed, and try again, but then I remembered an old trick for another TM issue: Exclude the iPhoto LIbrary (under "Options..." in Time Machine), run a backup, then include it again. Sure enough, it is now being added to the backup as I type.

    But, to reiterate, this is really distressing. If I had to identify the group of files in my life I would most hate to lose, my photos would probably be it. I use two TM backup disks that rotate between being in use and sitting in my desk drawer at work, to ensure my files are safe. [By the way, if you don't have an offsite backup, consider the possibility of fire or theft, which in a flash could wipe out your original and your backup.]

    In general, Time Machine is an awesome application and concept, but I'm glad I'm not on the receiving end of certain support calls Apple must be receiving these days.
    Intel iMac 24" GT 120 graphics, Mac OS X (10.6.2)
  • Almarmar Calculating status...
    Currently Being Moderated
    Feb 10, 2010 3:09 PM (in response to nolamike)
    Another one with the same problem, but with a small difference: when I have iPhoto opened and a Time Machine backup starts, what Time Machine decides is to backup the entire iPhoto library!! Mine is 68GB full of photos and some videos!!!! Try to realize how long it takes to backup that amount of data, and how funny is to discover that, two months ago, my oldest backup was one year old, and now, as the 1TB Time Machine is full of iPhoto garbage, the oldest backup is from november 2009!! Just two months ago!! I've lost all previous backups forever!! Great job Apple!! Another reason to migrate all my photos to Picasa. I'm having more and more reasons every day, as iPhoto becomes more and more slow and do things like this with backups...

    I'm really dissapointed with iPhoto. My biggest illusion before buying my first Mac, and my biggest deception after it. Some reasons:

    -Geolocation only works for itself, if you want to export your photos to Picasa, you have to geolocate them again.

    -Events only works for itself: even in the iPhone, they don't exist. You have folders instead. Oh, yes, and faces, that thing very funny to play with the first days and that almost everybody forgot about long time ago.

    -Extremely slow RAW processing.

    Etc...

    EDIT: I just edit to correct one information. I have just verified the logs and the last deleted backup is fabruary the 9th, 2010!! Two days ago!! Even funnier!!

    Message was edited by: Almarmar

    Message was edited by: Almarmar
    Two Macbooks (11/2008), Time Capsule and Mac Mini (3/2009), Mac OS X (10.6.1)
  • Almarmar Level 1 Level 1 (5 points)
    Hello,

    Some days ago I found something that I tried, and seems to work. At least, I don't have more "iPhoto full backups" after this thing. I'll try to explain it:

    I booted from the install disc, and from the utility menu, chose reset password for Macintosh HD, and at the bottom of the box clicked Reset Home Directory Permissions and ACLs. Then, rebooted again from the HDD, and done.

    Why I did this? Because I saw exactly the same ACL error messages as in this post: http://www.mac-forums.com/forums/os-x-operating-system/167580-successfully-remov ed-acl-found-but-not-expected-warnings-permissions-repair.html
    And in some other place, I read that our iPhoto problem is related to the permissions and some systems files that tell to Time Machine which photo is backed up and which doesn't. And as this solution reset all home directory permissions, I decided to try. The only consequence of this solution is that all spotlight data of your computer is deleted and indexed again, but I think it worth the try , as you don't loose anything.

    I'm not sure if it has 100% solved my trouble, but since I did it one month ago, Time Machine seems to be working again as expected. I wish it
    Two Macbooks (11/2008), Time Capsule and Mac Mini (3/2009), Mac OS X (10.6.1)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.