Skip navigation
This discussion is archived

Airport Express error (-15006) when trying to connect as a remote speaker?

55425 Views 70 Replies Latest reply: Apr 27, 2010 7:59 PM by r64david RSS
  • juseppe Calculating status...
    My AE works in Client mode, i.e., streaming music in my wifi network. As someone else said before, it eventually disconnects from iTunes and stops working with famous message 15006.

    One of the interesting things I have observed is when it happens, Config Tool in my PC does not find any AE. HOWEVER, if a choose "config another", and I supply ip address and password of the one not working, the config tool detects and connects properly. Afterwards closing that access, that damned SW insists in finding NO AE in my network. How is that possible?? Grrrrrrr
    Win XP, AE 7.4.2
  • Morganeer Calculating status...
    My error message is "An error occurred while connecting to the remote speaker...an unknown error occurred (-15000)." I don't know if error 15000 is substantively different from error 15006, but I have the same problem that everyone else in this thread has: AE status is green, but can't stream music from iTunes. My AirPort Express is brand new, installed under Windows XP SP3. My Linksys wireless router has no IP6V, whatever that is. Has anyone found a fix? Thanks!
    Dell 8400
  • Dan4mac Calculating status...
    Hi guy, I read the complete post and no luck.
    I stopped working about 7 days ago. Since then, I just can't get it to work.
    I always get error -15006.
    Any ideas ? Can an Apple Engineer get to us and help us out ?
    Thx !
    - Daniel
    MacBook Pro 15 - 2007
  • Steve H Calculating status...
    The first time I noticed this problem was when my Airport Express (named "Living Room Airport Express") stopped appearing as a play option at the bottom of the iTunes window. I restarted iTunes, no luck. Then rebooted Airport Express router, and restarted iTunes, no luck. Then reset the AE router (pen in the reset button). Then launched Airport Utility and set it to join existing network (my main router is a Netgear 802.11n), and quit Airport Utility. Relaunched iTunes, the "Living Room Airport Express" appeared but when trying to play a song, the spinning "wait" beachball appeared and after a minute, got the -15006 error. The light on the Airport Express is steady green - meaning that it should be working, yes...? This discussion board topic has been going for awhile - is anyone in Apple monitoring this thread? Thanks.

    (PS - Dear Apple Technical Support - I recently erased and reinstalled EVERYTHING on this computer, so it should be pretty useful if you want to contact me and troubleshoot this with me - see Applecare my case history)
    MacBook Pro Model 5,1 (late '08) 2.53 Ghz 15" 4Gb RAM, Mac OS X (10.6.2), iTunes Version 9.0.2 (25)
  • leeringluddite Calculating status...
    i have exactly the same problem as all i've read on the web and no joy so far. i have reboot and reset everything i can think of and would be considering a clean install of osx if i wasn't pretty sure that the problem seems to be linked to itunes 9.0-2 it is almost exactly to the hour that both my airport express units stopped working after 3 years or so of heavy usage.

    i have had the same problem with Airfoil too, a great app that has worked happily alongside other software for over a year.

    Buggy software is not good,
    mac book pro 15", Mac OS X (10.6.2)
  • Steve H Level 1 Level 1 (5 points)
    This is my post to MacWorld's forums last night. As of now, 23 views but no responses.

    http://forums.macworld.com/index.php?/topic/120307-airport-express-itunes-9x-err or-15006/

    I also use Airfoil, doesn't work for me either, suddenly. Like you, I've been using AP Expresses in my home for several years, and suddenly, doesn't work. Unacceptable.
    Q4'2008 MacBook Pro 2.53 Ghz 15" 4Gb RAM, Mac OS X (10.5.5), iTunes 9.0.2
  • Steve H Level 1 Level 1 (5 points)
    "-15000" errors, including "-15006" are firewall-related. Here are the steps that an AppleCare engineer took me through, to resolve my issue (see above). I reached this engineer only after two escalations, so this is not a well-known issue or fix.

    (These instructions are for a Netgear router - non Netgear devices should have very similar options and nomenclature)

    0) Quit iTunes

    1) Open your Web browser and in the URL field, enter "192.168.0.1" (typically the default URL for your primary router, regardless of make).

    2) This should bring you to the Admin screen of your main home router (for example, Netgear - not the Airport Express itself). If you secured your router, it will prompt you for your ID and password. If you don't remember it, you may need to do a "factory reset" and then re-set it up with a new name and password, then re-setup the security, such as WPA2 (remember to write it all down!!!)

    3) In the admin menu, select the menu option that lets you specify Ports and port exceptions. In the Netgear admin menu, this is under "Advanced/Port Forwarding & Port Triggering," for example.

    4) You will now add a "rule" that allows iTunes to stream over your router. Select "Port Triggering" and "Add service." You will be prompted to name this rule - I used "iTunes streaming." Then, "Service type" is TCP, the triggering port is 548.

    5) Under "required inbound connection," enter Port 548 (which is TCP / Apple Filing Protocol over TCP) through Port 554 (TCP/UDP / RTSP for streaming media players and Quicktime Streaming Server). If there is an option for it, make sure that "Service user" is set to "Any" so everyone using your network can get to it.

    6) Save settings, exit your router's Admin screen, using the "exit" option in your router's admin screen. Don't just close the window.

    7) Restart iTunes. You should see a dropdown menu in the lower right hand corner of the iTunes window, labeled "Computer." When you click on it, the resulting dropdown menu should also list your AirPort Express routers.

    Additional troubleshooting:

    If you have the firewall enabled on your Mac itself, go to System Preferences/Security/Firewall/Advanced and remove iTunes from the list (select it, press the "minus" symbol at the bottom of the list window), then hit the "plus" symbol to re-add it.

    Both the "Stealth Mode" and "Automatically allow Signed Software to receive Incoming Connections" options can be enabled - should make no difference.

    If this still doesn't work, you may need to re-setup the AirPort Express routers themselves. Use the AirPort Utility to do this. Join existing network (you may need to enter its name, security type and password manually. Remember to name your router with a name that you will remember later.

    This fixed mine!
    Q4'2008 MacBook Pro 2.53 Ghz 15" 4Gb RAM, Mac OS X (10.5.5), iTunes 9.0.2 (25)
  • djmcclosky Calculating status...
    Same problem here. Everything worked for years and then mysteriously no number of resets, or hard resets would get it to work again. At one point I got a constantly blinking amber light. That was resolved by turning off the ethernet in the manual settings. I only use my airport to stream music.

    I resolved the error message by going to the the manual setup and (even though the ethernet had been disabled) selecting "distribute a range of IP addresses" under "connection sharing"

    Everything now works.
    pc
  • Dan4mac Level 1 Level 1 (0 points)
    Hi guys,
    I finally get it to work... Here is what I did (and of course, I do not know what had an impact or not, but I did not do much)
    0. The symptoms are as described in my post a couple of days ago. (i.e. Airport Express Light Green, error -15006, no change by factory reset and reboots)
    1. In the Preferences-> security-> Firewall I removed and re-added iTunes.app; but this did not change anything (still failed afterwards). (just for info)
    2. My IP is 192.168.1.11 and the airport is .13 ; my router is .254
    3. I went to my router (brand new French Freebox) webpage on free.fr, logged in with my account.
    On this web page, go to the internet setting and then "configure my router"
    In the port redirection section:
    Set 2 new port settings
    Line 1: port 548 (thx guys),tcp, IP: x.13, port 548 => press add
    Line 2: port 548, tcp , IP: x.11, port 548 => press add
    press Send at the bottom;
    I think that any traffic that goes through my router on this port will be redirected to the Airport Express (let's say the second line is for the back path -- but honestly it was just a try)
    4. reboot the router.
    ==> It worked right afterwards.

    I worked a LOT on this trying all kinds of networks configuration (dhcp or static, different subnets, with or without cable)
    The fact that it worked with this step only is for me somehow an evidence that the problem is a firewall problem.
    You may or may not think it is, though.

    I hope you'll be lucky as I was today !!

    Buy and thx for the port 548 tip.

    - Daniel
    MacBook Pro 15 - 2007
  • leeringluddite Level 1 Level 1 (0 points)
    ok, so i've turned off firewalls (router and mac) and now itunes tells me that the network connection has failed. AE still green and happy looking, the AE name comes up on the speaker drop down on itunes so it looks good but still the network connection fails.

    suggestions?

    thanks in advance

    LL
    mac book pro 15", Mac OS X (10.6.2)
  • leeringluddite Level 1 Level 1 (0 points)
    btw, when i connect with an ethernet cable i can stream. it must be a network problem? but if all firewalls are off............?
    mac book pro 15", Mac OS X (10.6.2)
  • Guillaume Fiastre Calculating status...
    I'll add my testimony:
    I tried every solution here, nothing changed. When I boot the AE, they appear. Sometimes work, and then at some point I have the itunes error and they disappear.
    Here is my setup:
    Mac and Pcs in the house. 3 AE in different rooms.
    I use a router from Free (French ADSL provider).
    I used to connect via WIFI, but the connection was unstable. So I switched to CPL (Ethernet network via electricity wires).
    It has been working for years.
    Then, for the past two months, the error has appeared.
    Two things: I switched to Snow leopard, and I changed my DEVOLO CPL from 200 AV to 200 AV+.
    So I can't know where the problem comes from. No changes on the router side.

    But here is the interesting bit: For one of the three AE, i use a switch/Ethernet Hub between the CPL and AE (other devices are connected), and this one as never failed. Not once.
    It is as if the switch keeps the connection alive.
    I have switched one of the AE back to WIFI to see if it works better, I'll keep you posted.
    But all in all, it seems to be either coming from Snow Leopard or from the network I built with CPL. It can be both of course...

    Thanks for any help, it is very bothering.
    Guillaume
    MacPro 2008, Mac OS X (10.6.2)
  • Dan4mac Level 1 Level 1 (0 points)
    Allright, so in my post a couple of days ago, I said it was resolved.
    So I need to post again:
    The problem appeared again (exact same symptoms)
    However, as I said before, I configure the router to let some specific ports go through the router. But since I use DHCP, the IP addresses changed... I guess that's why it failed again.

    But there comes the interesting stuff.
    I verified what IP addresses had my mac and Airport Express. And changed the router configuration to match those news IPs.
    Guess what: it works again.

    I know I have to do the test again to reproduce it 100% but you know how it is when it starts working... you don't wanna touch it

    Good luck to you all,

    - Daniel

    PS: Can Apple take care of this, please !! it's annoying and drives my wife crazy when I stay in front of the computer another half hour to be able to listen to music in our living room.
    MacBook Pro 15 - 2007
  • wpswps Calculating status...
    I got this error when I tried to stream iTunes from my Vista PC desktop to my new AE. I solved the problem by going into control panel -> windows firewall -> Allow a program through the firewall -> check mDNS-SD/Bonjour. Also verify all Bonjour services are enabled. This solved my problem. I did not have to mess with my router etc - just the firewall on the machine hosting iTunes.

    My hunch is that the Airport utility sets up the firewall on the machine you use to configure the AE so streaming works. So an alternative is to use the Airport utility to configure the AE again from the machine that is not working.

    I believe this is why iTunes/AE worked fine from the Vista PC notebook i used to set up the AE. I configured the AE to connect to my existing wireless network from my notebook using an ethernet cable and the Airport utility. Verified that iTunes could stream from my notebook to AE.

    Hope this helps.
    HP, Windows Vista
  • Asa Durkee Calculating status...
    Currently Being Moderated
    Dec 30, 2009 8:49 PM (in response to Gester737)
    Disabling IPv6 "fixed" it for me as well... it at least allowed me to select the Extreme in iTunes without crashing the Extreme (error -15006 and a solid green light on the Extreme).

    Now it's freezing after a few seconds of the song, but whatever. I swear, it's a manifestation of a larger issue; AirTunes functionality became crazy janky for these boxes about a year ago. I used to show it off to my various guests- "look at this cool tech," I'd say, "it's like living in the year 2000!" - and now I'm ashamed of it, as it never works right. Even got a new AirPort Express today (unrelated warranty issue) and it's still exhibiting the same problems.

    Troubleshooting like this makes me feel so... dirty... as if I'm using some gaudy D-Link product that was half-engineered when it went out the door. Typical Apple move though. When they focus on something (like a new product) they get it right, but when they put something on the back burner (transitioning products and technology to maintenance mode), holy heck does it suffer.

    Eh, whatever; enough people are claiming it works fine that I should probably look at the rest of my ridiculously unsupported setup (hm? the DD-WRT router? the Solaris laptop server? etc.)
    Unibody something or other, Mac OS X (10.6.2)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.