Skip navigation
This discussion is archived

Asked for serial number on each start up + can't create client installer

11038 Views 16 Replies Latest reply: May 13, 2010 7:27 AM by macphreak4evr RSS
1 2 Previous Next
Kevin Watson Calculating status...
Currently Being Moderated
Nov 19, 2009 8:50 AM
Hi,

I just purchased and installed ARD 3. I have also updated to the most current Admin software.

I want to use ARD to control my mother's computer. She lives far away and is astoundingly proficient at screwing her Mac up.

- - -

Each time I launch ARD I am asked for my serial number. Once the number is entered ARD launches. Is this normal?

- - -

When I try to create a Client Installer, the "Create Client Installer" option in the File menu is 'greyed out.' Am I missing something obvious?
iMac 2.4 GHz core duo, Mac OS X (10.6.2), ARD 3.3
  • varjak paw Level 10 Level 10 (167,155 points)
    Each time I launch ARD I am asked for my serial number. Once the number is entered ARD launches. Is this normal?

    Are you logged into Mac OS X as a user with administrator privileges? If not, this behavior would indeed be normal. You need have admin privileges for your user account, at least for the first launch of the ARD admin app.
    iMac 2.8 Core 2 Duo 24" 4GB ATI 2600, Mac OS X (10.6.2), PowerMac G5 2.0GHz DP, Dell w/ Windows Vista Unlimited SP2, several others VM
  • Befuddle Calculating status...
    I have always logged on as admin.

    Not sure if this is the problem, but I migrated my Mac from another laptop. Would that cause a similar problem? If so, how do I get around it?

    Thanks, Dave.
    Power Mac G5, MacBook Pro, Mac OS X (10.4.10)
  • varjak paw Level 10 Level 10 (167,155 points)
    I've seen ARD have problems when migrated. I'd suggest uninstalling the ARD admin app using the instructions here and reinstalling.

    Hope that helps.
    iMac 2.8 Core 2 Duo 24" 4GB ATI 2600, Mac OS X (10.6.2), PowerMac G5 2.0GHz DP, Dell w/ Windows Vista Unlimited SP2, several others VM
  • Armando Stettner Calculating status...
    Hi.

    I am having the same problems (ARD asking for the serial number on each invocation!). I have removed ARD according to the Apple Support "How to uninstall or disable Apple Remote Desktop 2 or 3" page referred to above and then reinstalled ARD (also did a software update). ARD still asks for the serial number upon invocation.

    I rarely log into an admin account.

    Given that logging into an admin account was NOT necessary in 10.5, that upon installing ARD it asks for an access password specifically for ARD, and that this seems to be new behavior in 10.6, I suspect it is a bug.

    Any other clues or suggestions??

    aps.
    MacBook Pro; PowerBook Aluminum; 2xMacMinis; QuickSilver, Mac OS X (10.6.2), Former UNIX kernel hacker
  • varjak paw Level 10 Level 10 (167,155 points)
    Logging into a Mac OS X account with administrator privileges has always, in my years of experience with ARD, been necessary to get the serial number to hold. It's not new behavior, and really isn't a bug, per se, since ARD writes that serial number to a preference file in a folder that requires administrator privileges to access.

    If you haven't tried launching ARD from a Mac OS X account with administrator privileges and then entering in the serial number, I suggest you give that a try.
    iMac 2.8 Core 2 Duo 24" 4GB ATI 2600, Mac OS X (10.6.2), PowerMac G5 2.0GHz DP, Dell w/ Windows Vista Unlimited SP2, several others VM
  • Armando Stettner Level 2 Level 2 (205 points)
    Dave, I perhaps can't claim the years of experience with ARD you have; I've only been using it for three years or so. I went back to my wife's 10.5 laptop on which I have an account with ARD. I logged in (after several months of not using it) and launched ARD with no problem whatsoever. I'm not sure how to reconcile my experiences and observations with yours....

    Are you suggesting that I *install from an admin account* or that an *admin account is always necessary to run ARD* ? I will try the former but I have made it a practice to rarely log into an Admin account....

    aps.
    MacBook Pro; PowerBook Aluminum; 2xMacMinis; QuickSilver, Mac OS X (10.5.2), Former UNIX kernel hacker
  • varjak paw Level 10 Level 10 (167,155 points)
    As I said in my post back in November, you need have admin privileges for your user account, at least for the first launch of the ARD admin app, for the serial number to hold. ARD writes the serial number to a preference file in /Library/Preferences/ to which folder only administrator accounts can write. Once the serial number has been written there, you can then run ARD from an account without admin privileges, but you have to launch ARD initially from an account with admin privileges or the serial number won't be kept and you'll have to keep re-adding it.
    iMac 2.8 Core 2 Duo 24" 4GB ATI 2600, Mac OS X (10.6.2), PowerMac G5 2.0GHz DP, Dell w/ Windows Vista Unlimited SP2, several others VM
  • Armando Stettner Level 2 Level 2 (205 points)
    Why is it insufficient for the installation to run, ask for the privileges it needs for the install and then to do what it needs to do - as do so many other tools/applications needing privileges? This does not make sense....

    I shall try this and see how it goes.

    aps.
    MacBook Pro; PowerBook Aluminum; 2xMacMinis; QuickSilver, Mac OS X (10.5.2), Former UNIX kernel hacker
  • varjak paw Level 10 Level 10 (167,155 points)
    I don't say it makes sense, I just say that's what it does. ARD doesn't write the serial on installation, it writes it on first launch, so there are no elevated privileges from the installer and hence you need admin privileges in the user account.

    If you choose not to believe me, that's up to you. I've given my advice, and you can take it or leave it as you choose. I'm done here.

    Message was edited by: Dave Sawyer
    iMac 2.8 Core 2 Duo 24" 4GB ATI 2600, Mac OS X (10.6.2), PowerMac G5 2.0GHz DP, Dell w/ Windows Vista Unlimited SP2, several others VM
  • tom_kobza Calculating status...
    The trick that worked for me is to go to Macintosh HD-Library-Preferences-and delete com.apple.RemoteDesktop.plist.
    MacBook Pro, Mac OS X (10.6.2)
  • Armando Stettner Level 2 Level 2 (205 points)
    I'm sorry Dave - where have I heard that before.....

    I've been traveling and dealing with other stuff (work!) and had not been able to get back to this thread.

    It is not a matter of belief. I tried what you suggested (login into an admin account and install it from there) and it worked just as you said!!! All is fine now. Thank you for your suggestion.

    armando
    3xMacBook Pro; 3xMacMinis; AppleTV, etc., Mac OS X (10.6.2), Former UNIX kernel hacker
  • Armando Stettner Level 2 Level 2 (205 points)
    Thanks, Tom. I did not try that but, Dave's suggestion worked once I got it through my thick skull what to try....
    3xMacBook Pro; 3xMacMinis; AppleTV, etc., Mac OS X (10.5.2), Former UNIX kernel hacker
  • fergieville Calculating status...
    My Mac just came back from the genius bar with a new hard disk (Snow Leopard). When I installed ARD, I had the 'always prompting for serial number' problem even though I was installing as an admin.

    When I went and checked the Library -> Preferences folder, the Sharing permissions for admins was set to "Read only." I changed the setting to "Read & Write" and everything began to work correctly.
    iMac, Mac OS X (10.6.2)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.