8 Replies Latest reply: Mar 22, 2010 9:09 PM by MN-DC
kubrick2001 Level 1 Level 1 (0 points)
When i receive an email, and i hit Reply All, my email address is also in the TO or CC field. There is nowhere an option to disable this behavior.

I got this situation :
TO : email addresses of friends and my email address
FROM : my email address

How can i solve this ?

Mac Pro, Mac OS X (10.5.8)
  • 1. Re: OSX Mail : reply all -> my email address is also in to/cc field
    Ernie Stamper Level 8 Level 8 (37,475 points)
    Hi,

    With such messages, where my email address is the same as that I will Reply All with, my address is excluded, and this does not happen. Are you using an alias for these messages to be sent to, but receiving in a collection account, and then your replies are from your master account, perhaps?

    Ernie
  • 2. Re: OSX Mail : reply all -> my email address is also in to/cc field
    kubrick2001 Level 1 Level 1 (0 points)
    example :

    mail received ->
    From : friend x gmail account
    To : friend y gmail account
    Cc : my gmail account

    i do reply all in mail ->
    From : my gmail account
    To : friend x gmail account
    Cc : friend y gmail account, my gmail account

    How does it come that my gmail account is also in the CC field ?

    f.e. "Automatically CC: myself" is not enabled.
  • 3. Re: OSX Mail : reply all -> my email address is also in to/cc field
    Ernie Stamper Level 8 Level 8 (37,475 points)
    Very odd, especially since Gmail accounts can hardly be made to send an email to your own address!

    In your Sent mailbox, as seen in Mail, does your address appear in the Cc or To header? Or only when you receive the Cc?

    Ernie
  • 4. Re: OSX Mail : reply all -> my email address is also in to/cc field
    bmjohnson Level 1 Level 1 (0 points)
    I have the same problem as you kubrick. I haven't found a solution anywhere online.

    I definitely do not have "Automatically CC: myself"... enabled. I've tried deleting my Mail prefs and starting over, but the problem persists: Apple Mail cc's my own email address on all reply-to-all emails. This is with a Gmail POP account.

    I do not have the same problem on a different machine: MacBook Pro running 10.6.2 with an Exchange server, so it must not be a widespread issue. It surely is annoying though.
  • 5. Re: OSX Mail : reply all -> my email address is also in to/cc field
    appleconsumer Level 1 Level 1 (0 points)
    I now am having this same issue in mail 4.2. I have three accounts, exchange, gmail personal, gmail work. My preferences have "send new messages from: Account of selected mailbox" and no auto cc myself. Each account cc's it's own account address with reply all (exchange auto copies exchange) (gmail personal to gmail personal, etc). I cannot figure this out and is really frustrating me as I rely on this for work. I am new to mail as of SL upgrade so I could fully integrate with exch 2007. Please help!
  • 6. Re: OSX Mail : reply all -> my email address is also in to/cc field
    BilltheHutt Level 1 Level 1 (0 points)
    I have a variation on this problem. When I "reply all" in Mac Mail 4.2, addresses that were cc'd in the original email are not cc'd in my reply. The only outgoing address is "To:" the original sender. There is nothing in the Cc: box. When I "reply all" using my actual Gmail.com web page, this doesn't happen -- cc'd addresses in the original message are also in the outgoing reply. Any suggestions?
  • 7. Re: OSX Mail : reply all -> my email address is also in to/cc field
    thetrance Level 1 Level 1 (0 points)
    My Apple Mail app was doing the same thing. In my case I found a solution. It turns out that the email address that my coworkers were sending to was a duplicate email account with an alias. I added the alias to my current account settings by separating them with a comma. This allowed me to use only one account and kept my email address from showing up in the CC field when I hit "Reply All".

    Example 1:
    you@emailOne.com, you@emailTwo.com

    Example 2:
    FirstName@email.com, FirstName.LastName@email.com

    Hope this helps
  • 8. Re: OSX Mail : reply all -> my email address is also in to/cc field
    MN-DC Level 1 Level 1 (0 points)
    This worked for me too. My mail account is on Exchange 2007 and I have an alias. Adding the alias to the the email address field in the account settings worked perfectly. Thanks for the tip.