Skip navigation
This discussion is archived

Nano not updating Play Count

27481 Views 71 Replies Latest reply: Oct 6, 2010 4:54 AM by markmil RSS
1 2 3 ... 5 Previous Next
Trucido Calculating status...
Currently Being Moderated
Jan 8, 2010 9:43 AM
I just recently purchased the 5G Nano 16G and upgraded it to the latest firmware 1.3. Since getting the nano I added about 300 or so new songs to it and carried over about 1300 old ones. I was shuffling a lot of the new music on my way to and from work. When I got home I noticed that none of the songs play counts were updated.

So I decided to test it out at home, played a couple of songs, checked if they appeared on the recently played list and the first time I tried it, they did update. Then I ran a few more songs from various playlists/artists and those didn't appear on the recently played list nor were their play counts updated.

The issue seems to be on the Ipod itself and not with iTunes, and it appears to be random, although more often then not it does not update. It seems to be some sort of issue with memory where if 3+ songs are played it fails to store any of them as played. I couldn't find any answers to a solution so I came here hoping to find some answers. Thanks in advance.
Inspiron, Windows 7
  • CMCSK Level 6 Level 6 (10,200 points)
    Currently Being Moderated
    Jan 8, 2010 3:59 PM (in response to Trucido)
    I noticed that none of the songs *play counts* were updated.
    didn't appear on the *recently played list*

    Where are these settings on the iPod Nano 5th gen? I couldn't find anything about play counts or recently played list in the manual or in any of Apple's Knowledge Base articles. Thanks.
    Mac OS X (10.6.2)
  • CliftonR Calculating status...
    Currently Being Moderated
    Jan 13, 2010 8:56 PM (in response to Trucido)
    I don't have a solution, but I can confirm this problem. I have nearly 14000 songs in my collection, and use the Play Count and Last Played fields in iTunes with smart playlists to manage what goes onto my iPod. This approach has worked for several years with my 1st-generation Nano.

    I bought a new 5th-gen Nano shortly after Christmas and found that most of the time when I sync, the Play Count and Last Played information in iTunes is not updated. Occasionally, it will be updated for all of the songs I've played - it's all or nothing. I tried resetting it, updating it, reinstalling iTunes, none of that helped. I returned it yesterday and got a new one, thinking it must be defective, and found that the new 5G behaves the same way.

    My old Nano still syncs fine and always updates the info, so it appears not to be an iTunes problem; but the old one just won't hold a charge for very long.

    This is very frustrating because I rely on that status info to update my playlists so I can keep getting fresh tunes on the iPod.
    Custom-built PC, Windows XP, Core 2 Quad
  • CliftonR Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 13, 2010 11:25 PM (in response to CliftonR)
    I just realized it's also failing to update any ratings which I make on the Nano. Seems like the sync is only going one way, iTunes to iPod, and not the reverse.
    Custom-built PC, Windows XP, Core 2 Quad
  • eric4405 Calculating status...
    Currently Being Moderated
    Jan 14, 2010 9:01 AM (in response to Trucido)
    I too have the same problem with my 5th gen nano's 'last played' not updating on the nano itself.
    Dell Latitude D630, Windows XP Pro, SP3
  • boulder06 Calculating status...
    Currently Being Moderated
    Jan 16, 2010 2:45 PM (in response to eric4405)
    Same here. Just brought the Nano home an hour ago. I bought it specifically for the play count. I was happy with my Shuffle, but the play count doesn't update on that either. With the Shuffle, it's a known problem. Assumed Apple would have it fixed by now.
  • Melissa Andropoulos Calculating status...
    Currently Being Moderated
    Jan 18, 2010 9:21 PM (in response to boulder06)
    I am also having this problem and it is extremely frustrating since I use my Smart Playlists so frequently...has anyone found a solution or talked to anyone at Apple about it?
  • stm266 Calculating status...
    Currently Being Moderated
    Jan 22, 2010 1:30 PM (in response to Melissa Andropoulos)
    Hi,

    I have the same problem. This is not an answer but I wonder if it might be a step closer to the answer. I mostly get this problem when nano is docked on a gear4 dock I have. If I've listened through headphones or other docks the play count and recently played updates itunes fine. This gear4 is fine with my iPod classic so I'm pretty sure it's an incompatibility with the Nano. Can anyone else link the non-update with dock usage?
    Nano 16GB 5th gen
  • iPod Whisperer Level 3 Level 3 (775 points)
    Currently Being Moderated
    Jan 22, 2010 2:10 PM (in response to stm266)
    If you have your iPod set to manually manage your music. In other words, you drag the files to the iPod, then it will not update playcount.

    If you have it managed through playlists where you just click sync and your music syncs, it will update the playcount.

    Dragging music on and off your iPod is different than sync'ing and the system needs the sync'ing step for the playcount to be udpated.

    i
    MB Pro, MacPro, MacMini, iMac, MacServer. (Vista via Bootcamp), Mac OS X (10.5.5), Nano 4G, Classic 120, Shuffle, Touch. iPhone 3G
  • stm266 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 22, 2010 3:03 PM (in response to iPod Whisperer)
    It's set to work automatically. I'm going to take it back to the apple store on Monday and see what they say. Thanks for trying anyway.
  • stm266 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 25, 2010 11:51 AM (in response to stm266)
    took it to the apple store today. They tested it on their Macs and found it to be working fine. Typical! The error would not recreate in the store despite it being 'broken' all weekend. The best the guy in the shop could suggest was that this was a windows related fault. Whilst not the official line on it he guessed at the USB drivers. I have the number for the apple care team who specialise in Windows. Since getting home I've reloaded my music files (they had wiped it and formatted it for Mac to test) and it seems to be working correctly now (reloading from my computer did not solve the problem before). Watch this space - we'll see what happens.

    Does anyone get this fault when using a Mac?
    Nano 16GB 5th gen, Windows XP
  • iPod Whisperer Level 3 Level 3 (775 points)
    Currently Being Moderated
    Jan 25, 2010 12:32 PM (in response to stm266)
    I am using a Mac and I don't see it. I would say the best bet is to reinstall itunes. Here are the apple approved instructions for that:

    http://support.apple.com/kb/HT1925

    i
    MB Pro, MacPro, MacMini, iMac, MacServer. (Vista via Bootcamp), Mac OS X (10.5.5), Nano 4G, Classic 120, Shuffle, Touch. iPhone 3G
  • stm266 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 25, 2010 12:38 PM (in response to iPod Whisperer)
    already tried re-installing itunes. That did not work.
1 2 3 ... 5 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.