11 Replies Latest reply: Jan 12, 2010 10:17 AM by KOENIG Yvan
muhmi Level 1 Level 1 (0 points)
Hi

i updated to snow leopard and iworks09. All updates done. My older documents are written in Arial Regular 11. All the characters fl have changed to a strange symbol. Typing fl from new -> same strange characters. Problem doesn't occur with arial black or arial narrow. How to fix it?
Thanks muhmi

MacBook Pro, Mac OS X (10.6.2)
  • 1. Re: typing fl -> strange symbol
    Tom Gewecke Level 9 Level 9 (71,735 points)
    Sounds like possibly a bad font substituting for the real one. Try Format > Font > Ligature > Use None. Also in Inspector > Document, uncheck the Use Ligatures box at the bottom right.
  • 2. Re: typing fl -> strange symbol
    muhmi Level 1 Level 1 (0 points)
    Unfortunately there is no change, the same strange symbol (1 vertical line, two horizontal short lines, crossing the vertical line, Not possible to copy in here.)
  • 3. Re: typing fl -> strange symbol
    Tom Gewecke Level 9 Level 9 (71,735 points)
    the same strange symbol (1 vertical line, two horizontal short lines, crossing the vertical line, Not possible to copy in here.)


    Do you think it's the double dagger ‡ ?

    This happens whenever you type f followed by l ?
  • 4. Re: typing fl -> strange symbol
    Level 8 Level 8 (41,760 points)
    I tryed to reproduce what you get.

    Here with Arial Regular 11 the result is normal.



    I used the zoom set to 400%.

    The Apple delivered font, stored as :
    Macintosh HD:Library:Fonts:Arial.ttf
    is described as :

    773 236 bytes
    Creation/Modification 2009/07/16 07:43
    version 5.01.2x
    © 2006 The Monotype Corporation…

    Maybe you are using an other one or you have a corrupted fonts cache.

    Yvan KOENIG (VALLAURIS, France) mardi 12 janvier 2010 17:05:08
  • 5. Re: typing fl -> strange symbol
    muhmi Level 1 Level 1 (0 points)
    Exactly! this double dagger

    Message was edited by: muhmi

    Message was edited by: muhmi
  • 6. Re: typing fl -> strange symbol
    muhmi Level 1 Level 1 (0 points)
    I use the same font as you. Language German.

    This are the arial fonts installed:
    Arial Black.ttf
    Arial Bold Italic.ttf
    Arial Bold.ttf
    Arial Italic.ttf
    Arial Narrow Bold Italic.ttf
    Arial Narrow Bold.ttf
    Arial Narrow Italic.ttf
    Arial Narrow.ttf
    Arial Rounded Bold.ttf
    Arial Unicode.ttf
    Arial.ttf
    ArialHB.ttf
    ArialHBBold.ttf

    This double dagger appears every time I type f and then l
  • 7. Re: typing fl -> strange symbol
    Tom Gewecke Level 9 Level 9 (71,735 points)
    Exactly! this double dagger


    Does this only happen in Pages, or also in TextEdit if you select the same font?

    Have you made sure that there is nothing in Pages > Preferences >Autocorrection > Symbol and Text Substitution that produces the double dagger?

    Also go to Character Viewer, View = Code Tables, Tab = Unicode, 0000FB00, select FB02 and look in the Font Variation pane and see if any font shows a double dagger instead of fl.
  • 8. Re: typing fl -> strange symbol
    muhmi Level 1 Level 1 (0 points)
    TextEdit -> no problem fl as it should
    Autocorrection -> no double dagger
    Font Variation -> all the fonts show fl correctly, but Arial Regular, Arial Bold, Arial Italic and Arial Bold Italic show nothing
  • 9. Re: typing fl -> strange symbol
    Tom Gewecke Level 9 Level 9 (71,735 points)
    Open Fontbook and select Arial and do Preview > Show Font Info. Do you have more than one Arial? What is the Version of the one you have?
  • 10. Re: typing fl -> strange symbol
    muhmi Level 1 Level 1 (0 points)
    Dear Tom

    thanks a lot! I had an old microsoft version and the new mac version. Problem solved!!!
  • 11. Re: typing fl -> strange symbol
    Level 8 Level 8 (41,760 points)
    That exactly the track given by Tom in his first message :

    Sounds like possibly a bad font substituting for the real one.


    And what I wrote :

    Maybe you are using an other one


    Yvan KOENIG (VALLAURIS, France) mardi 12 janvier 2010 19:17:02