Skip navigation
This discussion is archived

Snow Leopard mini having DNS issues

50174 Views 101 Replies Latest reply: Mar 31, 2010 11:17 PM by marian.gilan RSS
  • rmmac Calculating status...
    Currently Being Moderated
    Nov 17, 2009 9:18 AM (in response to jpgoldberg)
    -I have a Snow Leopard DNS for local DNS on my LAN. I use OpenDNS for all other requests.
    -I have an airport extreme configured with my SL server as the first DNS entry and OpenDNS as the second entry. The search domain is the fully qualified domain of the SL server.
    -PC's and iPhone follow the rules and always use SL server as primary DNS lookups.
    -SL machines don't follow the rules it works some of the time but other times SL machines will use my alternate DNS source instead of SL.
    -I have configured an alternate DNS lookup in my Airport because I like my SL server to go to sleep at night.
    -Any suggestions how I can get my SL machine to always look to SL Server first?
    -There are occasions when my SL machines aren't using SL server for resolution that for some reason I can't even ping the IP of the SL Server. I find this behavior very odd. I usually just end up rebooting my Airport but it is really annoying.
    Mac Book Pro
  • Johanjpk Calculating status...
    Currently Being Moderated
    Nov 17, 2009 2:18 PM (in response to marian.gilan)
    We had this same problem with the setup like this. Now running on 2 DNS is doable but still a lot of problems.
    Macbook, iMac, Xserve, Mac OS X (10.6)
  • Perette Calculating status...
    Currently Being Moderated
    Nov 20, 2009 7:36 AM (in response to Johanjpk)
    Theory on the DNS issue: As a "feature", mDNSResponder is picking the fastest DNS server available. It normally sticks with the first on the list, but if that one is slow (even just hiccups) and it falls back to the second or third and gets a response more quickly, it then swaps the order to put the fastest one first-- for most users, improving their experience by eliminating network delays. This seems to be supported by testing: If I unplug my DNS server momentarily, my Snow Leopard box punts to the secondary (non-local) servers and doesn't go back to the first for a while after I plug it back in.

    One academic question is, what triggers reverting to the proper order? It could just be that my chosen secondary server is slow, so the reordering naturally happens again and my local again becomes primary. Or it may be coded revert to the "correct" order after a few minutes.

    Respecting that this feature is good for most users, I think what the rest of us need is a configuration option to enforce strict DNS server ordering.
    MacBook Pro, Mac OS X (10.6.2)
  • omnimac Calculating status...
    Currently Being Moderated
    Dec 20, 2009 4:30 PM (in response to jlann)
    This is a strange solution, but I have found a way for my clients to re-connect without having to restart. In all, create two identical locations. When your network connection goes down, toggle the location to the other one. Toggling to the other location (in this case the network uses DHCP) renews the network.
    Mac Pro, Mac OS X (10.6.2)
  • Rick Wargo Calculating status...
    Currently Being Moderated
    Jan 5, 2010 9:10 AM (in response to CEGSupport)
    I've created an SOA record for local. but to no avail - I still am receiving the same issue. I have now went down to a single DNS server as issued by my DHCP server - let's see how that goes.
    MacBook Pro, Mac OS X (10.6.2)
  • Rick Wargo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 5, 2010 11:13 AM (in response to Rick Wargo)
    It appears that pushing out a single (local) DNS server resolves (or at least works around) this problem for me.
    MacBook Pro, Mac OS X (10.6.2)
  • Thor Simon Calculating status...
    Currently Being Moderated
    Jan 12, 2010 6:55 PM (in response to Rick Wargo)
    There's a bug in Radar for this (multiple DNS servers sent to OS X 10.6 client via DHCP leads to intermittent DNS lookup failures which can persist until a reboot). It's worth filing one yourself so the existing bug will accumulate enough duplicates for Apple to make it a priority,.
  • jonabaker Calculating status...
    Currently Being Moderated
    Feb 11, 2010 2:48 PM (in response to shellprompt)
    @shellprompt - I'm seeing the same issue as you describe - dns not working for certain internal domains when I'm connected via an att aircard and a vpn (could be cisco ipsec or Juniper ssl). I have been experiencing this issue for a while now that I believed was related to my aircard and the way dns works with dns server assignment from ATT - but today I learned something.

    So I'm connected via aircard and Juniper ssl vpn using network connect. I have blah.com as a search domain. I run nslookup server1.blah.com and it succeeds, but if i ping server1.blah.com it fails as do other applications trying to access server1.blah.com. BUT - and here is the big news - when I remove that search domain from my aircard network pref the ping's by name now work!!! Unfortunately they only work for the Juniper and not the cisco.

    My company does have this same data in a applecare case and I too am eagerly awaiting 10.6.3 to see if they solve this resolv.conf/mdnsresponder issue but wondering if anyone has any comments on what I have found.

    Message was edited by: jonabaker
    MacBook Pro, Mac OS X (10.6.2), none
  • nicoladie Level 1 Level 1 (15 points)
    Currently Being Moderated
    Mar 14, 2010 12:02 PM (in response to jlann)
    I have the same problem with DNS, the strange thing is that one of my computers works but the other does not, even though they are all in the same local network using the same IP from the ISP.

    Then I tried to ping the unresolved host, and it bounced back with permission denied on the DNS unresolved machine. But if I sudo ping, it works.

    But on the machine that had no problem with resolving DNS, I don't need to sudo ping to get a response. So Snow Leopard is doing something strange to the permission, and I cannot fix the permission, even though I repaired the permissions, re-install 10.6.2 combo update.

    I had waited the DNS to propagate, flushed the DNS, but nothing works.
    iMac, MacBook, PowerBook, Mac OS X (10.6.2)
  • nicoladie Level 1 Level 1 (15 points)
    Currently Being Moderated
    Mar 15, 2010 7:33 AM (in response to jlann)
    Try check your firewall setting, esp. if you are using NetBarrier, check to see if your unresolved IP ended up in the StopList, and block any outgoing or incoming traffic to that IP, which may explain why you can lookup DNS but ping or any access are blocked,
    iMac, MacBook, PowerBook, Mac OS X (10.6.2)
  • avon_7 Calculating status...
    Currently Being Moderated
    Mar 15, 2010 6:08 PM (in response to jlann)
    I was having this problem on our LAN. Our DNS server is a 10.5.8 Server and most of our clients are 10.4 and 10.5.
    As soon as we added a couple of 10.6 clients, we started getting this problem as described on this thread.
    What fixed it for me is that I added a secondary zone ( slave ) DNS 10.5.8 server and also added it to our DHCP server to ensure DHCP clients were given the two DNS servers.
    Mac OS X (10.5.6)
  • marian.gilan Calculating status...
    Currently Being Moderated
    Mar 31, 2010 11:17 PM (in response to jlann)
    Hi,

    so after upgrade to 10.6.3 I followed http://support.apple.com/kb/HT4030, but I have one problem with this. After reboot none of my DNS server works and I need to do unload/load of com.apple.mDNSResponder.plist manually.

    Is here also someone else with same problem?

    Message was edited by: mgilan
    MacBook 4.1, Mac OS X (10.6.3)
1 ... 3 4 5 6 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.