Skip navigation
This discussion is archived

Copy / Paste folders on NAS, SMB (NTFS) - Error code -50

19343 Views 19 Replies Latest reply: May 28, 2010 6:26 AM by Frog studio RSS
1 2 Previous Next
Frog studio Calculating status...
Currently Being Moderated
Nov 4, 2009 8:40 AM
Hi Mac lovers,

With OS 10.6.1 we can't manage to move a folder from an Apple server to a Windows NAS, SMB (NTFS). We can though create folders, and move files but not folders, even when created locally on the NAS, and/or from a local Mac machine.

We get the following error:
+The operation can’t be completed because an unexpected error occurred (error code -50).+

Everything _runs perfect under 10.5.8_ with same configuration / accounts / keychains.

Few questions for you

- What is Error -50 referring to?
- Is it a know problem?
- Is there a known work around that could be operated under 10.6.1 (we all are developers, so scripting is OK if necessary)?
- Any inside information for a fix, if the fix is planned at all?

Thank you all in advance for shedding some light on this,

Frog Studio's team
2.26 GHz Intel Core 2 Duo - 2 GB 1067 MHz DDR3, Mac OS X (10.6.1)
  • K T Level 7 Level 7 (23,215 points)
    -50 paramErr Error in user parameter list


    Try copying fewer files...or find a utility and avoid the Finder for this operation.
    Intel iMac, Mac OS X (10.6.1), OLED Pano
  • Toddyt123 Calculating status...
    Im getting a similar problem but with a flash drive. It wont light my paste folders that have other folders in them, unless i paste them within an existing folder on the USB flash drive.

    The error code is 36.
    Mac Mini, Mac OS X (10.6.1), 1.83 GHz Core 2 Duo, 1GB RAM 200
  • BigG3522 Calculating status...
    I am running a DLINK NAS-343, with the drives formatted in EXT3, and I am experiencing the same problem in multiple folders and files. The scary thing about this is when I was using just a USB network share, everything went fine, its when I went to the NAS that I now have an issue. The NAS only lets me format to EXT3 or EXT2, and reformatting now, is really not an option as I have about 1TB of data I cannot lose.

    I am running 10.5.8.
    iMac 20 inch, Mac OS X (10.5.8), Dlink NAS-343
  • SilentStryder Calculating status...
    We're having the same issues with 5 MacBook Pro laptops. Everything worked fine under 10.5.x. Upgrading to 10.6 killed the ability to copy/duplicate folders. If I copy a folder with files in it, everything copies over but the process errors out after the files are copied. The folder remains grayed out and I can even navigate the folder and subfolders from a Windows machine. Something else worth mentioning is that the folder has the 'Date Created' attribute set to February 1946. It seems that OSX 10.6 tries to set an attribute that the NAS device does not like.
    Mac OS X (10.6.2)
  • Gary Jowett Calculating status...
    10.6.2 snow leopard
    I am connecting to a EMC Cellera NAS. Am able to copy a folder to the NAS on the command line but not the in the Finder, (error code -50).
    Folder appears greyed out and is empty on NAS after dragging and dropping.
    iMac 8,1, Mac OS X (10.6.2)
  • SilentStryder Level 1 Level 1 (0 points)
    We're using an EMC Cellera as well. Are you using a Virtual Data mover on yours? I've also tried setting a few parameters on the device to no avail.
    Mac OS X (10.6.2)
  • Plugger Level 1 Level 1 (0 points)
    I have experienced the same error message and gray folders after copying them to a networked Window server drive. The files would not be accessible from my Mac but they would be fully functional from a networked PC. However, when I individually copied the subfolder to the same drive, they copied fine and were accessible from my Mac.

    It acted like a permissions problem where it would let me copy files to the Windows server but not let me access them from my Mac once copied. But we double checked and rechecked the permissions, and that apparently was not the problem.

    I suspected the problem has to do with a corrupt folder or file within the folder copied - a corruption that bothered Macs but not Window (the .DS_Store file?). So on my Mac, I created a new blank folder titled "Clean" and then copied each of the visible subfolders from the problem folder into it. When I then copied "Clean" to the Widows server drive, it copied fine and the files were fully functional from my Mac.

    Since I replicate folder templates for my project file system, I suspect I may have been replicating a problem.
    MacBook Air (mid 2009), Mac OS X (10.6.2)
  • SilentStryder Level 1 Level 1 (0 points)
    Has anyone figured out this issue. I've been back and forth with both Apple and EMC.
    Mac OS X (10.6.2)
  • SilentStryder Level 1 Level 1 (0 points)
    Found a solution. The issue stems from the fact that Snow Leopard uses extended attributes instead of ._ files for storing resource forks. Ideally, using NTFS Streams would be a preferred choice as this keep the file system cleaner but there are times where the old way is the most stable way. I've only tested this with OSX 10.6 - 10.6.2 and an EMC Cellera NAS device.

    Create a file named nsmb.conf in the /etc directory using 'vi' within Terminal or creating the file on your desktop and copying it to /etc, Either way, you will need to authenticate as a super user. I used 'sudo vi /etc/nsmb.conf' to create the file, insert the information and save it.

    The data that needs to be in the file is as follows:




    #######
    [default\]
    streams=no
    #######



    After the file is saved, a reboot will be needed for the settings to take effect.


    Client: Macbook Pro, OSX 10.6.2
    Server: EMC Cellera NAS

    Further information:

    http://www.macosxhints.com/article.php?story=20091222051703927

    http://developer.apple.com/mac/library/documentation/Darwin/Reference/ManPages/m an5/nsmb.conf.5.html





    Here is an AppleScript that I have started using on the 10.6 Macbook Pros. It's not pretty, but it works.



    set the_password to ""
    repeat until the_password is "Correct"
    try
    set theFinderPID to do shell script "ps -axww | /usr/bin/grep '[>Finder'| awk '{print $1}' | head -1"
    do shell script "renice 1 " & theFinderPID password userpassword with administrator privileges
    do shell script "renice 0 " & theFinderPID password userpassword with administrator privileges
    set the_password to "Correct"
    on error
    display dialog "Sorry, the password entered was not correct. Please try again:" default answer ""
    set userpassword to text returned of result
    end try
    end repeat

    try
    do shell script "mv /etc/nsmb.conf /etc/nsmb.conf.bak" password userpassword with administrator privileges
    end try
    do shell script "echo '#####' >> /etc/nsmb.conf | echo '[default]' >> /etc/nsmb.conf | echo 'streams=no' >> /etc/nsmb.conf | echo '#####' >> /etc/nsmb.conf" password userpassword with administrator privileges

    tell application "Finder"
    display dialog "Your system needs to be rebooted for the settings to take effect. Do you want to reboot now?" buttons {"Restart", "Cancel"} default button "Restart"
    set HitButton to button returned of result
    if HitButton = "Restart" then restart

    end tell

    Message was edited by: SilentStryder
    Mac OS X (10.6.2)
  • Michael Pitogo Level 1 Level 1 (35 points)
    Yep can confirm our enterprise with 10.6.2 also suffers from this issue on our EMC Celerra NAS. Will try the fix to see if it works.
    iMac 27", Mac OS X (10.6.2)
  • kcaref Calculating status...
    Hi,

    Still waiting on Apple/EMC for a fix, but in the meantime, we haphazardly discovered a decent workaround: labeling the folder any color before copying to the NAS prevents the error from occurring. Hope this gets officially resolved soon...
    Mac Pro Quad-Core Intel Xeon, Mac OS X (10.6.2)
  • Martin Thorpe Calculating status...
    Hi we have a very similar issue with a Celerra 704G, we can copy files but not folders to the NAS. Also if we copy folders to the desktop we then can't Archive / Compress the folders. Tied the fix mentioned here and it re-instated Resource forks so Fonts ETC sre seen ok. help appreciated
    iMac 3.06Ghz, Mac OS X (10.6.2), The iMac is a Pip Pip Computer
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.