Skip navigation

No Network access: NSPOSIXErrorDomain:1

45181 Views 62 Replies Latest reply: Feb 4, 2014 7:57 AM by haroldp72 RSS
1 2 3 ... 5 Previous Next
jbksm Calculating status...
Currently Being Moderated
Jan 11, 2010 11:08 PM
I can't do anything that requires internet access--I can't access any websites in Safari, check for software updates, access email using Mac Mail, nothing.

In Safari, I get an error message saying "Operaiong could not be completed. Operation not permitted" (NSPOSIXErrorDomain:1) Please choose Safari > Report Bugs to Apple, note the error number, and describe what you did before you saw this message. (As for what I did before I saw this message, I can only answer, "I turned my back while my toddler was near my laptop... . )

I get a similar message in Mac Mail; in Firefox, just a message saying it can't access the webpage; in software update, nothing at all.

I've looked for answers online; nothing seems to help. It does not seem to be a networking issue; according to Network Diagnostics my connection "appears to be working normally" and the other computers in the house can connect just fine. Nor is it restricted just to Safari, unlike most of the other NSPOSIXError discussions I've found. (I tried reinstalling Safari just in case, but it didn't help.)

Any thoughts? Would reinstalling the OS fix it, do you think? And if so, what do I need to do/know before I take a drastic step like that? (Don't be afraid of talking down to me .)
MacBook, Mac OS X (10.5.8)
1 2 3 ... 5 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (2)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.