Skip navigation
This discussion is archived

ScreenSaverEngine first time open alert

12887 Views 4 Replies Latest reply: Jan 19, 2010 12:58 PM by Marco M. RSS
Richard Collyer1 Calculating status...
Currently Being Moderated
Sep 18, 2009 7:10 AM
A little over a week ago I updated my machine to Snow Leopard (and the 10.6.1 update). I have had my screen saver (built in picture displayer) kick in numerous times since. Suddenly this morning, I got the alert that is shown when an application is downloaded from the net: "You are opening the application ScreenSaverEngine for the first time. Are you sure you want to open this application? ..."

It is my understanding that this happens when the digital signature of the application is not seen or recognized. However, this is an application that comes with the OS. Is this an OS bug and I can safely open it, or should I be concerned that the file have been corrupted - in which case how do I fix it?

BTY, I do have a Time Machine backup and can go back to just after my Snow Leopard update. Any reason not to just restore that?

Message was edited by: Richard Collyer
Dual - Daul Core Intel, Mac OS X (10.5.6)
  • Loopis Billow Calculating status...
    Currently Being Moderated
    Oct 3, 2009 11:36 PM (in response to Richard Collyer1)
    I'm having this same problem. It's very annoying because my screensaver won't activate now on its own.
    Macbook pro 15" 2.4 GHz, 4GB RAM, Mac OS X (10.6.1)
  • AliGator35 Calculating status...
    Currently Being Moderated
    Oct 6, 2009 1:53 PM (in response to Richard Collyer1)
    Got the same problem here.
    Seems I got rid of it by updating my LaunchServices database :

    1) Open the Terminal, and log in with an admin account (by using su and/or sudo for example) if your current OSX account does not have admin privileges.

    2) Go to the LaunchServices.framework' Support directory :
    *cd /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.fra mework/Support*
    +(Note: in previous OSX versions, it was a subframework of ApplicationServices and not CoreServices, the path has changed since)+

    3) Use the "lsregister" commande line tool found in this directory to do a rescan/rebuild of your LaunchServices database. You can e.g. update your whole database with this command :
    *./lsregister -r -apps local,system,user*
    +(Or you can specify the path to the ScreenSaverEngine.app itself directly as a parameter)+

    ------

    After the LaunchService database has been rebuild, you should be good with ScreenSaverEngine (you can use an active corner to launch it immediately and check if the fix worked).

    HTH
    MacBook Pro, Mac OS X (10.6.1)
  • clbmacpro Calculating status...
    Currently Being Moderated
    Dec 29, 2009 10:47 PM (in response to AliGator35)
    I'll confirm AliGator35's fix.

    Running "./lsregister -r -apps ScreenSaverEngine.app" in the directory referred to above fixed the problem. Still don't know how I broke it though.
    Mac Pro, MacBook Pro
  • Marco M. Calculating status...
    Currently Being Moderated
    Jan 19, 2010 12:58 PM (in response to AliGator35)
    Got the same problem and fixed is as stated by AliGator35.

    However, after a few days, I had the same problem again.

    MM

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.