Skip navigation
This discussion is archived

How to remove a word from the spell checker?

3975 Views 6 Replies Latest reply: Jan 22, 2010 5:17 AM by shabalstaff RSS
OlafMeding Calculating status...
Currently Being Moderated
Dec 3, 2009 7:43 PM
How can I remove the word "fuer" from my spell checker? I meant to add the word "für".

I added the word "fuer" to the personal dictionary by mistake. Now I can not undo this mistake because the Ignore button for this word is grayed out.

*Here is what I did*: If you don’t want the word to be treated as an error, click Learn to add it to your personal dictionary. (In some applications, you can Control-click the word and choose Learn Spelling from the shortcut menu.)

*Here is what does not work*: If you accidentally add a misspelled word to the dictionary, type the misspelling in the Spelling and Grammar window and click Ignore, or Control-click the misspelling and choose Unlearn Spelling from the shortcut menu.

Thanks for your help.
Olaf
Mac Pro Early 2008, Mac OS X (10.6.2)
  • Golden Shoes Level 5 Level 5 (4,010 points)
    Currently Being Moderated
    Dec 3, 2009 8:02 PM (in response to OlafMeding)
    How to remove a word from the spell checker?.


    That's easy.

    Quit all applications that use the Spell Checker.
    Go to Home/Library/Spelling and open the file named "en" (for English).
    Delete the word(s) you don't want from the file, save the changes and quit.
    Restart the application you were using with the Spell Checker.
    Mac mini G4, 1.42 Ghz, Mac OS X (10.4.11)
  • shabalstaff Calculating status...
    Currently Being Moderated
    Jan 21, 2010 2:01 PM (in response to OlafMeding)
    I went into Macintosh HD\Library\Spelling but there was no file called 'en' there. Is it somewhere else?
    MacBook, Mac OS X (10.6.2)
  • varjak paw Level 10 Level 10 (167,195 points)
    Currently Being Moderated
    Jan 21, 2010 2:26 PM (in response to shabalstaff)
    Wrong folder. It's in your user's Home -> Library -> Spelling, as GS said.
    iMac 2.8 Core 2 Duo 24" 4GB ATI 2600, Mac OS X (10.6.2), PowerMac G5 2.0GHz DP, Dell w/ Windows Vista Unlimited SP2, several others VM
  • shabalstaff Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 22, 2010 5:17 AM (in response to varjak paw)
    I found the file -thank you - but it did not solve my difficulty. Let me explain. I could not think how to spell ridiculous and spelt it phonetically, (i.e. 'rediculus') depending on the checker to correct it but pushed the Learn key in error. I had also told it to 'learn' two words in my address that showed up as spelling errors. When I look in the en spellings file the two words in my address are there but not 'rediculus' although Mail still does not show it as a spelling error and it still appears listed in the Spell Checker options.
    MacBook, Mac OS X (10.6.2)
  • shabalstaff Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 22, 2010 5:34 AM (in response to shabalstaff)
    Sorry. Disregard my last message; I am new to Apple as you may have guessed. I found 'rediculus' listed in the "LocalDictionary" file in the same directory. I deleted it and the problem was solved.
    MacBook, Mac OS X (10.6.2)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.