1 2 3 Previous Next 103 Replies Latest reply: Dec 6, 2010 3:37 AM by Gabriel Ponzanelli
Mark Alan Thomas Level 1 Level 1 (85 points)
Now, I'm no expert, so correct me if I'm wrong, but I don't think turning my photos teal green constitutes an improvement over version 2's raw processing:

http://homepage.mac.com/markalanthomas/.Public/green.jpg

24" iMac 2.8 GHz 4GB, Mac OS X (10.5.6)
  • 1. Re: Aperture 3 goes green
    William Lloyd Level 6 Level 6 (19,355 points)
    Any chance you applied a Tungsten preset?
  • 2. Re: Aperture 3 goes green
    Mark Alan Thomas Level 1 Level 1 (85 points)
    Sadly, no. And no color adjustments have been made.
  • 3. Re: Aperture 3 goes green
    cwog Level 1 Level 1 (85 points)
    on the screen capture the white balance tick is enabled.
  • 4. Re: Aperture 3 goes green
    Mark Alan Thomas Level 1 Level 1 (85 points)
    True. But unfortunately that's not why the image is green.

    I hadn't made any changes other than to click "Reprocess," and I only did that because the gamma appeared to be off and the blue sky slightly purplish after the Library update.

    For the record, the images are DNGs from Canon 10D raw files, and Aperture 3's RAW Fine Tuning brick does correctly identify the camera as "Canon EOS 10D."

    As an experiment, I reset all adjustments and clicked "Reprocess" again. Same result. Green.
  • 5. Re: Aperture 3 goes green
    firstlaunch Level 3 Level 3 (610 points)
    Does this stick if you scale the Viewer? What happens if you delete and then update the Preview?
  • 6. Re: Aperture 3 goes green
    Mark Alan Thomas Level 1 Level 1 (85 points)
    Yeah, it sticks in both cases. And oddly, the thumbnail updates immediately, but the actual image in the viewer kind of takes its sweet time and only updates if I do something radical like enter full screen mode, or load a different image and then come back to it. Although the exact steps it takes aren't consistent.

    Bummer.
  • 7. Re: Aperture 3 goes green
    cwog Level 1 Level 1 (85 points)
    Have you tried to use the Aperture 2 Raw processor - if it was like in Ap 2 and you had Ap 1 installed previously you could swap between the two processes - I got this info from a video tutorial so I could be wrong.

    Have you tried exporting a jpeg from Ap 3 and seeing what it looks like outside of Ap

    If you have Photoshop installed have you sent the image to Photoshop via PSD or Tiff to see how PS sees it.

    These are just diagnostic tests.
  • 8. Re: Aperture 3 goes green
    Rafael Muller Level 1 Level 1 (0 points)
    I am seeing exactly the same problem with my Aperture 3 library. My files are mostly Canon EOS 5D RAW files. If I click reprocess they get exactly the same green cast.

    One thing I tried was to export and import the master RAW file. It seems that if I export master from the library and then drag that into another project inside Aperture then it properly seems to properly handle the file.

    Any ideas on how to address this?
  • 9. Re: Aperture 3 goes green
    Rafael Muller Level 1 Level 1 (0 points)
    I take that back. I thought it worked but eventually it turned green also.
  • 10. Re: Aperture 3 goes green
    Mrbiskit Level 1 Level 1 (0 points)
    My Raw Canon 5d images show the same green tint. However, if I click the Reset button for the RAW Fine Tuning on the Adjustments Tab, the picture clears up.

    If I toggle from one image to another and back, the image says it was adjusted in an earlier version of Apple's Raw processing and needs to be reprocessed. Doing that, causes it to go green again. It does appear that I have access to the advanced features for this image though... that supposedly required the A3 reprocess.

    Also, I can't select a lot of photos and make the reset change to all of them... it only appears to take affect on the last pic I selected. Still experimenting.
  • 11. Re: Aperture 3 goes green
    Mrbiskit Level 1 Level 1 (0 points)
    I'm an idiot. Did a lift/stamp on the raw adjustment and it fixed the pics, guess it's a workaround for now.
  • 12. Re: Aperture 3 goes green
    Rafael Muller Level 1 Level 1 (0 points)
    *SOLUTION FOR MY PROBLEM*

    I noticed something when working on this. I have two different cameras that do RAW. A 5D and a newer Rebel T1i. I noticed that the Rebel adjustements showed up as Apple - Camera Default and the 5D didn't. I remember playing with this back in Aperture 1.x

    So, to get rid of that what I did was goto Application Support in your USER account.

    In my case is:

    <USER>/Library/Application Support/Aperture/

    There are a couple of files there:

    Adjustment Chain Presets.plist
    AdjustmentDefaults.plis
    AdjustmentPresets.plis
    Raw Decode Presets.plist

    I moved them out of that folder instead of deleting them just in case. Fired Aperture back up and now the 5D shows as adjusted with Apple - Camera Default

    Ran re-process and NO green hue anymore.

    Raf
  • 13. Re: Aperture 3 goes green
    Taverner Level 1 Level 1 (25 points)
    I have the exact same problem, in my case it is with older images from my Canon 30D.

    Removing these files from the Application support folder indeed solves the problem for now, but Apple needs to bugfix this.
  • 14. Re: Aperture 3 goes green
    Mark Alan Thomas Level 1 Level 1 (85 points)
    I can confirm that deleting the Raw Decode Presets.plist from ~/Library/Application Support/Aperture solves the green problem. Well done, Rafael!

    Unfortunately, this doesn't cure all of my woes. My images are still opening with heightened black levels and some color problems, namely purplish skies.

    Also, this doesn't explain why the "Reprocess" button is available for my images when the 10D is not among the cameras for which updated processing is supposed to be necessary.

    But we're definitely getting somewhere. Cool.
1 2 3 Previous Next