Skip navigation
This discussion is archived

Problems importing iPhoto to Aperture 3 - Insufficient Disk Space

3457 Views 6 Replies Latest reply: Feb 22, 2010 12:09 AM by Daniel W RSS
SimeP Calculating status...
Currently Being Moderated
Feb 16, 2010 9:19 PM
I have just purchased A3, and am trying to import my iPhoto library into Aperture. The iPhoto library is 57Gb, and I am importing to an external HDD that has 660Gb free. I am importing into my aperture library, following the process described in the guide.

Each time I try this, the import goes into error, saying I have no space to import the library to.

The error message is as follows, "*Insufficient Disk Space* - There is not enough free space on your Aperture Library Volume to import the selected items. It is estimated that you need at least an additional -2147483647MB of Space"
MacBook Pro, Mac OS X (10.4.7)
  • DEFii Level 1 Level 1 (0 points)
    I had this same issue. I solved it by copying my aperture library to the external drive, deleting the copy on the computer, then importing the library back into Aperture 3. It takes forever and ever and ever...
    iMac, Mac OS X (10.6.2), MacBook Pro
  • Wingrove Calculating status...
    Same issue here, 75GB iPhoto library, half a terabyte of disk space available.
    Aperture says me i need -2147483647MB of space. which is a lot.. or minus a lot?
    Macpro 8X 6GB/2TB 2x23" MacBookPro 17", iPod touch 16gb, Mac OS X (10.5)
  • David Mikulin Level 1 Level 1 (20 points)
    I resolved this problem by rebuilding the offending iPhoto library using iPhoto Library Manager. It created an entirely new library, maintaining all of the metadata. The new library imported just fine into A3.

    I only had this problem on one of about 10 iPhoto libraries, but it sure was annoying.
    2x iMac Intel Aluminum, iMac G4 LCD, iBook G3, Mac OS X (10.6.2)
  • Daniel W Calculating status...
    I downloaded the trial version, and loaded it up onto my new 27" iMac, running Snow Leopard in 64 bit mode, with 600 GB free on the hard drive. I tried to import iPhoto - same error, same "insufficient disk space amount". Yah, my library is about 60 GB, not 2000 GB!

    I did two things: First, I opened iPhoto from the finder by holding Option+Command, then in the resulting box, told it to rebuild the thumbnails. It chugged along for a while. After it was done I quit iPhoto. I then opened Aperture 3 trial, and imported the library. Same issue.

    However, I tried it again - this time, I told it to save the photos in a folder - "Photos" it says - rather than in the Aperture library file. Tada! Works like a charm.

    The import is still going after quite a while - slurping down all the CPU and RAM my iMac can provide while doing it - but it's working!
    27" iMac Core2, 15" MPB, 15" PB G4, PM G4 x2, G3 iMacs x2, iPods, Mac OS X (10.6.2), Sawtooth and Quicksilver G4, iPod Touch, Mac SE/30, and others!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.