Skip navigation
This discussion is archived

Aperture 3 - graphic bugs

20715 Views 74 Replies Latest reply: May 26, 2010 5:51 AM by Petter Vitestam RSS
  • sebastienb Calculating status...
    Currently Being Moderated
    Feb 25, 2010 2:34 PM (in response to sth_)
    did you do the aperture update that came out yesterday ?
    macbook pro core 2 duo, Mac OS X (10.5.1), lovin it !
  • sth_ Calculating status...
    Currently Being Moderated
    Feb 25, 2010 2:46 PM (in response to sebastienb)
    Yes, running Aperture 3.0.1 on Mac OS X 10.6.2.
    MacBook Pro, Mac OS X (10.6.2)
  • Ray Gibson Calculating status...
    Currently Being Moderated
    Feb 25, 2010 4:08 PM (in response to sth_)
    I have a mac pro with 8gb ram and the ATI 2600 graphics card and have had similar issues with A3 and previously in A2. The other day I had the scrambled picture effects seen in this discussion and oddly had a sudden pop-up telling me that my graphics card is "not compatible with this version of aperture". anyone else had this warning? most of the time things work fine - even after that warning.

    not had time to test the 3.0.1 yet
    mac pro, Mac OS X (10.6.2)
  • the_lost_prophet Calculating status...
    Currently Being Moderated
    Feb 26, 2010 11:40 AM (in response to Ray Gibson)
    Update installed... Not A SINGLE improvement concerning glitches... **** Aperture 3 ! The trial period will end without being able to use it more than 5 minutes...
    Macbook Pro 15", Mac OS X (10.6.2)
  • nz_doun Calculating status...
    Currently Being Moderated
    Feb 26, 2010 12:16 PM (in response to de_ho_se)
    Same issue here - only on Aperture 3.01. No problems on Aperture 2, CS4 or any oher application. Running 3.01 on my iMac 2gHz Core2Duo.

    A3 is not usable for me. The application is also very sluggish compared to CS4 even with faces and places turned off, preview set to screen size etc.

    I would love to use it because I love the workflow and integration with the OS. Very poor effort from Apple here - what a shame.
    Mac OS X (10.6.2)
  • Jonathan Reynolds Calculating status...
    Currently Being Moderated
    Feb 26, 2010 12:31 PM (in response to lovinmymac)
    I get similar psychedelic previews on my iMac with NVIDIA GeForce GT 130 graphics card, if I get a preview at all - most of the time the machine just hangs when I try to update the Preview on an image. This seems to be associated with the number of retouch strokes on the image concerned; unretouched images are OK.

    For me, the psychedelic problem is new to A3. The hung edit problem also occurred with A2, but only since installing SL.
    iMac, Mac OS X (10.6.2), Snow Leopard
  • Ray Gibson Level 1 Level 1 (15 points)
    Currently Being Moderated
    Feb 26, 2010 2:11 PM (in response to Jonathan Reynolds)
    strange this. Having tested with the 3.0.1 update now things are stabilised. I was having problems (hangs, crashes, time lags, scrambled images, etc) every time I opened aperture 3 (less frequently but nonetheless annoying in A2) but fingers crossed so far things are definitely getting better after the update - and I deliberately did some intensive retouching and brushing at a large magnification)
    mac pro 8gb RAM; ATI 2600 graphics, Mac OS X (10.6.2)
  • alanman Calculating status...
    Currently Being Moderated
    Feb 26, 2010 3:28 PM (in response to de_ho_se)
    would you guys say i have the same problem?
    seems worse in my case. this happens when i try to import RAW into aperture 3.

    http://img716.imageshack.us/img716/5387/screenshot20100226at617.png

    i can upload using canons eos util fine.

    Message was edited by: alanman
    Macbook Pro, Mac OS X (10.6.2)
  • macwiz1220 Level 4 Level 4 (1,940 points)
    Currently Being Moderated
    Feb 26, 2010 3:39 PM (in response to de_ho_se)
    I shoot NEF RAW (Nikon) and have no issues whatsoever. As of the 3.0.1 update I can apply presets, brushes, etc... without any issues. System configuration below.
     17" MBP5,2 (Early 2009), 2.93GHz, 4GB RAM, 320GB 7200RPM HD, Glossy , Mac OS X (10.6.2),  PowerBook G4 12'', 512MB DDR2 RAM, 1.5GHz PowerPC G4+ iPhone 3G 16GB Black
  • Phil Townsend Calculating status...
    Currently Being Moderated
    Feb 26, 2010 9:22 PM (in response to macwiz1220)
    Similar graphics problems as others have stated, BUT only after I installed the Feb 26/2010 RAW updater from Apple via Software Update. I am using Aperture v3.01. The MBP has the GeForce 8600M GT video chipset installed. The RAW photos being damaged are of NIKON NEF format. I've never had a problem of this type before using Aperture 2. The Aperture library is on the MBP internal hard drive, the image files are on a stand alone drive.

    When I choose a RAW file to edit, I get the message in the Adjustments panel that: "The photo was adjusted using an earlier version of Apple's RAW processing." If I click on the "Reprocess" button, the file becomes damaged. The photos were taken with a NIKON D80 which has been using an Apple RAW convertor for several years now.
    MacBook Pro 2.6GHz/4GB, Mac OS X 10.6.3
  • the_lost_prophet Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 28, 2010 3:57 AM (in response to Phil Townsend)
    Now with the update, Aperture is crashing on top of the glitches problem... It's going better and better...
    Macbook Pro 15", Mac OS X (10.6.2)
  • lastefan Calculating status...
    Currently Being Moderated
    Feb 28, 2010 5:14 AM (in response to de_ho_se)
    I have the same issue with graphic glitches since upgrading to Snow Leopard. It is visible so far i iPhoto 8 and Aperture 3. This was never an issue before Snow Leopard. I to have an iMac 2,16 C2D with the ATI X1600 graphics card which seems to be one common issue together with Snow Leopard.
    iMac C2D 2.1GHz, Mac OS X (10.6.2), 3GB RAM, 250+160GB HDD, ATI X1600 128VRAM, 750GB TimeMachine
  • blackmtnside Calculating status...
    Currently Being Moderated
    Mar 4, 2010 8:16 AM (in response to sth_)
    This problem has been driving me crazy the last week and I finally stumbled on this thread. I have had graphic glitches in Aperture 3 ever since I've installed it and they have continued regardless of the released updates. It seems to happen on every second image that I apply adjustments to. I have noticed it seems more common when using the "Definition" or "Vibrance" sliders, and it renders the brushes unusable, but I have also noticed it occurring on other adjustments as well, just less frequently. The only work-around I have found is to edit in full-screen view, but I only tried that on a few images last night so this might not work either.

    Hope you get this ironed out Apple! I know you'd love me to toss this old iMac and get a new one, but I still don't see a reason to do that yet until you bring in Blueray and bring back a matte screen option.

    Edit: just wanted to mention that I never had this problem in Aperture 2.1.4 under Snow Leopard - the only place this occurs is AP3.

    Specs of computer in sig.

    Message was edited by: blackmtnside
    20" iMac 2.0ghz Core Duo, Mac OS X (10.6.2), ATI x1600, 2 GB 667mhz SDRAM
  • tombec Calculating status...
    Currently Being Moderated
    Mar 11, 2010 6:17 AM (in response to de_ho_se)
    Same issues here. Awful. I never used A2, I just purchased A3 and Snow Leopard for my new Canon 7D. It works great for organizing photos, but I can't edit anything in any view without major glitches. Exported images seem to be ok, it's working with them in A3 that doesn't work.

    I absolutely can't by a new Mac to fix this. I have the same setup that a lot of you seem to have on here...

    Please fix this! Waste of money so far.
    iMac 5,1 Intel Core 2 Duo 2.16 Ghz, 2 Gigs SDRAM, ATI Radeon X1600, Mac OS X (10.6.2)
  • alienist Calculating status...
    Currently Being Moderated
    Mar 11, 2010 7:13 AM (in response to tombec)
    I can't believe they didn't pick this up in testing (or perhaps they did and just don't care about users on anything other than the latest equipment.)

    Luckily I tried the 30 day trial before purchasing. You should be able to get a refund but it would be better if they fixed it.
    iMac 5,1 20" 2GB, Mac OS X (10.6.2), ATI X1600 128Mb

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.