1 2 Previous Next 20 Replies Latest reply: Feb 28, 2010 10:15 PM by John Purlia Go to original post
  • 15. Re: 3.0.1 a huge step dow for me
    RoddyC Level 1 Level 1 (0 points)
    Hi John

    Sorry I can't help on that front but I wonder if you rebuilt the library again maybe that will reset what Aperture opens as the initial image. Not much help and I'm sure you considered it. To be honest I really wanted to thank you. I had exactly the same issues as you (not helped by some "experts" putting it down to lack of ram, etc) but didn't realise it was a specific image, as the image causing the problems was the first one selected whenever I restarted, so the fault seemed across every image.

    Your suggestion it was a specific image was spot on and I generated a "new version from master" ones I found the offender and deleted the offending image and all is well. Still doesn't alter the fact Aperture 3.0 has been a disgrace. Like you, I have worked in IT development for 25 years and am appalled by the way they have released A3 & 3.0.1. It's their software that corrupted my offending image after all. I was even threatening Lightroom a few hours ago (actually downloaded the Beta) but I just don't like the interface so was loathed to go that route.

    If you are still having issues log a call with Apple Support. As you purchased A3 for cash you are entitled to support for it under warranty on the phone. That's what I did with my initial A3 issues and they gave me workarounds over the phone. Hope you get it sorted. Thanks again, good call.

    Roddy
  • 16. Re: 3.0.1 a huge step dow for me
    Coqui- Level 1 Level 1 (20 points)
    I had my issues with 3.0.0 and while some were fixed others popped out with 3.0.1. At the moment the program is relatively stable, but I am starting to see issues where I can't switch from one image to the other.

    I would not consider this release a beta release. Maybe an alpha, at best. Specially when you consider this to be a "professional" program. This program is not in need of a 3.0.x release. Instead it is in desperate need of a 3.1 release, followed quickly by a 3.2 release. Too many bugs to fix.

    I am sure (well at least hope) Apple will eventually fix the issue, but all in all, a very disappointing experience.
  • 17. Re: 3.0.1 a huge step dow for me
    shane zatezalo Level 1 Level 1 (30 points)
    John, try holding down shift/alt/cmd when you launch Aperture.

    Also, make sure you don't have anything in ~/Library (esp the cache directory) named Aperture.

    One thing I would suggest. If you can isolate those one or two corrupt images - even if you can get them out of Aperture's data by hand, file a bug report with Apple and attach those two images to the report.

    I have had "corrupt" images in prior Aperture libraries (from prior versions of Aperture, not v3). It wasn't fun and was totally frustrating. I never did figure out where the corruption actually came from. But once I got them out, Aperture was fine. And I never took the time to send them in as a bug report (I know, tisk tisk). Maybe if I had people now would have less problems. Regardless, even if an image file is corrupt, no matter what the source, the application shouldn't crash on it. IMHO that's a bug and it needs fixed.

    http://bugreport.apple.com/
  • 18. Re: 3.0.1 a huge step dow for me
    Abbstrack Level 1 Level 1 (35 points)
    i am observing a similar though not identical problem. This is the same problem that plagued me during when I was using 3.0 however, that caused me to rebuild and lose my entire library, forcing me to restart my whole upgrade process from a backup (turned out to be a 40 hour process).

    When I select certain images within certain projects, the images in the browser do not match the thumbnails. I have noticed this occurring mostly with scanned film images (I have not yet seen it happen with RAW files). my only resolution when I experienced this a week or so ago was to delete the file. no amount of thumbnail generation, or reconnecting masters would solve the problem.

    even exporting just the project as a library and rebuilding it does not solve the issue. not sure where the disconnect is.
  • 19. Re: 3.0.1 a huge step dow for me
    b.bingham Level 1 Level 1 (0 points)
    Hold the Option key while launching.

    Do you have more than two libraries? If so, the resulting window will allow you to pick another library. If not, create a new one from this same window ("Create New" button, bottom right). Select the Main Projects view from this new library, then use the File>Switch To Library command to get back to your old, main library. With luck, you should be in the Projects view. From the new library, you might try setting Quick Preview, then reopen the problem database. Of course, that would assume the thumbnail is not the source of the corruption, so I'm not sure there's an advantage there.

    I don't think Option-Shift-Command is a key combination for anything (Zane's post, this thread). Option-Command is the combination to repair/rebuild/consistency check the database; adding Shift doesn't change it.

    You could muck about in the Aperture Library database ("Show Package Contents…" from the context menu; usual cautions of having backups here). Drag the Thumbnails or Previews folder to your desktop (one or the other at a time), and try to relaunch then (guessing that a corrupt thumbnail/preview is the problem). If you suspect a bad preview, "Select All" and "Delete Previews" for killing off all your previews, from within Aperture's main photo view. Then rebuild all previews, or only the ones you need, as you need (this is how I use it). Or, if you know the file name/number, find that raw and drag it out of the library package ("Masters" folder in the package, but good luck finding it in that maze of a hierarchy… I much preferred the old package build). Rebuild the database after any mucking (Cmd-Opt double-click the database). Suspecting a corrupt file could hold the idea of bad-blocks in the back your mind also: Disk Utility, ProSoft's Drive Genius or equivalent.

    Good luck. I'll be curious to see how this works out.

    Bob
  • 20. Re: 3.0.1 a huge step dow for me
    John Purlia Level 1 Level 1 (70 points)
    I managed to get the problem fixed, though I wouldn't call it "solved". After a lot of trial and error, which involved completely trashing Aperture, reinstalling from 2.0, digging out my original 1.x serial number, verifying that all my 2.1.4 projects were fine, reinstalling 3.0 as a clean install, applying the 3.0.1 update, and importing projects one at a time...

    I discovered that the 3.0.1 import function consistently corrupts two of my 2.1.4 photos (one of which happened to be the very photo I was interested in when first applying the 3.0.1 patch - bad luck!). One corruption causes the disappearing or "stuck" adjustments panel in the main window. The other is the source of a hard crash of Aperture each time that photo is selected. Why the corruption occurs on these two photos is not entirely clear, though I strongly suspect it has something to do with the combination of adjustments that were originally applied to those photos (which are JPEGs, and were originally adjusted with version 1.x). Moreover, both of these photos include judicious use of spot'n'patch adjustments (before we had the much improved retouch tool in 2.0). My guess is that not a lot of attention has been paid towards the compatibility of spot'n'patch with the 3.0 importer.

    I've filed a very detailed bug report with Apple, with the offer to provide to them the project (just 40 images) that becomes corrupted each time it is imported to 3.0.1. Entirely reproducible, and hopefully this will lead them to a rapid solution because photos — regardless of the version of Aperture from which they originated — must always remain compatible with new versions of the software. Photos are permanent records, and on the computer should be every bit as timeless as old snapshots.

    Thanks for all the recommendations people on this thread, they were all very helpful!

    John
1 2 Previous Next