Skip navigation
This discussion is archived

Touchpad & occasionally keyboard freeze since Snow Leopard upgrade

12276 Views 24 Replies Latest reply: Oct 25, 2010 8:15 PM by BlueMeanie RSS
1 2 Previous Next
EmileVictor Calculating status...
Currently Being Moderated
Sep 1, 2009 10:27 PM
Hi guys,

I'm rather lost; my macbook pro's touch pad seems to freeze every few minutes; I thought it was a hardware issue, but sometimes it stores up the previous few second's movements and plays then back 3x the speed when it starts working again.

I have no idea what the deal is. What is the suggested course of action?
Macbook Pro, Mac OS X (10.6)
  • jsargent Calculating status...
    I'm starting to have a similar issue on my Mac Pro with the Apple aluminum wired keyboard. I notice it primarily when switching between Spaces.

    I use Control+Arrow keys to move between spaces, and after a few hours of uptime, I switch spaces and the Spaces interface stays locked on the screen for several minutes. During that time my keyboard is completely inoperable EXCEPT that I can continue switching between spaces the entire time. I just can't do anything else. The mouse still works perfectly as well.

    Just reset my PRAM, so we'll see if that helps, but I'm not optimistic at this point.
    Mac Pro (Early 2008), Mac OS X (10.6)
  • Johnmarshall4 Calculating status...
    I have the exact same keyboard problem since upgrading to snow leopard. I use 'alt'-number to switch spaces. It gets stuck with the icon on the screen and can only switch spaces but cannot type anything else. I have to reboot it. I am downloading the latest update and hope it helps.
    MacBook pro early 2008, Mac OS X (10.6), 4g ram, 320 hd
  • Johnmarshall4 Level 1 Level 1 (0 points)
    Well the latest SL updates didn't help. It just locked up again switching spaces. Someone help please.
    MacBook pro early 2008, Mac OS X (10.6), 4g ram, 320 hd
  • jsargent Level 1 Level 1 (0 points)
    Status Update:

    After resetting my PRAM, as mentioned above, the occurrence of this problem on my Mac Pro seems to be much less frequent, but still occurs occasionally...and it is SUPREMELY annoying to be forced to reboot because of this! And now I have been regularly having the exact same issue on my brand new 15" MacBook Pro.

    About to reset the PRAM now, as it seems Apple has yet to offer any explanation or fix. C'mon guys! I seriously don't understand how Apple ranks so highly in those customer support surveys...they're always completely silent on issues like this until they suddenly get fixed with zero communication. Drives me nuts!
    MacBook Pro 15", Mac OS X (10.6.1), Spaces
  • Scollk Calculating status...
    I have also been experiencing this problem. I use Ctrl+1/2/3/4 to switch between Spaces. It's VERY annoying. It often requires a reboot (sometimes a forced reboot by taking out the battery). I am considering going back down to Leopard because of this.

    I feel like i'm missing an arm when I don't have proper use of my Spaces
    Macbook, Mac OS X (10.6.1)
  • stvelucky Level 1 Level 1 (5 points)
    I've had a similar problem and have found a workaround, though not a fix. Go into System Preference and click on Expose and Spaces. In one of the active screen corners choose "Sleep Display". When the spaces icon gets stuck at the bottom, move your mouse to this corner and put your display to sleep. When you move your mouse it will wake up your screen and everything should be cool. I hope this works.
    iMac CoreDuo, Mac OS X (10.6.2)
  • jjurkiewicz Calculating status...
    I've exactly the same issue: while trying to switch to Space 1 by hitting Ctrl+1 my keyboard freezes, I can use mouse though and I can see the small spaces switcher window.
    Getting the monitor to sleep is a workaround, but I'm expecting a fix as this makes my work less productive.
    MacBook Pro 13, Mac OS X (10.6.2)
  • Rod Hagen Level 7 Level 7 (31,985 points)
    It is very hard to see the connection between the "follow up"posts in this thread and the problem of the original poster. He / she was talking about a general keyboard/ trackpad issue, quite possibly of a hardware nature

    Everyone else seems to be just talking about issues specific to "Spaces"! Some posters aren't using an MBP (the focus of this particular forum) and some, again, are unfortunately talking about suffering the "exact same problem" as the original poster, when it is patently clear that they don't!

    There are, of course, many reasons why people may experience a slowdown of one kind or another in any given situation, but I very much doubt that there is any connection at all between the OPs MBP related trackpad issue and any of the other matters raised in this thread wrt Spaces!

    I realise that most of the posters here are very new arrivals (with a couple of others with a handful of posts), but "Spaces" issues are really far better dealt with in the Snow leopard forums than here., and if people believe there is some special MBP question involved they would be far better advised to start a new thread detailing their issues in much more detail, rather than "me tooing" on top of a thread that at face value seems to involve a different issue (and often hardware, as well) altogether!

    Cheeers

    Rod
    MBP 13"2.26, MBP15"2.2, iMacG520"RevB , MB2CD, MBCD, ,PM5400/180 & earlier, Mac OS X (10.6.2), 7 chooks, 2 dogs, 2 daughters, 1 pear tree, 0 partridges, itinerant bats, magpie
  • Irradiated Calculating status...
    I have a software product named Cinch by Irradiated Software. I've been receiving reports of this issue in when my app is running. Can anyone here confirm that they are running Cinch, or any other application the works with the mouse/trackpad (MagicPrefs, Zooom/2, etc)?

    Regards,
    Steve
  • John Chandler Calculating status...
    Steve,
    I'm using Cinch and having this problem. It does seem to be more frequent since I've been trying Cinch out, though I did have this problem on occasion prior to trying Cinch. (Great app by the way!)
    MBP 13", Mac OS X (10.6.2)
  • geminate2 Calculating status...
    I have the same problem. I am usually in Safari 4.0.5 and the touchpad will just stop working. If I wait about 5 seconds it will start working again. The only software I am running is Safari and Mail most of the time. This is not happening to me after waking from Sleep. My keyboard and power button seem to work fine when the touchpad is locked up.

    I'm also having problems where the keyboard sometimes thinks that a key is being held down so I figure the USB controller is having problems or something. I have already tried reseating the ribbon to the motherboard with no luck.
    2.4GHz iC2Duo Macbook Pro, Mac OS X (10.6.3), None
  • kostjazz Calculating status...
    I have exact same issue with my mbp... Was working absolutely fine before the upgrade.
    Macbook Pro, Mac OS X (10.6.3)
  • ABlinov Level 1 Level 1 (10 points)
    One more workaround for this kind of problem is to force quit Dock.
    I have some freezes too but my touchpad/mouse works fine. So i can launch Activity Monitor and Force Quit Dock. After killing Dock - everything becomes OK.
    PowerBook 17", Mac OS X (10.6.3), 2.8GHz C2Duo 4GB 1067 MHz DDR3
  • telmodias Calculating status...
    On this other thread: http://discussions.info.apple.com/thread.jspa?threadID=2383403 user cater alerted to this patch which apparently solves the problem - 10.6.3 (v 1.1) combo updater.

    You can find it here: http://support.apple.com/kb/dl1017

    Still downloading so not sure if it works or not, but it seems like a good thing to do.

    Cheers!
    Macbook Pro 15", Mac OS X (10.6.3)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.