Skip navigation
This discussion is archived

Palm Treo calendar has stopped syncing with iCal

3044 Views 6 Replies Latest reply: Mar 4, 2010 6:23 PM by Michael Lafferty RSS
Spider Silk Design Calculating status...
Currently Being Moderated
Jan 22, 2010 2:25 AM
I have a Palm Treo 650 and an Intel iMac runing OS X 10.4.11. I've had both for a few years, and I've always been able to sync them with no problems using the iSync conduit when doing a Hot Sync from the Palm. But suddenly I'm finding that, while it appears to be syncing fine and doesn't display any error messages, iCal is not being updated with new events from the Palm calendar.

Tonight is the first time I've encountered this, but it's also the the first time I've been able to sync at all in a while, because for the last few weeks, every time I've tried, I've gotten an error due to having too much data on the Palm - which is a catch-22 in that I didn't want to delete anything without being able to do a backup, but couldn't do a backup without deleting things first. But finally I took the plunge tonight and deleted a bunch of things. And it seemed like it synced OK - except that no new events turned up in iCal.

I've tried several times, and I've checked my settings in both iSync and the HotSync Manager to make sure they were OK. I read through some support articles on here (although most of them seemed to deal only with 10.5 and 10.6) and tried re-enabling Palm syncing in iCal, resetting my sync history, and quitting iCal, clearing the cache folders, and restarting it, but still no go.

The little mini-report you see at the end of a HotSync always says the iSync conduit ran OK, but if I look in the log itself, I see this:

iSync Conduit: received NULL message, disconnecting... 1/22/10 4:43:48 AM
OK iSync Conduit

So it seems like it is encountering some sort of problem with iSync, but is then reporting it OK anyway? The iSync log doesn't show any errors at all. Another odd thing I noticed is that if I have iSync open while I'm hot syncing, iSync seems to be finished while Hot Sync is still working on the Datebook, even though theoretically it should be iSync that's handling that.

Does anyone have any idea what might be going on here? Or anything else I might try in the way of troubleshooting?
iMac 20" - 2.16 GHz Intel Core 2 Duo, Mac OS X (10.4.11)
  • Michael Lafferty Level 6 Level 6 (16,080 points)
    Can you post a list of the conduits which are present in the active Conduits Folder, and a list of those which are deactivated and present in the Disabled Conduits folder?
    PowerBook G4 12 inch 1.5 GHz 1280 meg 80 gig SuperDrive, Mac OS X (10.4.11), coupled with a UMA-capable Nokia 7510 Supernova and T-Mobile HotSpotâ„¢ @Home
  • Michael Lafferty Level 6 Level 6 (16,080 points)
    The conduit Apple is the iSync Palm Conduit: that's its Finder name. In the HotSync Manager it appears as iSync Conduit and in most documentation, it is referred to as the iSync Palm Conduit. One process: three names.

    The conduits are appropriately stored in the proper folders. I asked, because what you described suggested that you had the iSync Palm Conduit active but used only to synchronize contacts, and either or both of the standard Palm event and task conduits—Calendar Conduit and/or Datebook Conduit and Tasks Conduit and/or Tasks Conduit—activated. That's not the case.

    There are many thing which can cause the null issue to arise. Chief among them is a lack of available storage space on your Palm device itself. Typically this can only be corrected by overwriting the contents of your organizer by initiating a first time synchronization and selecting that option, following a reset of the synchronization framework on your Macintosh.

    You mentioned two machines - are you synchronizing your Palm device with BOTH, or with just one of these platforms? The synchronization to multiple platforms may also result in the sort of issue that you are seeing.
    PowerBook G4 12 inch 1.5 GHz 1280 meg 80 gig SuperDrive, Mac OS X (10.4.11), coupled with a UMA-capable Nokia 7510 Supernova and T-Mobile HotSpotâ„¢ @Home
  • tmaddry Calculating status...
    I am having a similar problem. My Palm Treo Centro has stopped syncing with my iCal (neither direction works). My device has plenty of space, 84M out of 128M. I've tried disabling calendar syncing in iSync and then disabling iSync entirely for the device. No change.

    Error log shows a problem opening the DB:

    SyncOpenDB returned 16388 for database DatebookDB, creating a new database 2/23/10 10:44:42 AM
    Warning: Could not create database DatebookDB (return code 16395), ignoring database 2/23/10 10:44:42 AM
    iSync Conduit: Got back NULL from rendezvous for request BladeGetAllRecords 2/23/10 10:44:42 AM
    iSync Conduit: Sending Error Response 1: iSync Conduit: Could not find database DatebookDB 2/23/10 10:44:42 AM
    iSync Conduit: received NULL message, disconnecting... 2/23/10 10:44:42 AM
    Macbook Pro, Mac OS X (10.5.8), intel 2.2 Ghz / 2G ram
  • Michael Lafferty Level 6 Level 6 (16,080 points)
    Currently Being Moderated
    Mar 4, 2010 6:23 PM (in response to tmaddry)
    Actually, your particular issue is very likely completely unrelated to this thread. Please start a new thread and repost your question.

    Please indicate in that reposted message if you, as your footer indicates, are using Mac OS X 10.5.x and the identify of your wireless provider.
    PowerBook G4 12 inch 1.5 GHz 1280 meg 80 gig SuperDrive, Mac OS X (10.4.11), coupled with a UMA-capable Nokia 7510 Supernova and T-Mobile HotSpotâ„¢ @Home


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.