5 Replies Latest reply: Mar 19, 2010 11:36 AM by Windows7Guy
Windcomfort Level 1 Level 1 (0 points)
I using Apple Magic Mouse on Windows 7. But I found there are some problems when I use this mouse play WOW.

1). Some time right click will stop auto-run.
2). When I didn't use mouse few second. The mouse will "sleep" for save power I think. I have to click mouse to wake it up. But it will make mistake sometimes. I have disable power management for Bluetooth Radio. But seems it still not work.

Anyone have the same problem?

MAC PRO, Mac OS X (10.5.6)
  • 1. Re: Magic Mouse, Windows 7, World of Warcraft
    notasailorboy Level 1 Level 1 (0 points)
    yes, the magic mouse doesn't work that well on windows 7 using the boot camp drivers, if you uninstall the wireless mouse driver, it will be more precise, not have latency issues and wont "fall asleep" but you will not be able to scroll on the mouse.

    wait for apple to update boot camp for windows 7 (it's supposed to be coming soon) and the drivers will be available then.

    p.s. stop playing WOW, it's for bozos.
  • 2. Re: Magic Mouse, Windows 7, World of Warcraft
    mjy78 Level 1 Level 1 (0 points)
    The sleepy mouse problem in Windows 7 is not a problem with the magic mouse driver. It's a Windows 7 bluetooth setting that's easily resolved. Actually "easily" might not be the best word to describe it...

    1. Click on the "Bluetooth Devices" blue icon in the system tray (you'll probably need to click that little UP arrow first) and choose "Open Settings" from the menu.
    2. Under the "Hardware" tab of the resulting dialog, select the "Apple Built-in Bluetooth" device and click the "Properties" button on the lower right.
    3. Under the "General" tab in the resulting dialog, click the "Change Settings" button on the lower left (it has a shield icon on it)
    4. Under the "Power Management" tab in the resulting dialog untick the "Allow the computer to turn off this device to save power" checkbox.
    5. Press OK, OK and OK.

    Hey Presto! Windows 7 will no longer put your shiny new magic mouse to sleep and it will be just as responsive in Windows 7 as it is in its native home land :o)
  • 3. Re: Magic Mouse, Windows 7, World of Warcraft
    RLBurkes Level 1 Level 1 (0 points)
    Thanks, that defo did the trick. I am not sure why Microsoft would enable such an annoying feature out of the box, not to mention nest it in 3 sub windows making it hard to find in order to disable.
  • 4. Re: Magic Mouse, Windows 7, World of Warcraft
    Joe Winke Level 1 Level 1 (0 points)
    You are the man! That worked perfectly and made the scrolling 5x better too! Thanks for the detail.
  • 5. Re: Magic Mouse, Windows 7, World of Warcraft
    Windows7Guy Level 1 Level 1 (0 points)
    Hello mjy78,

    Just an FYI for you.

    It is always best to check with the software manufacturer FIRST. They will tell you if they have tested the product and the version, as well as whether or not it will work with Windows 7.
    Check out the Windows 7 Compatibility site: (There you will find out about hardware and software compatibility.)
    http://www.microsoft.com/windows/compatibility/en-us/default.aspx
    There is a pulldown from which you can choose "hardware" and "software".

    There are also some great articles, instructional videos and such to help with your Windows 7 at our Springboard site:
    http://technet.microsoft.com/en-us/windows/default.aspx

    In any event a lot of the times, Vista drivers will work in lieu of Windows 7 drivers, however, it's not 100%!

    As stated previously, it's best to have the Windows 7 certified drivers installed.
    Thanks again,
    John M.
    Microsoft Windows Client Support